What is wrong w/ the Auto Organize feature in v4?

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: What is wrong w/ the Auto Organize feature in v4?

Re: What is wrong w/ the Auto Organize feature in v4?

by nohitter151 » Wed Jan 11, 2012 3:36 pm

Spudnubber wrote:
Spudnubber wrote:The rule I have is:
______________________
Criteria- Collection:Music Video
Directory- H:\MEDIA\VIDEO\MUSIC VIDEO\
File Format- <Album Artist>\ $Left(<Title>,50)
(The directory of my "Music" and "Classical Music" collections is H:\MEDIA\MUSIC)

The only collection that has problems is "Music Video". I believe it works when I 'manually' auto-organize music video files but they get moved by the "Auto-Organize rules" into the music folder (H:\MEDIA\MUSIC).
The Music collection also includes Music videos by default. That is probably your problem. Just edit the Music collection so that it does not also include music videos.

Re: What is wrong w/ the Auto Organize feature in v4?

by Lowlander » Wed Jan 11, 2012 3:29 pm

I don't see anything wrong with the rule so maybe the files match other rules as well?

Re: What is wrong w/ the Auto Organize feature in v4?

by Spudnubber » Wed Jan 11, 2012 3:27 pm

The rule I have is:
Criteria Directory File Format
Collection:Music Video H:\MEDIA\VIDEO\MUSIC VIDEO\ <Album Artist>\ $Left(<Title>,50)
(The directory of my "Music" and "Classical Music" collections is H:\MEDIA\MUSIC)

The only collection that has problems is "Music Video". I believe it works when I 'manually' auto-organize music video files but they get moved by the "Auto-Organize rules" into the music folder (H:\MEDIA\MUSIC).

Re: What is wrong w/ the Auto Organize feature in v4?

by Lowlander » Tue Jan 10, 2012 11:31 pm

Perhaps there is a mistake in the rule? What rule are you using?

Re: What is wrong w/ the Auto Organize feature in v4?

by Spudnubber » Tue Jan 10, 2012 10:13 pm

How come music videos end up auto-organized with music when I specifically set a rule to have them auto-organized in a different folder?

Re: What is wrong w/ the Auto Organize feature in v4?

by Spudnubber » Tue Dec 20, 2011 11:17 pm

Awesome, Thank you!

Re: What is wrong w/ the Auto Organize feature in v4?

by Lowlander » Tue Dec 20, 2011 11:10 pm

255 is the limit. Generally you wouldn't use <Filename> but use something like $Left(<Artist>,50) - <Track#> - $Left(<Title>,50)

For more see: http://www.mediamonkey.com/wiki/index.p ... ormats/4.0

Re: What is wrong w/ the Auto Organize feature in v4?

by Spudnubber » Tue Dec 20, 2011 10:37 pm

Is there a way to define what the "<Filename>" field is when auto-organizing? I just would like the file names to be up to date and in the correct format/directory, which is already in place. "<Filename:n>" is the only way I know to limit the length of file names. I just have a few songs with really long names and I have heard it is good to keep file names in windows under 64 characters or so.

Or is this not necessary if my library is either already organized in the format/directory I want or MediaMonkey "Automatically Organizes Files (during scans or edits)"

Thanks

Re: What is wrong w/ the Auto Organize feature in v4?

by jalan » Sun Dec 18, 2011 11:06 am

Wow, duh! Thanks - that was it.

Re: What is wrong w/ the Auto Organize feature in v4?

by BKKKPewsey » Sat Dec 17, 2011 7:20 pm

What is your destination mask?
are you using <artist> or <album artist>?

I have auto organised about 2000 tracks in MM4 so far and the results, with my mask, are exactly the same as with MM3.
:-?

What is wrong w/ the Auto Organize feature in v4?

by jalan » Sat Dec 17, 2011 6:23 pm

I have used MediaMonkey for years so I am familiar with the AutoOrganize feature. I always get my tags right, then I auto-organize the files based on them by using the CRTL R feature.

Ever since updating to v4, it just simply isn't working consistently. Often the results will be as predicted and other times it simple won't do anything.

Here is an example:

Image

As you can see, the first track is named "Take a Chance on Me" and the artist is "Mamma Mia" as is the album. My organization method is ARTIST\ALBUM
\TRACK_TITLE. As you can see, the path at the right, the organization artist is VARIOUS ARTISTS instead. See the track HONEY HONEY, which is from a different MAMA MIA album. In that case, the organization artist is MELISSA GIBSON instead of VARIOUS ARTISTS. However, the track above that, OVERTURE/PROLOGUE is perfect.

Now look at the organization window for the track HONEY HONEY here:

Image

It suggests no changes to the organization despite the library and tags being different from the currently organized structure.

Finally, here is the same HONEY HONEY track in Windows:

Image

This confirms that the files tags matches the MediaMonkey library for the ARTIST field which should be VARIOUS ARTISTS but MediaMonkey is just plain ignoring that when organizing. This is happening with hundreds of tracks so far that I've found in my collection of 4400.

Any ideas?

Top