Can't set MM as the default media player

Post a reply

Visual Confirmation

To prevent automated access and spam, you are required to confirm that you are human. Please place a check mark next to all images of monkeys or apes. If you cannot see any images, please contact the Board Administrator.

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: Can't set MM as the default media player

Re: Can't set MM as the default media player

Post by nonob » Wed May 16, 2012 7:13 am

Hi, thanks for this tip, i had a file association pb, i fixed it by uninstalling my MediaMonkey_4.0.3.1476, install a older release (MediaMonkey_4.0.0.1459), then by reinstalling the 1476.

Thanks

Re: Can't set MM as the default media player

Post by GzyOnline » Sun Mar 25, 2012 2:11 pm

MaxiM wrote:Ha! Update on the subject at hand.

Instead of further messing with registry, i've decided to find the oldest MM4 release, which was 4.0.1.1461. Uninstalled the 4.0.3 one, installed the oldie, and *ta-dam* it works. MM is now listed under Default Programs, it assotiates the files via Options no problem, all music registered files have their proper icons and so on. Seems to me that 4.0.3 installer is broken. Should be fairly easy to fix, but for pete's sake, do it. I know many less patient people who would uninstall this program and never come back after encountering something like this. And there's a saying that applies to this: 1 happy customer will bring 10 more; 1 unhappy customer will deter other 100 ;)

My system info just in case it's helpful: Windows 7 Enterprise 64-bit (6.1, Built 7601), Service Pack 1, GENUINE (not some pirated crap of unknown origin).

EDIT: Installing 4.0.3 over 4.0.1 also worked. Maybe many of you didn't noticed the problem because you started with the older version and upgraded.


Hey, this helped! Thank yoU!!.. This certainly is a bug in the latest MM 4.x release and developers should make note of this.. I installed MediaMonkey_4.0.3.1476 on a fresh Windows 7 64-bit OS install and the context menus, when selecting songs to play in Windows Explorer, have never come up.. How very sad and odd, seeing how this was an amazing and desired feature of MM and to see it not working or have gone away is just terrible! So THANKS, MaxiM!, I did as you instructed.. I uninstalled MM 4.0.3.1476, installed MM 4.0.0.1459, checked to see if the context menus appeared, and (as you expressed above) *ta-da!*, they appeared!!.. :-D.. I then re-installed MM 4.0.3.1476 over MM 4.0.0.1459 and the menus still remain! Now, I have yet to restart my system but hopefully when I do, they will not have gone away!.. Thank yoU!! and here is a screen shot of what I'm referring to:

Image

Re: Can't set MM as the default media player

Post by tommycrock » Thu Mar 22, 2012 2:54 pm

Fair enough, do you not think it should be moved?

Re: Can't set MM as the default media player

Post by Lowlander » Thu Mar 22, 2012 11:05 am

No (viewtopic.php?f=1&t=40381), topics can be moved if needed.

Re: Can't set MM as the default media player

Post by tommycrock » Wed Mar 21, 2012 3:33 pm

Hi Lowlander

I was posting under bug reports so it would get noticed as a bug and entered into Mantis. Was that not the right thing to do?

Can't set MM as the default media player

Post by tommycrock » Mon Mar 19, 2012 4:09 pm

Having installed build 1473 from fresh I could no longer set MM as the default media player as discussed in this post. It turned out that installing an older version and then reinstalling the latest version fixed it for me and several people. For MaxiM file associations also weren't working.

Re: Can't set MM as the default media player

Post by MaxiM » Mon Mar 19, 2012 9:44 am

Have more faith in humanity Tommy, but I'm glad I could help you both (and myself in the process) ;)

Re: Can't set MM as the default media player

Post by tommycrock » Fri Mar 16, 2012 2:20 pm

Me too. Good work MaxiM and thanks steviegt for saying it worked otherwise I wouldn't have tried it! (sorry MaxiM :wink:)
Can someone stick this in Mantis please.
P.S. I used build 1461 too

Re: Can't set MM as the default media player

Post by steviegt » Wed Mar 14, 2012 4:10 pm

I have done as suggested and it does work. Is anyone going to make this a known problem that needs a fix in a future release? I would sure hate to have anyone double install to make MM work like it's supposed to.

Re: Can't set MM as the default media player

Post by MaxiM » Thu Mar 08, 2012 1:32 pm

Guys, as I said, try to install older 4.0.X release first (uninstall the one you have now ofc). It helped me, might as well help you.

Re: Can't set MM as the default media player

Post by steviegt » Wed Mar 07, 2012 8:52 pm

Correction to my previous post...I do have registry entried for MM. That was a brain fart. Everything else I have in that post is correct.

Re: Can't set MM as the default media player

Post by tommycrock » Wed Mar 07, 2012 2:11 pm

steviegt wrote: I also have no registry entries for MM and I am running v4.0.3.1476.
...
but MM still dows not show up as a program in Default Programs. Of course it does not shou up in Autoplay settings either.

Odd, I've got half of this problem, I have registry entries and didn't have any problems with file associations or autoplay but do have the default programs problem.

Re: Can't set MM as the default media player

Post by steviegt » Wed Mar 07, 2012 12:48 pm

I am running Win 7 HP 64bit. I also have no registry entries for MM and I am running v4.0.3.1476. I reinstalled Windows so I did a fresh install of MM. No portable install. Nothing to tweak to make MM the default player (os integration, file types etc) and none of the file types are associated with MM because MM isn't showing anywhere as being a program installed other than start menu and control panel>programs and features. If I play the mp3's in MM they play fine but if I double click on the mp3 outside of MM Windows Media Player opens and plays the mp3. I don't want to uninstall/reinstall an older version and then install over it. Is there a real official solution to this problem or an easier solution?

I associated MM by file type thru Control Panel>Default Programs>Associate by Filetype and now MM opens when 2x click on file outside of MM but MM still dows not show up as a program in Default Programs. Of course it does not shou up in Autoplay settings either.

Re: Can't set MM as the default media player

Post by MaxiM » Tue Mar 06, 2012 6:29 pm

Nope, not portable. I tried installing it many times to the same effect.

Re: Can't set MM as the default media player

Post by tommycrock » Tue Mar 06, 2012 1:04 pm

Hmm, the earliest one I installed was build 1473 because I reinstalled windows. Might you have done a portable install? That would explain having no registry entries.

Top