WASAPI not bypassing windows audio processing

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: WASAPI not bypassing windows audio processing

Re: WASAPI not bypassing windows audio processing

by nohitter151 » Wed Jun 11, 2014 3:47 pm

ashenkin wrote:Thanks lowlander. Exclusive mode fixes the issue (though switching devices doesn't). But, still, should this be the case?
Yes. Exclusive mode is necessary for bit-perfect output.

Re: WASAPI not bypassing windows audio processing

by ashenkin » Wed Jun 11, 2014 11:54 am

Thanks lowlander. Exclusive mode fixes the issue (though switching devices doesn't). But, still, should this be the case? Even operating in shared mode, shouldn't the audio streams bypass Windows messing with it? Isn't that the point of WASAPI? I realize this probably isn't MM's issue, but I figure that there are plenty of folks here qualified to address the question...

Re: WASAPI not bypassing windows audio processing

by Lowlander » Tue Jun 10, 2014 10:09 am

Not very familiar with this, but is exclusive mode enabled in the WASAPI plugin in MediaMonkey? Also check which audio device is selected in the WASAPI plugin.

WASAPI not bypassing windows audio processing

by ashenkin » Tue Jun 10, 2014 10:05 am

Hi Folks,

I have a Dell laptop, and it has "speaker enhancement" controllable via the Dell Audio app. Of course, I would like to completely bypass this when listening via mediamonkey on my nice headphones. I * could* just turn it off. However, it was a little disturbing to find that the audio was still being processed by this "speaker enhancement", even when MM was using the WASAPI output plugin.

Any idea what's going on here? Shouldn't WASAPI bypass all attempts by Windows to process the audio signal, and just pass it to the output DAC more-or-less directly?

Thanks in advance for your thoughts...

Win 7 Enterprise x64
MM 4.1.1.1703
WASAPI output plugin v 1.1
Dell M3800 with Waves MaxxAudio® Pro suite of advanced audio enhancement tools

Top