ExtractFields v0.1.4 [MM2+3]

Post a reply

Visual Confirmation

To prevent automated access and spam, you are required to confirm that you are human. Please place a check mark next to all images of monkeys or apes. If you cannot see any images, please contact the Board Administrator.

Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: ExtractFields v0.1.4 [MM2+3]

Re: ExtractFields v0.1.4 [MM2+3]

Post by MMFrLife » Thu Jul 23, 2015 6:56 pm

I love RegExp F&R, but this script would be great for occasional quick fixes. Unfortunately, it doesn't work properly. :(

Re: ExtractFields v0.1.4 [MM2+3]

Post by inpariswithyou » Thu Jul 23, 2015 3:53 pm

Never mind! I figured it out! (Gotta use Visual Basic, not regex.)

Re: ExtractFields v0.1.4 [MM2+3]

Post by inpariswithyou » Thu Jul 23, 2015 1:16 pm

nohitter151 wrote:No, the author hasn't made any updates since 2006. The RegExp plugin can do what you're looking for. viewtopic.php?f=2&t=28510&hilit=regexp


Took a look at the plugin and I'm a bit >_<.

Is there a way to combine fields? Basically I need to take <Conductor> and append it to <Title>... so that the new <Title> would look like <Title> [<Conductor>].

(I store remix titles in <Conductor>, but I have to migrate to iTunes, which requires that I include the remix as part of <Title> now. It's all very annoying, and iTunes is the devil... but we do what we must.)

Re: ExtractFields v0.1.4 [MM2+3]

Post by nohitter151 » Thu Jul 23, 2015 12:10 pm

inpariswithyou wrote:Has there been any work recently on this plugin?

It does exactly what I need -- but I need it to move the <Conductor> field, which is currently not a mask, to the end of <Title>. In a pinch I can make this happen via some intermediates, but I'd rather not.

Any thoughts?

No, the author hasn't made any updates since 2006. The RegExp plugin can do what you're looking for. viewtopic.php?f=2&t=28510&hilit=regexp

Re: ExtractFields v0.1.4 [MM2+3]

Post by inpariswithyou » Thu Jul 23, 2015 12:02 am

Has there been any work recently on this plugin?

It does exactly what I need -- but I need it to move the <Conductor> field, which is currently not a mask, to the end of <Title>. In a pinch I can make this happen via some intermediates, but I'd rather not.

Any thoughts?

Re: ExtractFields v0.1.4 [MM2+3]

Post by MMFrLife » Fri Apr 03, 2015 10:08 am

Is this stable in MM.v4?

When I do:
Title <-- <Filename>
It puts "%F" in the Title field (not the filename I have, btw).

Other fields seem to work, although I haven't tried them all.

Re: ExtractFields v0.1.4 [MM2+3]

Post by Guest » Tue Jul 02, 2013 2:42 pm

tbravery wrote:I'm trying to make my album fields display as <artist> - <album>. Is this possible with this script? Can someone show me how?

Somehow I made all my artist fields display as albums (I realized what it was doing and force closed mediamonkey to prevent it from doing further damage)

doublepost, but I figured it out. Sharing this to anyone that would like to do the same.


Album Name <- [<Artist>] <Album>

2 lines, serial

Re: ExtractFields v0.1.4 [MM2+3]

Post by tbravery » Tue Jul 02, 2013 2:28 pm

I'm trying to make my album fields display as <artist> - <album>. Is this possible with this script? Can someone show me how?

Somehow I made all my artist fields display as albums (I realized what it was doing and force closed mediamonkey to prevent it from doing further damage)

Re: ExtractFields v0.1.4 [MM2+3]

Post by sn0skier » Sat Jun 22, 2013 5:00 pm

Figured out why it wouldn't install. You need to put the script in C:\Users\Andrés\AppData\Roaming\MediaMonkey\Scripts\Auto and not in program files.

Re: ExtractFields v0.1.4 [MM2+3]

Post by sn0skier » Fri Jun 21, 2013 11:16 pm

seriously though that other script is stupid complicated. Completely not worth my time to learn, or most other people's. And his 200+ presets take forever to look through and usually don't have what I want. Please bring this script back from the dead.

Re: ExtractFields v0.1.4 [MM2+3]

Post by sn0skier » Fri Jun 21, 2013 10:52 pm

Does the manual install not work anymore? How should we install it instead. I just did the copy to notepad save as .vbs, and move to auto folder in scripts that has worked so many times before, but it doesn't seem to anymore.

Re: ExtractFields v0.1.4 [MM2+3]

Post by Steegy » Thu Mar 08, 2012 3:00 pm

zephyr wrote:Quick q's re this and right click for scripts:

Should ExtractFields be available via the right click scripts menu?

If so, how can it be added?

Right click mentions type 0 scripts only... not sure if this is possible.

Thanks in advance

Z
In the script's code, replacing Menu_TbStandard with Menu Pop TrackList should somewhat do the trick (in MM4 the standard toolbar isn't visible anyway, so you won't miss anything).

This script is an autoscript (it starts automatically when MM is starting, e.g. to add a button the MM's toolbar) so the RightClickForScripts script isn't applicable here (it works only for 'type 0 ' scripts, i.e. scripts that are added by MM to the menu Tools > Scripts and need to be started manually).

Re: ExtractFields v0.1.4 [MM2+3]

Post by Steegy » Thu Mar 08, 2012 2:53 pm

lobojon wrote:After upgrading from MM3 to MM4 two weeks ago.
After attempting to "install" it like I did in MM3. The Ctrl-Alt-X function did not work, nor did tools/scripts/extract fields show up.
After reading in the forum that it no longer works on MM4.

Am I mistaken?
For me it works in MM4, that is, it shows up in menu Tools > Scripts > Extract Fields, and Ctrl+Alt+X works. I didn't actually test changing the tags. My guess is that the script wasn't installed properly.

Re: ExtractFields v0.1.4 [MM2+3]

Post by zephyr » Sat Feb 11, 2012 5:26 pm

Quick q's re this and right click for scripts:

Should ExtractFields be available via the right click scripts menu?

If so, how can it be added?

Right click mentions type 0 scripts only... not sure if this is possible.

Thanks in advance

Z

Re: ExtractFields v0.1.4 [MM2+3]

Post by lobojon » Tue Jan 10, 2012 1:57 pm

After upgrading from MM3 to MM4 two weeks ago.
After attempting to "install" it like I did in MM3. The Ctrl-Alt-X function did not work, nor did tools/scripts/extract fields show up.
After reading in the forum that it no longer works on MM4.

Am I mistaken?

Top

cron