Discogs Tagger 5.60 (Updated: 2018-06-17)

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Discogs Tagger 5.60 (Updated: 2018-06-17)

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by vbs » Sun Jul 22, 2018 8:22 am

It's still working! :)

Big thanks for this plugin!

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by crap_inhuman » Thu Jul 19, 2018 7:08 am

vbs wrote:
Wed Jul 18, 2018 1:02 pm
crap_inhuman wrote:
Tue Jul 17, 2018 3:21 pm
vbs wrote:
Sat Jul 14, 2018 5:55 pm
I have tested some more stuff regarding this issue:
  • running Mediamonkey as admin in Win10 does not help
  • I tried to capture HTTP traffic with Wireshark as I hoped to able to see if the cover download works but since the traffic is HTTPS I could not see it that easily
  • but most importantly: I think I was wrong saying that some albums DO work. Currently I think it generally does not work (for all albums). It's just that some of my mp3s had cover art included in the first place so that I thought DiscogsTagger had added it successfully.
    I am not 100% sure about this point yet but currently I cannot find an album for that cover download does work at all.
I just tried to tag the album 10204889 from discogs. The download of the cover was successfully. I still have Windows 7. So the problem comes from Windows 10 ?
Well... I know it sounds really stupid but I was just about to test the "Windows 7 compatibility"-mode on Windows 10 but suddenly the problem disappeared and cover download is working suddenly (without changing anything). Tested it on two machines that did not work before.
Sorry, I have no explanation or excuse, it is just strange. Only explanation would be that discogs somehow changed their website interface but no idea if this is really likely.
I will keep watching it Oo
That's really strange. It may be possible, that Discogs had problems with their cover servers.
Or a new patch from Windows 10 removed this "bug".

I'm happy that it work again!

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by vbs » Wed Jul 18, 2018 1:02 pm

crap_inhuman wrote:
Tue Jul 17, 2018 3:21 pm
vbs wrote:
Sat Jul 14, 2018 5:55 pm
I have tested some more stuff regarding this issue:
  • running Mediamonkey as admin in Win10 does not help
  • I tried to capture HTTP traffic with Wireshark as I hoped to able to see if the cover download works but since the traffic is HTTPS I could not see it that easily
  • but most importantly: I think I was wrong saying that some albums DO work. Currently I think it generally does not work (for all albums). It's just that some of my mp3s had cover art included in the first place so that I thought DiscogsTagger had added it successfully.
    I am not 100% sure about this point yet but currently I cannot find an album for that cover download does work at all.
I just tried to tag the album 10204889 from discogs. The download of the cover was successfully. I still have Windows 7. So the problem comes from Windows 10 ?
Well... I know it sounds really stupid but I was just about to test the "Windows 7 compatibility"-mode on Windows 10 but suddenly the problem disappeared and cover download is working suddenly (without changing anything). Tested it on two machines that did not work before.
Sorry, I have no explanation or excuse, it is just strange. Only explanation would be that discogs somehow changed their website interface but no idea if this is really likely.
I will keep watching it Oo

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by crap_inhuman » Wed Jul 18, 2018 12:01 am

VonSupponnatime wrote:
Tue Jul 17, 2018 5:32 pm
I have recently uninstalled/reinstalled MM and this script and have come across an error when trying to search from MusicBrainz:

Error #13 - Microsoft VBScript runtime error
Type mismatch: 'response(...)(...)(...)(...)(...)'
File: {path}, Line: 6132, Column: 8

Clicking OK on that error brought up another message:

Error happened during script execution:
Type mismatch: 'response(...)(...)(...)(...)(...)'


What is needed for this script to run properly? I want to make sure I have everything needed before saying this is truly a bug (unless others have encountered it)
Which Version you have installed from Discogs Tagger?
Did the error every time come across when searching for an album?

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by VonSupponnatime » Tue Jul 17, 2018 5:32 pm

I have recently uninstalled/reinstalled MM and this script and have come across an error when trying to search from MusicBrainz:

Error #13 - Microsoft VBScript runtime error
Type mismatch: 'response(...)(...)(...)(...)(...)'
File: {path}, Line: 6132, Column: 8

Clicking OK on that error brought up another message:

Error happened during script execution:
Type mismatch: 'response(...)(...)(...)(...)(...)'


What is needed for this script to run properly? I want to make sure I have everything needed before saying this is truly a bug (unless others have encountered it)

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by crap_inhuman » Tue Jul 17, 2018 3:21 pm

vbs wrote:
Sat Jul 14, 2018 5:55 pm
I have tested some more stuff regarding this issue:
  • running Mediamonkey as admin in Win10 does not help
  • I tried to capture HTTP traffic with Wireshark as I hoped to able to see if the cover download works but since the traffic is HTTPS I could not see it that easily
  • but most importantly: I think I was wrong saying that some albums DO work. Currently I think it generally does not work (for all albums). It's just that some of my mp3s had cover art included in the first place so that I thought DiscogsTagger had added it successfully.
    I am not 100% sure about this point yet but currently I cannot find an album for that cover download does work at all.
I just tried to tag the album 10204889 from discogs. The download of the cover was successfully. I still have Windows 7. So the problem comes from Windows 10 ?

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by vbs » Sat Jul 14, 2018 5:55 pm

I have tested some more stuff regarding this issue:
  • running Mediamonkey as admin in Win10 does not help
  • I tried to capture HTTP traffic with Wireshark as I hoped to able to see if the cover download works but since the traffic is HTTPS I could not see it that easily
  • but most importantly: I think I was wrong saying that some albums DO work. Currently I think it generally does not work (for all albums). It's just that some of my mp3s had cover art included in the first place so that I thought DiscogsTagger had added it successfully.
    I am not 100% sure about this point yet but currently I cannot find an album for that cover download does work at all.

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by crap_inhuman » Thu Jul 12, 2018 6:07 pm

vbs wrote:
Thu Jul 12, 2018 1:52 pm
crap_inhuman wrote:
Wed Jul 11, 2018 8:02 pm
vbs wrote:
Tue Jul 10, 2018 2:46 pm
But still no artwork appear in properties:
https://imgur.com/a/zW70i0T
In the artwork window you'll see an add button. With it you can manually add an image as a cover. Did Mediamonkey save it and show it again after restart mm ?
Are these mp3-files or flac ?
Ok thanks, I did that and adding a cover from a local image file did work. It was also kept when restarting Mediamonkey. Files are mp3s.

Might the problem possibly be the album itself on Discogs? Some do work and some do not. Is anyone able to download covers for example for this album?
https://www.discogs.com/Odd-Beholder-At ... e/10204889
Could you please send me the Discogs_Script.log, too ? You should find it at this location c:\users\username\appdata\roaming\mediamonkey\scripts
You can send it to my email address. Maybe i can find the issue in the log-file.
Thank you !

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by crap_inhuman » Thu Jul 12, 2018 5:55 pm

a_daley wrote:
Thu Jul 12, 2018 2:03 am
I had exactly the same issue and it will only show if I save it manually and it happens to a wide variety of albums since windows was updated.... And had the same issue when trying to drag and drop when getting other images like artist, composers and lyricists - I do wonder whether it is a Windows 10 or a MediaMonkey issue rather than your addon...

Regards

Arthur
Hi Arthur,

thank you for your post. Would you please send me the Discogs_Script.log ? You should find it at this location c:\users\username\appdata\roaming\mediamonkey\scripts
You can send it to my email address. Maybe i can find the issue in the log-file.
Regards,
Sven

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by vbs » Thu Jul 12, 2018 1:52 pm

crap_inhuman wrote:
Wed Jul 11, 2018 8:02 pm
vbs wrote:
Tue Jul 10, 2018 2:46 pm
But still no artwork appear in properties:
https://imgur.com/a/zW70i0T
In the artwork window you'll see an add button. With it you can manually add an image as a cover. Did Mediamonkey save it and show it again after restart mm ?
Are these mp3-files or flac ?
Ok thanks, I did that and adding a cover from a local image file did work. It was also kept when restarting Mediamonkey. Files are mp3s.

Might the problem possibly be the album itself on Discogs? Some do work and some do not. Is anyone able to download covers for example for this album?
https://www.discogs.com/Odd-Beholder-At ... e/10204889

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by a_daley » Thu Jul 12, 2018 2:03 am

I had exactly the same issue and it will only show if I save it manually and it happens to a wide variety of albums since windows was updated.... And had the same issue when trying to drag and drop when getting other images like artist, composers and lyricists - I do wonder whether it is a Windows 10 or a MediaMonkey issue rather than your addon...

Regards

Arthur

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by crap_inhuman » Wed Jul 11, 2018 8:02 pm

vbs wrote:
Tue Jul 10, 2018 2:46 pm
But still no artwork appear in properties:
https://imgur.com/a/zW70i0T
In the artwork window you'll see an add button. With it you can manually add an image as a cover. Did Mediamonkey save it and show it again after restart mm ?
Are these mp3-files or flac ?

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by vbs » Wed Jul 11, 2018 12:14 pm

crap_inhuman wrote:
Tue Jul 10, 2018 4:48 pm
vbs wrote:
Tue Jul 10, 2018 2:46 pm
I have recently upgraded from version 5.4.5 (I didnt use it for a while) and I am experiencing a problem when trying to save album covers for some particular albums. Some other albums do work as expected.
What is different between a working album and a not working album? Different drives? Maybe you don't have the rights to write in the drive/folder? Maybe Disk full?
I am not aware of any differences. The albums all reside on the same network share in the same directory. I cannot see any read-only access rights.
I even just tried to copy the album in question to my local Desktop but still the same result: album covers does not get written to the MP3s.
crap_inhuman wrote:
Tue Jul 10, 2018 4:48 pm
Do Mediamonkey save the cover if you store it manual ?
Hm sorry, I don't know how to do this. You mean from inside the Discogs Tagger window? I could not find an option to manually store the cover.

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by crap_inhuman » Tue Jul 10, 2018 4:48 pm

vbs wrote:
Tue Jul 10, 2018 2:46 pm
I have recently upgraded from version 5.4.5 (I didnt use it for a while) and I am experiencing a problem when trying to save album covers for some particular albums. Some other albums do work as expected.
What is different between a working album and a not working album? Different drives? Maybe you don't have the rights to write in the drive/folder? Maybe Disk full?
Do Mediamonkey save the cover if you store it manual ?

Re: Discogs Tagger 5.60 (Updated: 2018-06-17)

by vbs » Tue Jul 10, 2018 2:46 pm

I have recently upgraded from version 5.4.5 (I didnt use it for a while) and I am experiencing a problem when trying to save album covers for some particular albums. Some other albums do work as expected.

What I do is:
- I select all songs in a directory and hit CTRL-L
- then I let it scrape the info and hit "Auto-Tag"
- I made sure to select "Save Images" and then select "Save images to tag if possible"
- Then I clikc OK and the dialog closes

But no cover is downloaded nor saved to the tag. Also when I use "Save image to file folder" then no file is created.

This is an example:
https://imgur.com/a/C5ne4RI

But still no artwork appear in properties:
https://imgur.com/a/zW70i0T

Is this a bug or am I wrong somewhere? Thank you!

Top