ExternalTools v1.4 [MM2+3+4]

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: ExternalTools v1.4 [MM2+3+4]

Re: ExternalTools v1.4 [MM2+3+4]

by JohnInMass2 » Tue Apr 02, 2019 3:53 am

Simple, just use %W as the parameter, and voila it worked.

One can disregard this post.

Re: ExternalTools v1.4 [MM2+3+4]

by JohnInMass2 » Mon Apr 01, 2019 5:36 am

Hello,

Some years ago I was using your tool to launch a pdf viewer that took the filename out of the songs table (from a custom field in Songs) and it worked great.

Because of a reinstall on a new computer I've completely forgotten how I did this. I installed version 1.4 but the associated documentation on how to use this has disappeared from the web (and this forum).

Any help would be appreciated, thank you.

JohnInMass2

External Tools

by cldcp00 » Wed Mar 14, 2018 6:58 pm

I am using External Tools to open Mp3tag from MM it works fine if I select 1 files but I cannot get it to work with when I select multiple[img][img][/img][/img] files.

Any Ideas

Des

Re: ExternalTools v1.4 [MM2+3+4]

by Peke » Fri Mar 09, 2018 5:17 pm

You need to rescan files into MMW

using Advanced Renamer program with MM

by MrJamesEMcBride » Fri Mar 09, 2018 8:53 am

Hello,
I am a new MM user, and I figured out how to send a list of filenames to a filename editor to work on them. After I have manipulated the filenames, I need MM to reflect the changes made to the filenames, which it doesnt now. How can I accomplish that?

Thanks in advance
--Jim

Re: ExternalTools v1.4 [MM2+3+4]

by drughetto » Wed Nov 02, 2016 1:25 am

kevin-australian wrote:I am having problems with the ExternalTools script or it is just me.

https://drive.google.com/file/d/0B2UcKI ... sp=sharing

outline of problem
I have been able to place an podcast rss style feed of youtube address into the mediamonkey database.

So i have looked and found the ExternalTools script. i have found on the internet youtube-dl as a parameter the the link to the youtube webpage and downloads the video.
Need to clarify
In the mediamonkey podcast list of episodes there is a list of youtube web pages ie http://www.youtube.com/watch?v=FQiG2dfXd0 ( example link) in the path section

useing the ExternalTools script I seem not to work on paths that are SHOWING GREYOUT in the database.
i have tryed
C:\monkey\youtube-dl.exe
parameter %P

(error expecting script event. Invaliad procedure call or argument)

this is the comand line that works

Code: Select all

c:\youtube-dl http://www.youtube.com/watch?v=FQiG2dfXd0 ( example link)


Any ideas or what have i missed ?????
thanks kevin
hi thanks a lot
can i use to encode with quaac or other encoders?

Re: ExternalTools v1.4 [MM2+3+4]

by kevin-australian » Sun Oct 30, 2016 2:23 am

I am having problems with the ExternalTools script or it is just me.

https://drive.google.com/file/d/0B2UcKI ... sp=sharing

outline of problem
I have been able to place an podcast rss style feed of youtube address into the mediamonkey database.

So i have looked and found the ExternalTools script. i have found on the internet youtube-dl as a parameter the the link to the youtube webpage and downloads the video.
Need to clarify
In the mediamonkey podcast list of episodes there is a list of youtube web pages ie http://www.youtube.com/watch?v=FQiG2dfXd0 ( example link) in the path section

useing the ExternalTools script I seem not to work on paths that are SHOWING GREYOUT in the database.
i have tryed
C:\monkey\youtube-dl.exe
parameter %P

(error expecting script event. Invaliad procedure call or argument)

this is the comand line that works

Code: Select all

c:\youtube-dl http://www.youtube.com/watch?v=FQiG2dfXd0 ( example link)


Any ideas or what have i missed ?????
thanks kevin

Re: ExternalTools v1.4 [MM2+3+4]

by MMFrLife » Fri Mar 25, 2016 9:02 am

Register to MM's Mediamonkey.registry (a file in MM portable folder), read about it here under description.
According to the status in the Mantis report (link), that manual reg. issue Peke was referring to should be fixed now, as I didn't have to deal with
it when installing.

However, there is another issue involving "Line 20" that can pop up when you try to install. Look for the words "Line 20"
somewhere on the error message. If that happens, follow Zephyr's instructions
above and it should work. Notes after reading through Zephyr's post, you only need notepad (Win Accessories)
or notepad++ to read a .vbs file (just click on it). Depending on the Archiver you use, it may not rename the .zip back to .mmip directly
from the interface of the Archiver. Just try to rename it and if it creates the file into the destination folder with .zip still on the end of it,
just manually change it back to .mmip from explorer.

Re: ExternalTools v1.4 [MM2+3+4]

by drughetto » Sun Mar 20, 2016 6:20 am

Peke wrote:It doesnt work on Portable unless manually MMW is registered. Try to add " ' " in front of "Dim SDB"?
hi Peke
what do you mean
for It doesnt work on Portable unless manually MMW is registered.
and
Try to add " ' " in front of "Dim SDB"
thanks

Re: ExternalTools v1.4 [MM2+3+4]

by drughetto » Sun Mar 20, 2016 3:49 am

chrisjj wrote:
Peke wrote:It doesnt work on Portable unless manually MMW is registered. Try to add " ' " in front of "Dim SDB"?
Thanks. That fixes it.

Is the inclusion of that line a bug? http://www.mediamonkey.com/wiki/index.p ... uto-script is clear that SDB is already provided.
hi
how can i fix it?
thanks
can somebody upload the fixed version?

i tried to edit the script but it doesn't work
" ' " Dim SDB : Set SDB = CreateObject("SongsDB.SDBApplication")

Re: ExternalTools v1.4 [MM2+3+4]

by drughetto » Sun Mar 20, 2016 3:44 am

wow!
can i use to send songs to external encoder ?

for example to qaac.exe
these are parameters -v192 -i

thanks

Re: ExternalTools v1.4 [MM2+3+4]

by chrisjj » Mon Sep 15, 2014 7:44 pm

Sending 28 files to a single Mp3tag window causes:

Image

Any way to disable this?

Re: ExternalTools v1.4 [MM2+3+4]

by chrisjj » Mon Sep 15, 2014 7:36 pm

Peke wrote:It doesnt work on Portable unless manually MMW is registered. Try to add " ' " in front of "Dim SDB"?
Thanks. That fixes it.

Is the inclusion of that line a bug? http://www.mediamonkey.com/wiki/index.p ... uto-script is clear that SDB is already provided.

Re: ExternalTools v1.4 [MM2+3+4]

by Peke » Mon Sep 15, 2014 6:26 pm

It doesnt work on Portable unless manually MMW is registered. Try to add " ' " in front of "Dim SDB"?

Re: ExternalTools v1.4 [MM2+3+4]

by chrisjj » Mon Sep 15, 2014 5:20 am

trixmoto wrote:could be because it's not registered (unlikely)
It is registered.
trixmoto wrote: or because some anti-virus or similar security software to blocking access (more likely).
I take that to mean: blocking access from your script to the database. Thanks.

Not: this is a portable install. May I ask: have you verified your script works on a portable install?

Top