Wifi sync worked for a few days, and now nothing

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Wifi sync worked for a few days, and now nothing

Re: Wifi sync worked for a few days, and now nothing

by imusicman » Sun Apr 27, 2014 2:47 pm

it seems to be working pretty well, now. next time it fails, i'll try the phone reset. thanks.

Re: Wifi sync worked for a few days, and now nothing

by bkenobi69 » Wed Apr 23, 2014 12:46 pm

The problem can be resolved by resetting the phone. An earlier post (maybe in a different thread, no time to find it) describes the issue's root cause. The short form is that Android has enough connection failures over time that a component somewhere decides to stop trying. By resetting the phone, this component will reset the lock-out and things will work again. If they don't, then you have an issue with your setup (network, MMW/MMA settings, etc).

Re: Wifi sync worked for a few days, and now nothing

by thelostpirate » Fri Apr 11, 2014 3:39 pm

just subscribing to this thread, i had similar issue with playlist syncing,

Re: Wifi sync worked for a few days, and now nothing

by Lowlander » Fri Apr 11, 2014 11:43 am

It works fine for me connected via ethernet. It could be that the server is set to a specific IP (Tools > Options > Media Sharing), or that you've started MMW while wifi was available and thus the server is running on that IP (restarting MMW with wifi off should fix that).

Re: Wifi sync worked for a few days, and now nothing

by imusicman » Fri Apr 11, 2014 11:36 am

Older thread but topic is right. I'm on latest versions of both mma and mmw as of 4/11/2014 at 9:30 mountain time. Seems like with all versions since a very early one, though, sync works only the first time after an installation of a new mma version. then it never works again. today, i did discover that at least part of the problem was that i don't normally start the wireless network adapter on my desktop machine, just connect to the wired network. both my wireless and wired networks have the same network name and share the same tcp/ip address space. Once I connected to the same network using the wireless adapter on my pc, then mma was able to see both the mmw server and library.

Shouldn't it work as long as it's on the same network, even if the mmw pc itself is connected via a wire? maybe this isn't a bug but a feature request.

Thanks and keep up the good work. (I bought mmw gold at least 5 years ago, so I know I've got my money back already. i did upgrade to mma pro :D )

Re: Wifi sync worked for a few days, and now nothing

by Peke » Wed Jan 22, 2014 8:22 pm

BenRad wrote:Obviously, they're on the same network, just different WAPs. I'm still having spotty luck with syncing, but I will soldier on.
Ok here is the basic Issue. Looks like your APs are both acting like separate DHCP Servers on devices that were connected to it. You would need to dedicate IP space for Wired and Wireless. I use 192.168.0.x for wired adn 192.168.1.x for wireless, my NAS is serving as DHCP Server (in all APs DHCP is set to bridged/relay mode pointing to NAS IP). That would assure all devices are in same network.

NOTE: Subnet mask in my case is 255.255.254.0

Hint: Try using ES file explorer to access different shared folder(s) on MMW PC

Hint2: I always use Static IP for NAS and LAN Connected PCs.

EDIT: To make things easier here is some URLs that can help you in network Administration ad settings http://www.subnet-calculator.com/

Re: Wifi sync worked for a few days, and now nothing

by rusty » Wed Jan 22, 2014 2:38 pm

BenRad,

A couple of questions; Once MMA is failing to sync:
- can MMA connect to the MMW UPnP server?
- can Bubble UPnP connect to the MMW UPnP server? (I know that you wrote that you successfully streamed to your PS3 from MMW, but it's unclear whether that was at the same time as MMA was unable to connect to MMW UPnP)
- does restarting the device affect either of the above?

Also, you wrote that there are 2 servers in MMW: MM Server, and MM Library. Can you confirm which of those is used by your device's profile (i.e. in the device profile's home page there is a config "[x] Grant remote sync / access rights to the <MediaServerName>" -- what is the MediaServerName ? If you delete/disable the other Media Server, are the results any different?

Thanks.

-Rusty

Re: Wifi sync worked for a few days, and now nothing

by BenRad » Sat Jan 18, 2014 11:54 am

Lowlander wrote:The key is that both the client and the server are on the same network, as otherwise DLNA won't work. Besides that make sure ports used aren't blocked.
Obviously, they're on the same network, just different WAPs. I'm still having spotty luck with syncing, but I will soldier on.

Re: Wifi sync worked for a few days, and now nothing

by bkenobi69 » Wed Dec 18, 2013 11:50 am

FWIW, I have had a similar issue where for some reason MMA refuses to find MMW via WiFi. The solution I have come up with is to close MMW and restart it and to reboot the phone. I don't know which is the fix, but it always works.

Re: Wifi sync worked for a few days, and now nothing

by Lowlander » Sun Dec 15, 2013 12:29 pm

The key is that both the client and the server are on the same network, as otherwise DLNA won't work. Besides that make sure ports used aren't blocked.

Re: Wifi sync worked for a few days, and now nothing

by BenRad » Sat Dec 14, 2013 8:36 pm

I may have figured this out, but I haven't confirmed yet. I have two WAPs in my house, both connected to the same switch, but with different SSIDs. I may need to set up some port forwarding on the second AP, because when I connected to the other AP, syncing was successful.

Meanwhile, I'll just keep blathering on in this thread as I figure things out. :lol:

Re: Wifi sync worked for a few days, and now nothing

by BenRad » Sat Dec 14, 2013 8:32 pm

Bah. I just went and successfully streamed to my PS3 from MMW, so I guess that's not it.

Re: Wifi sync worked for a few days, and now nothing

by BenRad » Sat Dec 14, 2013 8:23 pm

Everything is up to date, and now I can no longer see the MMW server on the network (which I realize makes no sense).

Couple of things:

I'm starting to wonder if this might be a UPnP issue and not just a syncing issue. I was able to play music from my phone using BubbleUPnP streaming from MMW this morning, then MMA synched. After updating MMA, I could no longer sync.

I have two entries under Media Sharing and Wifi Sync, MM Server and MM Library, is that correct?

I set up port forwarding on my router, just for fun, to see if that would fix it, but it doesn't seem to make a difference.

Where are the logs for the server stored?

Re: Wifi sync worked for a few days, and now nothing

by Lowlander » Sat Dec 14, 2013 12:53 pm

As both MMA and MMW have been updated since I suggest you start by updating both to the latest.

Re: Wifi sync worked for a few days, and now nothing

by BenRad » Sat Dec 14, 2013 9:32 am

Yes, I checked that. The only profile I have active is for the external card, "Android Phone".

Top