Distorted sound while seeking with seek enabled [#13333]

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Distorted sound while seeking with seek enabled [#13333]

Re: Distorted sound while seeking with smooth seek enabled

by jiri » Tue Jun 07, 2016 1:35 pm

Btw, sorry for the problem, it slipped through our testing. We certainly continue develop every aspect of MM, including the old good audio playback. That said, there's been only quite few changes in the playback functionality recently, simply because there wasn't any need for significant changes. ;-)

Jiri

Re: Distorted sound while seeking with smooth seek enabled

by rpsgc » Tue Jun 07, 2016 11:01 am

MiPi wrote:Problem with seeking in MP3 (introduced in 4.1.10) and in M4A is fixed, will be included in the next beta build.
I cannot reproduce any problem with WAVs.
That's great news! Looking forward to test it.

Re: Distorted sound while seeking with smooth seek enabled

by MiPi » Tue Jun 07, 2016 10:46 am

Problem with seeking in MP3 (introduced in 4.1.10) and in M4A is fixed, will be included in the next beta build.
I cannot reproduce any problem with WAVs.

Re: Distorted sound while seeking with smooth seek enabled

by rpsgc » Thu May 12, 2016 8:46 am

Peke wrote:Are you sure that you have installed latest drivers from realtek site. Also it is known that on some card chips due the software interpolate setting of 96/24 and higher can make problems with buffer clearing. I have 4 PCs and all have Realtek cards, 2 have 889 Chips, 1 892 chip and one that have that interpolating issue have 865 Chip which is now set to 48/24 and have no issues at all.

HINT: Download EXE installation as it makes less issues on installation (from personal experience)
For the record:

I have the latest drivers.
Audio format is 24-bit/48KHz (default setting).
Desktop uses Realtek ALC1150, laptop uses Realtek ALC269.
I am using portable installations to troubleshoot.
I am using Numpad to control the seek bar (MediaMonkey.ini --> PlaybackControl=3)
MediaMonkey 4.1.9 doesn't have this issue, only later versions.

I can't reproduce the issue 100% of the time. Either it's random or there's something that triggers it.

I'm going to test with MediaMonkey Debug version and DbgView.


EDIT:

There's nothing different/unusual in DgbView when the issue occurs.
The issue occurs with mp3, m4a and wav files, but not with flac or ogg files. If that makes any sense...

Re: Distorted sound while seeking with smooth seek enabled

by Peke » Thu May 12, 2016 7:07 am

rpsgc wrote:
Peke wrote:Hi,
Sorry to hear that, this kind of issues are mostly pc specific. Can you please open support ticket so that we can see what can be done.
It happens on my laptop too so I very much doubt it's system specific (unless by "PC specific" you actually meant "anyone with a Realtek sound card").
Are you sure that you have installed latest drivers from realtek site. Also it is known that on some card chips due the software interpolate setting of 96/24 and higher can make problems with buffer clearing. I have 4 PCs and all have Realtek cards, 2 have 889 Chips, 1 892 chip and one that have that interpolating issue have 865 Chip which is now set to 48/24 and have no issues at all.

HINT: Download EXE installation as it makes less issues on installation (from personal experience)

Re: Distorted sound while seeking with smooth seek enabled

by Lowlander » Tue May 10, 2016 1:42 pm

rpsgc wrote:
Darmst wrote:MM development has become all about synchronization and other features I don't care about while still being a bugfest for just playing music.
That's sadly the truth.
A developer is offering direct support through a Support Ticket, can't get much better than that.

Re: Distorted sound while seeking with smooth seek enabled

by rpsgc » Tue May 10, 2016 1:38 pm

Darmst wrote:Nope, I still get the bug in 4.1.12.1790 RC, even with DLNA/UPnP enabled or disabled from what I gather.
Turns out it was just a coincidence. I didn't run into it at the time when I first tested it but it's still here.
Darmst wrote:MM development has become all about synchronization and other features I don't care about while still being a bugfest for just playing music.
That's sadly the truth.
Peke wrote:Hi,
Sorry to hear that, this kind of issues are mostly pc specific. Can you please open support ticket so that we can see what can be done.
It happens on my laptop too so I very much doubt it's system specific (unless by "PC specific" you actually meant "anyone with a Realtek sound card").

Re: Distorted sound while seeking with smooth seek enabled

by Peke » Sun May 01, 2016 11:38 am

Hi,
Sorry to hear that, this kind of issues are mostly pc specific. Can you please open support ticket so that we can see what can be done.

Re: Distorted sound while seeking with smooth seek enabled

by Darmst » Sat Apr 30, 2016 4:45 am

Nope, I still get the bug in 4.1.12.1790 RC, even with DLNA/UPnP enabled or disabled from what I gather.

I have converted to musicbee after using mediamonkey for 8 years. MM development has become all about synchronization and other features I don't care about while still being a bugfest for just playing music.

Re: Distorted sound while seeking with smooth seek enabled

by rpsgc » Fri Apr 29, 2016 7:32 am

@Darmst,

Have you tried the latest RC, version 4.1.12.1790 RC?
MMW client occasionally plays few seconds of track before skipping to next
It's under "DLNA/UPnP" but this might fix the issue. Can you confirm?

Re: Distorted sound while seeking with smooth seek enabled

by rpsgc » Tue Mar 08, 2016 10:06 am

Darmst wrote:The bug is still present in 4.1.11.1783.
I'm reverting back to 4.1.9.1764 as it's too annoying hearing random parts of the track for a split second while seeking.
Same in 4.1.12.1785 Beta.

Truth be told, I don't think this bug will be fixed any time soon. They seem focused on fixing synchronization issues and little else. I can't imagine them devoting resources to something like this.
Peke wrote:Sound should be teh same I have not seen any changes to output plugins from 1764 -> 1778.
The plug-ins are not the cause of the problem. I've replaced the plug-in .dll files with the ones from a "good" version and the issue is still present (obviously, as they're identical)

Re: Distorted sound while seeking with smooth seek enabled

by Darmst » Sat Feb 20, 2016 12:44 pm

The bug is still present in 4.1.11.1783.
I'm reverting back to 4.1.9.1764 as it's too annoying hearing random parts of the track for a split second while seeking.

Re: Distorted sound while seeking with smooth seek enabled

by rpsgc » Sat Jan 02, 2016 10:57 am

Same here (Windows 10 x64). Seeking in the latest version feels broken, especially for someone who uses numpad keys to do it. It's not just distorted sound either, sometimes when I'm seeking forward it will go back for an instant and then forward, other times seeking isn't 'solid', like MM isn't sure of what it's doing and hesitates, so the result isn't smooth or fluid.

I've gone back to 4.1.9 and I'm sticking with it for as long as I can.

Re: Distorted sound while seeking with smooth seek enabled

by Peke » Wed Dec 23, 2015 8:12 pm

Sound should be teh same I have not seen any changes to output plugins from 1764 -> 1778.

Distorted sound while seeking with seek enabled [#13333]

by Darmst » Wed Dec 23, 2015 7:15 am

When upgrading to the current 4.1.10.1778 I get distorted sound while seeking in a track with both smooth seek disabled and enabled. When I downgraded to 4.1.9.1764 the distorted sound is gone.

Windows 8.1 64

Top