[SOLVED] Special Character Search fails

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: [SOLVED] Special Character Search fails

Re: Special Character Search fails

by SpinCycle » Wed Nov 15, 2017 5:11 pm

Embarrassingly simple solution. Not sure how I hadn't tried that. Thank you! :D

Re: Special Character Search fails

by Ludek » Wed Nov 15, 2017 4:40 am

Hi, yes, directly in the search bar entering '^^^' does not work as it uses full-text-search engine and uses prefixes search.
Workaround for you is to click the magic glass button to bring up the Search dialog , enter ^^^ directly into the Genre field and press [OK]

[SOLVED] Special Character Search fails

by SpinCycle » Tue Nov 14, 2017 8:59 pm

Hi All, I've been DJing on a laptop since 2002 (Mixmeister!), and so I started very early to develop my own tagging method as various programs supported various sets of tags and usually included a few of their own. So I decided to rely on the tags that I knew would be supported, rather than to say, use "Rating" in one app that might not be visible in another.

So, in my Genre tags, I trail the genre with ^^ or ^^^ for songs I really like (yes, only 2 or 3 stars in my rating system). For example, Dile by Don Omar had the genre tag "reggaeton ^^^". When I want to see all of my "hits", I just type ^^^ into the search box. It worked in Mixmeister. It works in VirtualDJ, and other programs. But alas, it does NOT work in MediaMonkey. :-(

It forces me to type a letter along with the special characters--which defeats the purpose and does not yield the entire list of all songs with a trailing ^^^ in the genre tag. I think this is just a programming shortcoming in dealing with special characters in regular expressions.
'reggaeton ^^^' works. But '^^^' yields an empty list. I have tried with quotations around it, etc. Perhaps there is a special way to "escape" special characters??

What I know is that that in other programs I use, it just works. And in MM it does not. It's been bugging me for years, and I've finally got around to submitting this bug. I'm hoping it will somehow percolate up to the programmers who can fix it and/or that there is a very simple fix that I have somehow missed.

Thanks for your help.

Jim

Top