Auto Organise Problems (keeps adding the track number twice)

Post a reply


In an effort to prevent automatic submissions, we require that you complete the following challenge.
Smilies
:D :) :( :o :-? 8) :lol: :x :P :oops: :cry: :evil: :roll: :wink:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: Auto Organise Problems (keeps adding the track number twice)

Re: Auto Organise Problems (keeps adding the track number twice)

by Lankylad » Fri Sep 27, 2019 9:34 am

Thanks for letting me know.

Re: Auto Organise Problems (keeps adding the track number twice)

by Lowlander » Thu Sep 26, 2019 10:13 am

You can copy & paste the Mask used in Auto-Organize. That's what I did (I use Auto-Organize to tell me which files are unorganized, not to organize them). Linking the 2 has been requested.

Re: Auto Organise Problems (keeps adding the track number twice)

by Erwin Hanzl » Thu Sep 26, 2019 9:50 am

You are responsible for capturing the right parameters and not MM. MM provides you with the tool to customize everything to your liking.
What's so difficult?

Image


Result in windows explorer:
Image

Upload with: https://imgbb.com/

Re: Auto Organise Problems (keeps adding the track number twice)

by Lankylad » Thu Sep 26, 2019 9:10 am

I understand, still its a shame it can't offer you your auto organise choices in a dropdown list when you do rightclick.

Re: Auto Organise Problems (keeps adding the track number twice)

by Lowlander » Wed Sep 25, 2019 9:30 am

They are separate features as technically you don't need manual organizing if you have automatic organizing enabled.

Re: Auto Organise Problems (keeps adding the track number twice)

by Lankylad » Wed Sep 25, 2019 2:17 am

Actually it made me realise something after reading your response. When I created an Auto organise choice in the Options section I did indeed choose <Title> at the end.
However, when I choose a group of songs and clicked the right mouse button before choosing Auto Organise it had filled in the text box by adding most of my choices including the 3 digit track but it had then added a hyphen after track number and changed the <Title> to <filename>.

After setting up the auto organise option you want in the Options menu it seems bizarre that it doesn't use that as the default when you then choose auto organise after highlighting an album??? It also tries to fool you by changing my choice of hard drive from g/audio to c/user/etc. This seems especially odd as I have made the music album on G my default music folder in Windows 10.

Just another Mediamonkey mystery I guess. It feels like it is setup to catch you out deliberately sometimes.

Re: Auto Organise Problems (keeps adding the track number twice)

by Lankylad » Tue Sep 24, 2019 6:10 pm

Yes of course, that makes sense. Thank you, I will give that a try!

Re: Auto Organise Problems (keeps adding the track number twice)

by Lowlander » Tue Sep 24, 2019 12:05 pm

<Filename> is where you're going wrong as it take the existing Filename which already includes the Track#, so:

Audio\Music\<Album Artist>\<Album>\<Artist> <Track#:3> <Title>

would work better, but this will be hard to use if you ever wanted to recover Artist or Title from Filename. Using a delimiter is better, like -, , or . between fields.

Screenshot: https://www.mediamonkey.com/support/ind ... orum-posts

Auto Organise Problems (keeps adding the track number twice)

by Lankylad » Tue Sep 24, 2019 11:37 am

Hi, I am trying to use Auto-organise to alter my filenames. After previous disasters trying to make sense of this tool I am doing it album by album in the hope that if it goes wrong again manually putting it right is not too big a job.

You can see my problem by my screenshot. (I wish)

The current album file contains the following in the filename.
A 2 digit track number, followed by the artist a dash then the name of the song. eg.
Great Big Sea\Turn\01 Great Big Sea - Bad As I Am.flac

I wish it to read; artist then a 3 digit track number then the name of the song (no dashes). eg.
Great Big Sea\Turn\Great Big Sea 101 Bad As I Am.flac

However, the "new" column (showing what would happen if I hit the OK button) with Auto organise shows it will read
Great Big Sea\Turn\Great Big Sea 101 01 Great Big Sea - Bad As I Am.flac

I wrote the auto-organise rule as (I tried replacing the Artist with Album Artist in the filename but it came out the same.
Audio\Music\<Album Artist>\<Album>\<Artist> <Track#:3> <Filename>

What am I doing wrong, please? Could it be something connected with the criteria box which I have left blank as both the you tube tutorials I saw didn't mention it.
Thanks
Lankylad

Great...now I can't find the paperclip image, why oh why is nothing simple or standard with Media monkey. I have a screenshot that would perfectly show the problem but apparently we can't add files... I will go back over this and try and put in more detail to get around the deficiency.

Top