last.fm and mm

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

glitztech
Posts: 7
Joined: Mon Feb 04, 2008 4:41 am
Contact:

Post by glitztech » Mon Feb 04, 2008 6:45 am

spacefish wrote:
glitztech wrote:I can't believe that something that is completely and utterly seemless and pain free with WMP is pile of crap in MM3!
Don't think it's MM's issue but rather the Winamp plugin. As I said, there were reports long ago of CDs not scrobbling but since last.fm support is next to non-existent, I don't keep up with the support forums there anymore. Remember that WMP uses a completely different plugin altogether from the Winamp version.

That said, Peke is working on native scrobbling support for MM so have patience. ;)
That's cool, having a native version would be fantastic!
I can live with scrobbling audio CDs using WMP for now.
Anyone know what the ETA on Peke's version is yet?

spacefish
Posts: 1427
Joined: Mon Jan 14, 2008 7:21 am
Location: Denmark

Post by spacefish » Mon Feb 04, 2008 6:57 am

No idea on the ETA (I'm excited, too!) but here's a teaser:

http://www.mediamonkey.com/forum/viewto ... 341#123341
Image
MM Gold 3.0.3.1183 : Vista HP SP1 (x86) : Zen Stone (2GB)
Zekton: An original MM3 skin by Eyal.
Scripts in Use: Add/Remove PlayStat | Auto Album DJ | AutoRateAccurate | Backup
Case & Leading Zero Fixer | Classification & Genre Changer | Clean Scripts.ini | Clear
Field | Custom Report | Discogs Auto-Tag Web Search | Forget Crossfade | Invert
Selection/Select None | Last 100... | Lyricator | Lyrics to Instrumental | MonkeyRok
MusicBrainz Tagger | My Custom Nodes | Now Playing Art Node | Play History & Stats
Right Click for Reports | Right Click for Scripts | Right Click for Web | Stop After Current
WebNodes

urlwolf
Posts: 179
Joined: Sun Mar 05, 2006 6:58 am

Post by urlwolf » Mon Feb 04, 2008 12:26 pm

urlwolf wrote:got it working, thanks!
Scratch that.
I swear to God it's not working anymore.
Using gen_wa2_scrobbler.dll.

Doesn't show up under general plugins.

Guys, this is leaving me a VERY bad impression.
MM3 was in development for longer than I care to remember, and there are SO MANY little things that are broken! It's not even funny.

How much more of my time am I going to waste?
Image

spacefish
Posts: 1427
Joined: Mon Jan 14, 2008 7:21 am
Location: Denmark

Post by spacefish » Mon Feb 04, 2008 1:16 pm

urlwolf wrote:
urlwolf wrote:got it working, thanks!
Scratch that.
I swear to God it's not working anymore.
Using gen_wa2_scrobbler.dll.

Doesn't show up under general plugins.

Guys, this is leaving me a VERY bad impression.
MM3 was in development for longer than I care to remember, and there are SO MANY little things that are broken! It's not even funny.

How much more of my time am I going to waste?
I don't know about gen_wa2_scrobbler (is that the one that needs the last.fm client to run?) but know that gen_audioscrobbler.dll works and shows up in the plugin list. Have you tried that one? I linked it above.
Image
MM Gold 3.0.3.1183 : Vista HP SP1 (x86) : Zen Stone (2GB)
Zekton: An original MM3 skin by Eyal.
Scripts in Use: Add/Remove PlayStat | Auto Album DJ | AutoRateAccurate | Backup
Case & Leading Zero Fixer | Classification & Genre Changer | Clean Scripts.ini | Clear
Field | Custom Report | Discogs Auto-Tag Web Search | Forget Crossfade | Invert
Selection/Select None | Last 100... | Lyricator | Lyrics to Instrumental | MonkeyRok
MusicBrainz Tagger | My Custom Nodes | Now Playing Art Node | Play History & Stats
Right Click for Reports | Right Click for Scripts | Right Click for Web | Stop After Current
WebNodes

urlwolf
Posts: 179
Joined: Sun Mar 05, 2006 6:58 am

Post by urlwolf » Mon Feb 04, 2008 1:33 pm

I'm using the old version (1.1) now. It works.
But I had to reinstall (!).

It also got a dsp plugin that wasn't working before.

I also changed skins.

It MIGHT be that the newer skin (and best to my taste) MM-ultimate screws things up slightly.

I'm not going to touch anything now that it works.
But, God, MM is the example of an application that is dangerous as hell. I don't trust it at all.

There are bugs in the bugs!
Image

urlwolf
Posts: 179
Joined: Sun Mar 05, 2006 6:58 am

Post by urlwolf » Mon Feb 04, 2008 6:40 pm

If I close MM and open it again,
The plugin is gone from the general list.

ANY last.fm plugin.

This, ladies and gentleman is shitty programming at its best.

----

Plus, some covers are not displayed even when they are in the same folder as the music.

Plus some wma tags are never seen.

I'll stop wasting my time with MM3 now.
Image

drjboulder
Posts: 1119
Joined: Mon Apr 09, 2007 12:03 am
Location: Boulder, Colorado, USA

Post by drjboulder » Mon Feb 04, 2008 6:44 pm

For all the ranting you have been doing about what an awful program the Monkey is, I am surprised that you are still using it!

There are many many users who are more than pleased with it.

Maybe your solution is to un-install and use Itunes. :-?
D Rock
Image
MediaMonkeyGoldv3.0.3.1183
Vista Home Basic|4thGen 20GPod
Zune Small Player Skin w/ Aqua 4 Player Mod
Backup | Last FM Node | Scrobbler DJ | TopTracks | StayInSameStyleDJ
RadioDJ | RadioFreeMonkey | PrettyPictures | MiniLyricsEmbedder
LyricsViewer | Lyricator | LyricsPlugin | VisualizationEmbedder | MonkeyRok
RightClickForWeb | WebSearchPanels | WebNodes | MagicNodes | FavoritesNodes
NowPlayingArtNode |AutoRateAccurate | TaggingInconsistencies
AdvancedDuplicateFind&Fix | CaseModify | PlayHistory&Stats | Etc...

Teknojnky
Posts: 5533
Joined: Tue Sep 06, 2005 11:01 pm
Contact:

Post by Teknojnky » Mon Feb 04, 2008 6:46 pm

Works for me!

If the plugin disappears from the general plugin list either:
a) there are still running mm process (check task manager process list) either from crash or perhaps try to re-open before it finish shutting down)
b) some thing is removing the plugin from the plugin folder.

below page is basically same information already in this thread (and probly several other threads as well)

http://www.mediamonkey.com/wiki/index.p ... lugin_Info

BTW, scrobbler submission server is down or something atm, gettng bad auth for last hour or so.

urlwolf
Posts: 179
Joined: Sun Mar 05, 2006 6:58 am

Post by urlwolf » Mon Feb 04, 2008 6:47 pm

If I reinstall, everything works normally, for a while.

Then last.fm plugin disappears; so does one dsp plugin, Ozone.

It's not just closing and reopening what creates the problem. I'm not sure how to recognize it.

This is not even alpha quality software.
Image

Teknojnky
Posts: 5533
Joined: Tue Sep 06, 2005 11:01 pm
Contact:

Post by Teknojnky » Mon Feb 04, 2008 6:57 pm

Have you rebooted lately?

What OS? and what version MM? DEP can cause problems with various software. Do you have it enabled for all applications? (windows control panel > system > advanced > performance options > data execution prevention

is that Ozone plugin for winamp TWO or FIVE?

Do you have only ONE scrobbler plugin? they tend to conflict with each other if you have both there.

Also, you do not need to uninstall/re-install, simply moving or renaming the gen_ plugin from the plugins folder and it will be disabled after restarting MM, plugins are only initialized during application start.

If you don't provide sufficient information (and too much attitude for that matter), its difficult for anyone to help.

urlwolf
Posts: 179
Joined: Sun Mar 05, 2006 6:58 am

Post by urlwolf » Tue Feb 05, 2008 1:09 pm

Teknojnky wrote:Have you rebooted lately?

What OS? and what version MM? DEP can cause problems with various software. Do you have it enabled for all applications? (windows control panel > system > advanced > performance options > data execution prevention
XP SP2
MediaMonkey_3.0.2.1134
DEP for essencial services and applications only
rebooted 2 days ago.
Teknojnky wrote: is that Ozone plugin for winamp TWO or FIVE?
two since it worked with MM2.5
Teknojnky wrote: Do you have only ONE scrobbler plugin? they tend to conflict with each other if you have both there.
Only one; tested both ways, but in any case, they were alone.

I had MusicIP in the background, which may have something to do with the problems although unlikely...
Teknojnky wrote: Also, you do not need to uninstall/re-install, simply moving or renaming the gen_ plugin from the plugins folder and it will be disabled after restarting MM, plugins are only initialized during application start.
I have tried that. Once MM misses the plugins, the only way to get it to see them again is to reinstall it.

Which is really, really strange and makes me worry about what it's doing....
Teknojnky wrote: If you don't provide sufficient information (and too much attitude for that matter), its difficult for anyone to help.
I've used MM 2.5 for 2 years or so, Gold user. Moved to something else. MM 3 beta screwed my tags more than once, so I stayed away. I was really eager to try MM 3 when out of beta (now!), but I'm finding more problems than anyone would like to admit.

The fact that I'm still here is a testament on how determined I am to get it to work. And to how dissapointing other options in the market are, overall.
Image

urlwolf
Posts: 179
Joined: Sun Mar 05, 2006 6:58 am

Post by urlwolf » Tue Feb 05, 2008 2:27 pm

Ok, I found that the dissapearing plugin phenomenon happens when MM crashes on exit.
That is, you press alt F4, MM closes, but unknown to the user, it has actually crashed.

I just realized I have logs for the last 4 crashes.

Using crashlog (installed using advice in some Opera thread).

Where should I send those logs?

Thanks
----
Another topic is the problems MM3 has getting all album art. I have found that it misses about 25%.
We are talking about files that are in the same folder as the music, and named folder.jpg.

Where are the rules set up? Any tweaks that I can apply to make it work with 100% of the art?
Image

Teknojnky
Posts: 5533
Joined: Tue Sep 06, 2005 11:01 pm
Contact:

Post by Teknojnky » Tue Feb 05, 2008 5:30 pm

The support at mediamonkey dot com probly.

I dont know if those logs will be useful or not, normally you should use debug view + the debug release of MM..

more info

http://www.mediamonkey.com/forum/viewtopic.php?t=69

Baculaat
Posts: 14
Joined: Tue Aug 14, 2007 6:06 am

Post by Baculaat » Thu Feb 07, 2008 9:30 pm

hi, some dude called baculaat posted a zip file to make MM work with the newest client :lol:

http://www.last.fm/forum/34905/_/360038


Post Reply