How to get rid of the spacer between tracks?

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

How to get rid of the spacer between tracks?

Postby drice97 » Wed Sep 01, 2004 10:46 am

In ripping a mixed cd to my computer, MediaMonkey automatically places a 1-2 second delay, or spacer, in between the tracks. It's really annoying, and I can't figure out how to get rid of it. It really interrupts the flow of the music. Anyone have this problem? thanks!
drice97
 

Postby Lowlander » Wed Sep 01, 2004 11:56 am

Silences in between songs can be solved by the output plugins. Several have silent removal features that eliminate these silences in playback.

Directsound, which comes installed with MM, is one of those.



I don't know if MM adds silences at beginning and/or end of songs???
Lowlander
 
Posts: 37060
Joined: Sat Sep 06, 2003 5:53 pm

Postby drice97 » Wed Sep 01, 2004 12:23 pm

So, would I disable the Directsound then to get rid of the gaps?
drice97
 

Postby Lowlander » Wed Sep 01, 2004 1:34 pm

Nop, you would select DirectSound as your output plugin.

Then configure it. In the window that pops up you select the other tab and select remove silence at beginning/end track. You might need to play with the DB level there to get your perfect mix.


BTW are you sure that MM adds the silence, or do the songs have silence on the CD as well? And if MM adds it, is it for a CD's or just certain?
Lowlander
 
Posts: 37060
Joined: Sat Sep 06, 2003 5:53 pm

Postby drice97 » Wed Sep 01, 2004 1:49 pm

Ok, thanks.

Yeah, MM definitely adds the silence. On my cd's, the tracks are mixed together, as if it's all one big song. On my Roxio CD burner, it also adds that gap in between. However, if I select "disc at once" instead of "track at once," it records it exactly how it plays.
drice97
 

Postby Lowlander » Wed Sep 01, 2004 3:55 pm

Another output plugin you can consider is sqrSoft (can be found on winamp). It has advanced fading options which can be nice to get rid of silences or just smooth transistions between songs.
Lowlander
 
Posts: 37060
Joined: Sat Sep 06, 2003 5:53 pm

can't get timing right

Postby mesla » Mon Sep 06, 2004 7:50 pm

I'm also trying to remove silence between tracks during play and not having any luck. I've checked the 'remove silence between tracks' box in Direct Sound, but it says that it also depends on the buffer length. I'm thinking I don't want a buffer since that would mean no gap, but lowering the buffer increases the pre-buffer which I assume adds space at the beginning of a track. How can I configure direct sound so that the tracks fade at the end and seamlessly into the next track? Thanks.
mesla
 

Postby Lowlander » Tue Sep 07, 2004 9:15 am

You do want buffer for this and as large as possible. It will only be able to move the gap from the part loaded into buffer.
You also might want to play with the cutoff DB value. The higher the more it cuts off. You might want to fiddle with it for a while and see which works best for you.

And lastly if you want some more advanced stuff you can get sqrSoft Advanced Fading plugin (I believe you need to have WinAmp installed to install it, read MM help for more info). Because cutoff can cut music off as well when at low volume you might want to consider using crossfading between tracks. This makes songs seem to flow over in each other.
Lowlander
 
Posts: 37060
Joined: Sat Sep 06, 2003 5:53 pm

From the readme...

Postby roachster » Mon Nov 07, 2005 1:15 pm

Here are instructions from MM's readme file. This worked perfectly for me:


6. Tips

a) How to enable cross-fading between Tracks:
If you are using Windows 98, ME, 2000 or XP, you can enable crossfading or gapless
playback via the included DirectSound output plugin:
-Go to Tools|Options|Output plug-ins and set DirectSound as the output plug-in if it isn't already.
-Click the 'Configure' button to configure the plugin.

To enable crossfading:
-Select the 'Fading' tab
-Change the default fade length to 600ms
-Double-click 'On start' and then 'On end of song' to enable fading
-Click 'Apply' and then 'OK'

To enable gapless playback:
-Select the 'Buffering' tab
-Increase the 'Buffer length' to 5000ms
-Increase 'Buffer-ahead on track change' to 3000ms
-Select the 'Fading' tab
-Ensure that fading is disabled for 'on start', 'on first start', and 'on end of song'
since if fading is active, gapless playback will be disabled.
-Select the 'Other' tab
-Check "Remove silence..."
roachster
 

Postby Peke » Mon Nov 07, 2005 4:36 pm

Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
Peke
 
Posts: 8184
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia


Return to Need Help? (mmw)

Who is online

Users browsing this forum: Google [Bot], SilvaNights and 16 guests