Lyrics saved in MM don't show up in MiniLyrics

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

lorie
Posts: 32
Joined: Fri Jan 04, 2008 11:58 am
Location: NW USA

Lyrics saved in MM don't show up in MiniLyrics

Post by lorie » Sat Jan 12, 2008 4:55 pm

Here's my problem: I am saving lyrics to the tag in MM3. However, the lyrics do not show up in some other applications, such as the very cool MiniLyrics.

When I right-click on MiniLyrics, go to Lyrics-->Load lyrics from song... I get this under Description:

"Embedded ID3v2 unsynchronised lyrics,XXX"

and this under Lyrics:

"song://id3v2/uslt/XXX"


These lyrics do not show up in the MiniLyrics window.

Hope that is enough to give an idea of the problem (NoHitter, let me know if you need more...)

EDIT: XP2; MM3; WMP 11

Thanks,
lorie

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Post by nohitter151 » Sat Jan 12, 2008 5:06 pm

lorie, these are the exact steps I take to load lyrics from mp3 into Minilyrics:
Image

Right click in the Minilyrics window, go to Lyrics -> Open Lyrics-
Image

Select first choice, it should say song://id3v2/uslt/XXX
Image

Lyrics appear-
Image
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Chazcon
Posts: 25
Joined: Thu Jan 03, 2008 11:01 pm

Post by Chazcon » Sat Jan 12, 2008 5:28 pm

Whoa that skin is so cool i just downloaded it.

Now messing with MiniLyrics. How did you embed that window?


Where's that search button...


Still can't rip CD's but working on that too.
FOR THE VITAE !

lorie
Posts: 32
Joined: Fri Jan 04, 2008 11:58 am
Location: NW USA

Post by lorie » Sat Jan 12, 2008 5:30 pm

Okay, that is exactly what I'm doing only nothing happens. What is peculiar is that for some songs, as soon as the song starts, the lyrics are there; I don't even have to go to Lyrics ->Open lyrics, etc...

That is what has me confused. I know that I put lyrics in songs using a variety of programs before I found MM. They all show up in MM. But not in MiniLyrics.

lorie

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Post by nohitter151 » Sat Jan 12, 2008 5:47 pm

Chazcon, see here: http://www.mediamonkey.com/forum/viewto ... &start=199

Lorie
, check the lyrics to a song where the lyrics do not show up. Do you have any "special" characters in your lyrics such as ç, é, û, or similar? Try temporarily removing those characters and retrying the import of lyrics. Minilyrics might be having a problem with special characters.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Chazcon
Posts: 25
Joined: Thu Jan 03, 2008 11:01 pm

Post by Chazcon » Sat Jan 12, 2008 6:03 pm

Got it. Wonderful! Embedded miniLyrics and using your nice Zune skin.

Media Monkey is fantastic.

Off thread question: Can you select your entire library and search for album art on the web, or must you go album-by-album?
FOR THE VITAE !

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Post by nohitter151 » Sat Jan 12, 2008 6:13 pm

Chazcon wrote:Got it. Wonderful! Embedded miniLyrics and using your nice Zune skin.

Media Monkey is fantastic.

Off thread question: Can you select your entire library and search for album art on the web, or must you go album-by-album?
You can only use Auto-Tag from Web one album at a time but if you'd like you can try Trixmoto's Batch Art finder script to search for your entire library or multiple albums at a time.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

lorie
Posts: 32
Joined: Fri Jan 04, 2008 11:58 am
Location: NW USA

Post by lorie » Sat Jan 12, 2008 6:16 pm

NoHitter, I'm pulling my hair out...

Many of my songs are in French, so yes, they have those special characters. But again, some of them work, so that may not be it entirely.

So, let's try it in English. I found a song with no lyrics. Got the lyrics by cutting and pasting from a web page. Pasted them into my text editor (EditPadLite). Added a missing line. Saved it as text file (just so I don't have to go hunting again... not to be linked in MiniLyrics). Copied the new lyrics from text editor into MM3. Clicked CTRL + S to save the lyrics to the tag.

Opened WMP11 (where MiniLyrics opens in a window Always on Top). BAM! There were the lyrics...

So I repeated the procedure only this time cutting the lyrics out of another English song already supposedly tagged in MM. Pasted lyrics into text editor. Deleted a couple of extra lines. Saved as text file (same reasoning). Copied the new text; pasted it into MM3. Clicked CTRL + S to save the lyrics to the tag.

Reopened WMP11... Blast, no lyrics...

At this rate, I will be bald before the evening... Help?
Any ideas? Bit rate? Some other kind of encoding? Why does it work sometimes and not others???

lorie

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Post by nohitter151 » Sat Jan 12, 2008 6:31 pm

Lorie, sorry I can't be of more help. The fact that when you go to load the lyrics the location is put as 'song://id3v2/uslt/XXX ' means that the lyrics are correctly being saved to the mp3 tags, which means MM is doing its job.

I suggest you send an email to support [at] crintsoft.com (Minilyrics support email) explaining your problem and attaching an example mp3 that will not load lyrics from tag correctly. I have dealt with this support email in the past and they were able to deal with a couple of problems I had found. Hopefully the Minilyrics team can find the problem and give a fix.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

lorie
Posts: 32
Joined: Fri Jan 04, 2008 11:58 am
Location: NW USA

Post by lorie » Sat Jan 12, 2008 7:07 pm

Thanks so much for your patience and help, NoHitter... I am going to mess around with the bit rate, etc. And then if I can't get it to work, I will email crintsoft.

One of the things I will check is the fact that on Crintsoft's help page, they mention three methods of saving to ID3 tag; one of them is something like Lyrics3v2 for ID3v1. They indicate that this is not widely supported. I am going to experiment because one of the programs that I have used to tag lyrics does use this method. And I believe that these are the songs that DO show the lyrics in MiniLyrics. (Will check to be sure before making that claim to Crintsoft, of course... :o )

Any thoughts on the message in the Open lyrics dialog:
"No suitable lyrics found"
even when there are lyrics in the tag?


Also, when saving downloaded lyrics to the tag: ANSI or UNICODE?

Thanks again. If I find an answer, I'll report back just in case anyone else has had this issue. (Though it doesn't look like it; that's what I get for having uncommon music; "popular" songs get populated with lyrics automatically, I discovered...)

Have a great weekend!

lorie

drjboulder
Posts: 1119
Joined: Mon Apr 09, 2007 12:03 am
Location: Boulder, Colorado, USA

Post by drjboulder » Sat Jan 12, 2008 7:35 pm

lorie wrote: Any thoughts on the message in the Open lyrics dialog:
"No suitable lyrics found"
even when there are lyrics in the tag?
Are you pushing the "No Suitable Lyrics Found"? in the download dialog box? If so, this is where it is coming from. If you select "Cancel", you will not see that listed as an option in the Open Lyrics dialog box.
lorie wrote:"popular" songs get populated with lyrics automatically
Be careful with that one. you will get a lot of wrong lyrics that way. :(
D Rock
Image
MediaMonkeyGoldv3.0.3.1183
Vista Home Basic|4thGen 20GPod
Zune Small Player Skin w/ Aqua 4 Player Mod
Backup | Last FM Node | Scrobbler DJ | TopTracks | StayInSameStyleDJ
RadioDJ | RadioFreeMonkey | PrettyPictures | MiniLyricsEmbedder
LyricsViewer | Lyricator | LyricsPlugin | VisualizationEmbedder | MonkeyRok
RightClickForWeb | WebSearchPanels | WebNodes | MagicNodes | FavoritesNodes
NowPlayingArtNode |AutoRateAccurate | TaggingInconsistencies
AdvancedDuplicateFind&Fix | CaseModify | PlayHistory&Stats | Etc...

lorie
Posts: 32
Joined: Fri Jan 04, 2008 11:58 am
Location: NW USA

Post by lorie » Sat Jan 12, 2008 7:56 pm

drjboulder wrote:
Are you pushing the "No Suitable Lyrics Found"? in the download dialog box?
No, not pressing the button; the line is already there. Thanks for weighing in. If you have any other ideas as to what I'm doing wrong, just shout...

So far, there is no rhyme or reason.

And as for the "wrong lyrics" I don't have very many "popular" songs so that shouldn't be much of a problem... (Turned into my parents: "That's not music, it's noise, etc...)

lorie

lorie
Posts: 32
Joined: Fri Jan 04, 2008 11:58 am
Location: NW USA

Post by lorie » Mon Jan 14, 2008 2:16 pm

UPDATE:

The support staff at Crintsoft sent a link to a newer version; the problem was a bug and it is now solved...

The version number is 5.6.3376

Thanks everyone on this forum for your efforts in getting it straigtened out.

lorie

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Post by nohitter151 » Mon Jan 14, 2008 4:24 pm

Ah, I should have asked which version you were running. I was running the newest which explains why it worked for me. Glad you got it sorted out!
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Post Reply