Auto-Sync

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

gab
Posts: 328
Joined: Tue Oct 11, 2005 1:20 pm

Auto-Sync

Post by gab » Mon Apr 21, 2008 2:04 pm

I am syncing a lossless library to an archive folder on my PC using the USB device plug-in. Every time I run the sync I get a dialog box that tells me that I have 11,000 files on the device that are not in my library (and gives me the option of deleting the files - ouch!). The 11,000 files are actually the songs in my library but the "device" (the folder on my hard drive) is empty. It's almost like MM3 is treating the source files (which are in my library) as the destination location. Any ideas?

Teknojnky
Posts: 5533
Joined: Tue Sep 06, 2005 11:01 pm
Contact:

Post by Teknojnky » Mon Apr 21, 2008 2:08 pm

do you have checked in the auto-sync configuration for that device, "auto-sync tracks from the device to the pc" ?

gab
Posts: 328
Joined: Tue Oct 11, 2005 1:20 pm

Post by gab » Mon Apr 21, 2008 3:26 pm

I did originally and then I unchecked it and still get the message. Also the device is empty so I thought it shouldn't matter since this is the first sync (otherwise you'd always delete the files on the source device during the first sync). In any event, it is unchecked and I still get the message.

wonko
Posts: 6
Joined: Sat Apr 26, 2008 3:20 am

Post by wonko » Sat Apr 26, 2008 3:30 am

I've just been trying the same thing and got the same worrying dialogue.
I suspect it's because I set the destination directory as being on the same drive as where my main flac/mp3 files are. My guess is that the sync routine scans that whole destination drive and offers to let you delete any music file that would not be synced.
A quick fix I've just tried was to map a new network drive to the target folder and use that - it seems to work.
Now I've got to work out how to use the auto-coversion options to convert all the files to mp3s of suitable bitrate.
Hope this helps javascript:emoticon(':D')
javascript:emoticon(':D')

gab
Posts: 328
Joined: Tue Oct 11, 2005 1:20 pm

Post by gab » Sun Apr 27, 2008 5:33 pm

I'm glad I'm not the only one with the problem. I'm not sure I understand the fix you described. Are you syncing to a folder on the network?

wonko
Posts: 6
Joined: Sat Apr 26, 2008 3:20 am

Post by wonko » Mon Apr 28, 2008 6:02 am

OK sorry if I was too cryptic. I'll try and explain what I did.

I keep all my music on a separate M: drive. My PC also acts as a server to other PCs and Squeezeboxes around the house, so the M: drive is shared (read permissions only!)

Initially I tried to set up the USB mass storage device to use a new, empty, directory M:\mp3 as the destination (in device profile, device configuration, I set the drive letter as "M" and prefixed the "Sync tracks to" with "\mp3\"). When I tried it I got the scary message offering to delete files from the M: drive.

So I thought I'd try it with the destination set to be a whole drive instead of a sub-folder (as that's probably what was in mind for USB pendrives etc.). There would be lots of ways of trying this (use a real pendrive or empty USB hard disk, use a separate physical hard disk or partition and assign it's own drive letter) but the easiest way for me was to set up M:\mp3 as a network share, and to then map an unused drive letter ("I:") to this share.

The net result (excuse the pun) is that if I browse M:\mp3 or the I: drive then I'm viewing the same files. In MM I changed the USB plugin to use the "I" drive letter, removed the "\mp3" from the start of the "sync tracks to" and it all seemed to work.

So to answer your question, yes I'm syncing to a folder on the network. It just happens to be on the same PC as MM is running on...

I wouldn't suggest that you use this solution unless you're reasonably familiar with networking and security etc.

Going back to MSDOS days you could do the same thing using the subst command - a quick search suggests this can be made to work on XP at least.

Hope this helps and makes some sense.

gab
Posts: 328
Joined: Tue Oct 11, 2005 1:20 pm

Post by gab » Tue Apr 29, 2008 7:51 am

Thank you for taking the time to provide the detail of your solution. I'll probably heed your warning (I'm not very familiar with networking) but your explanation did help my understanding. Hopefully the developers will address this issue.

Post Reply