Page 1 of 1

tracks from m-z appear to be lost from library

Posted: Mon Aug 25, 2008 3:40 am
by drsfp
For some reason Mediamonkey's library has 'lost' all files from M onwards. They are still present on my harddrive, but rescanning the folders doesn't result in the files being added to the library again. I'm using Mediamonkey 3.0.3.1183. Is anyone familiar with this problem and knows how to fix it? I don't want to empty my library and rescan everything because I fear I will lose all playcounts etc. I hope anyone can help.

Thanks,
drsfp

Re: tracks from m-z appear to be lost from library

Posted: Mon Aug 25, 2008 10:07 am
by Lowlander
Can you confirm that when you click on the Artist node (give MediaMonkey time to load all songs) that the songs are no longer in the database? Can you confirm the same when using the Location node to browse to the music?

If you can confirm that the music is no longer in your library can you try and locate them using the My Computer node in MediaMonkey? Try to see if one of these missing tracks plays in MediaMonkey.

Did you do any file moving/renaming outside of MediaMonkey?

Re: tracks from m-z appear to be lost from library

Posted: Mon Sep 01, 2008 6:53 am
by drsfp
Thanks for your reply. Sadly I found out that I did wipe the tracks of the harddrive... MM just left the folders on there, which were all empty. Gonna take me a while to recover everything :(

Re: tracks from m-z appear to be lost from library

Posted: Mon Sep 01, 2008 7:34 am
by rovingcowboy
oh shucks no backup cdroms? ouch!!! :(

i burn back up cdroms after i get enough new songs in the system to fill up a few cdroms.
got about 200 back up cdroms now., they have come in handy. but they don't hold all the tag info on the earlier back up disks. but thats easier to put in then re ripping the songs. :wink:

Re: tracks from m-z appear to be lost from library

Posted: Mon Sep 01, 2008 9:52 am
by Lowlander
Have you checked your Recycle Bin to see if any tracks reside there? If so just restore them and have MediaMonkey scan them again using Add/Rescan Tracks.

Re: tracks from m-z appear to be lost from library

Posted: Wed Sep 03, 2008 3:11 am
by drsfp
I have backups luckily... Most is on an old hard drive, which has some problems of its own. The rest is on dvds somewhere. But re-tagging all the songs is taking weeks... Time to buy an extra external hard drive! Thanks for the support though;)!

Re: tracks from m-z appear to be lost from library

Posted: Wed Sep 03, 2008 9:39 am
by Lowlander
The problem is why did these tracks disappear? Understanding this can help prevent this issue in the future.

Possible MediaMonkey causes:
- You selected remove and allowed Remove from Library
- You applied Auto-Organize Files and chose a mask that resulted the tracks to be overwritten
- You synchronized incorrectly to a portable device

Other causes
- Hard drive failed
- Windows messed up
- Other media application messed up

Re: tracks from m-z appear to be lost from library

Posted: Thu Sep 04, 2008 5:47 pm
by Benn
I use an ext. HD for my backups, this script http://mediamonkey.com/forum/viewtopic. ... lit=backup may interest you. I also experienced what you describe, about a year ago, due to my old ex. being corrupted (dodgy USB i think), so DVD's and such are the safest way I guess.