tagging problems and observations

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

bloomer
Posts: 10
Joined: Fri Jan 01, 2010 5:13 am
Location: Melbourne, Australia

tagging problems and observations

Post by bloomer » Fri Jan 01, 2010 11:39 am

I've been using MM3 for about two weeks now. I've come up against a number of issues that seem to have many different responses in the forums over time and would like to get some clearer answers now.

I'm running MM 3.2.0.1294 under XP-SP3. The library is on a networked harddrive (FAT32), PC and drive are wired, not wireless. All files are OGG.

1. Adding/modifying a tag for the current song from Now Playing causes the song to jump twice: after 12 secs it jumps back to the music at the time when I clicked the stars, it then plays 14 secs, then jumps to the correct music for the current time(x+12+14). The time display counts upwards second-by-second as normal throughout this. Settings when this occurs: YES update tags when editing properties, YES & NO modify timestamp. This might just apply to OGG files.

2. Changing a tag takes one to two minutes to update each OGG file but just a second or two for MP3s. MM3 is much much slower to update tags than Songbird.

3. If you change a tag with NO update tags when editing properties, and then rescan the files, the tags are not updated (verified using mp3tag). This is also true if you change setting to YES update tags when editing properties immediately before the rescan.

4. I can't see how in MM3 you can verify that the tags have actually been written to the file rather than just the database.

5. MM3 reads ratings made by Songbird, but as "0 stars" because Songbird 1.3 is using a 1-5 scale, so "5" is read as being in the lowest bracket on the MM3 0-100 scale. Songbird can't interpret MM3 ratings.

I hope these observations are useful and maybe someone can explain some of these (or tell me if I'm doing something wrong).

paulmt
Posts: 1170
Joined: Tue Jul 18, 2006 6:06 pm

Re: tagging problems and observations

Post by paulmt » Fri Jan 01, 2010 2:16 pm

bloomer wrote:> 1. Adding/modifying a tag for the current song from Now Playing causes the song to jump ... This might just apply to OGG files.
No - this has been problem on various formats for quite a few years.
What input plugin are you using. The effect you describe is a well documented issue with MAD plug-in.
Try changing back to the default (if this is a possible cause)
MediaMonkey 3.2.4.1304 Gold Lifetime
Hardware: Intel Core 2 Quad 3.33GHz, 8Gb Ram, 2tB Internal Storage, 2tB External Storage (USB & eSATA)
Software: Windows 7 Ultimate x64, FireFox v3.6.x, ThunderBird v3 x64, MailWasher Pro v6.5, Kaspersky Internet Security 2010
Backups by Karens Replicator v3.5.12,

bloomer
Posts: 10
Joined: Fri Jan 01, 2010 5:13 am
Location: Melbourne, Australia

Re: tagging problems and observations

Post by bloomer » Fri Jan 01, 2010 6:50 pm

ADDED: The original post has now been resurrected by a moderator and the normal responses continue about five posts further down (here).

Why was this post edited so severely that two points in the original post are missing and someone else's comments are now presented as my own? I would add that the description that I wrote of the problems was intended to help other people see what the symptoms and causes might be. Now it's just truncated and abbreviated so that barely helps anyone.
Last edited by bloomer on Fri Jan 01, 2010 9:59 pm, edited 1 time in total.

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Re: tagging problems and observations

Post by Bex » Fri Jan 01, 2010 7:42 pm

I just checked the logs and no one has altered your post. You must have made some kind of error when you wrote your first post.
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

bloomer
Posts: 10
Joined: Fri Jan 01, 2010 5:13 am
Location: Melbourne, Australia

Re: tagging problems and observations

Post by bloomer » Fri Jan 01, 2010 8:25 pm

Bex wrote:I just checked the logs and no one has altered your post. You must have made some kind of error when you wrote your first post.
Please check your PM. The post was radically truncated and the other person added in their comments -- this is clearly visible to you in the first post... that sort of thing doesn't happen by "some kind of error".

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Re: tagging problems and observations

Post by Bex » Fri Jan 01, 2010 8:35 pm

Actually, when I rechecked the moderator log I saw that chrisjj has done some editing in your post. (I wonder how I could miss that the first time I looked.) Send him a PM and ask him why. (He has done that in error before.)
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Re: tagging problems and observations

Post by Bex » Fri Jan 01, 2010 8:42 pm

I think I see what has happened.
crisjj incorrectly pressed the moderator button "Edit" instead of the Quote button and then he wrote his answers, thinking he was in a reply. He has done that mistake before and I'm sure he will apologize for his mistake.
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Re: tagging problems and observations

Post by Bex » Fri Jan 01, 2010 8:51 pm

This post is from chrisjj:
1. Adding/modifying a tag for the current song from Now Playing causes the song to jump ... This might just apply to OGG files.

No - this has been problem on various formats for quite a few years.

> 4. I can't see how in MM3 you can verify that the tags have actually been written to the file rather than just the database.

Tree > Files to Edit > Unsynchronized Tags is I think intended for this, but I have found it to be severely bugged.

> 5. MM3 reads ratings made by Songbird, but as "0 stars"

MP3 rating storage is unstandardised. MM's claim that its storage is "Defacto-Standard" is false.
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Re: tagging problems and observations

Post by Bex » Fri Jan 01, 2010 8:53 pm

I moved chrisjj's answer to a new post and reinstated your original post which you PM:ed me! :)
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: tagging problems and observations

Post by chrisjj » Thu Jan 24, 2013 1:53 pm

Just stumbled upon this now.
Bex wrote:I think I see what has happened.
crisjj incorrectly pressed the moderator button "Edit" instead of the Quote button and then he wrote his answers, thinking he was in a reply. He has done that mistake before and I'm sure he will apologize for his mistake.
Indeed he will! Sorry bloomer and thanks Bex for the fix-up.
Chris

Post Reply