MM ";" artist seperator and XBMC

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

Belgrath
Posts: 71
Joined: Sat Oct 27, 2007 6:14 pm

MM ";" artist seperator and XBMC

Post by Belgrath » Fri Jul 16, 2010 4:05 pm

Hi all,

Long time user of MM, but new user of XBMC. Is there anyone here that uses both programs as I'm trying to figure out how to get XBMC to recognize our ; seperator when it comes or artist,album artist, tags.

Many thanks ahead of time.

Belgrath
Posts: 71
Joined: Sat Oct 27, 2007 6:14 pm

Re: MM ";" artist seperator and XBMC

Post by Belgrath » Mon Jul 19, 2010 10:43 am

No XBMC users here?

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Re: MM ";" artist seperator and XBMC

Post by Bex » Mon Jul 19, 2010 10:52 am

I saw your posts at xbmc's forum. MM displays the configured multiple separator (default is ;) in the library but that is not what is written to the tag of the file. For mp3 I believe it's a / that is the standard. Try to change the setting in xbmc from ; to / (as others already have proposed) and I'm sure it'll work.
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

Belgrath
Posts: 71
Joined: Sat Oct 27, 2007 6:14 pm

Re: MM ";" artist seperator and XBMC

Post by Belgrath » Mon Jul 19, 2010 8:30 pm

Bex wrote:I saw your posts at xbmc's forum. MM displays the configured multiple separator (default is ;) in the library but that is not what is written to the tag of the file. For mp3 I believe it's a / that is the standard. Try to change the setting in xbmc from ; to / (as others already have proposed) and I'm sure it'll work.
Yeah I've tried a few things.

my advanced settings is set to the following

Code: Select all

<advancedsettings>
  <musiclibrary>
    <itemseparator>; </itemseparator> 
  </musiclibrary>
</advancedsettings> 
Each time I update the advanced settings I shutdown XBMC, nuke the music database and rebuild a new one. I've tried whitespaces in the advanced file, I've tried / \ with and without various quotes etc etc. I unfortunately continue to see non separated artists :(

arghhhh. I'm sure its something silly that I'm doing. Do you have an advanced settings file... if so can you post a clippet of it?

Thanks ahead of time,
Belg

Belgrath
Posts: 71
Joined: Sat Oct 27, 2007 6:14 pm

Re: MM ";" artist seperator and XBMC

Post by Belgrath » Mon Jul 19, 2010 11:11 pm

figured it out.. MM actually stores a / in the actual MP3 and not a ;
And I had my settings file in the wrong directory :p

Post Reply