Assertion Failure..

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

marcsansoucie
Posts: 2
Joined: Sun Jan 22, 2012 8:45 pm

Re: Assertion Failure..

Post by marcsansoucie » Mon Jan 30, 2012 4:55 pm

I encountered the same syndrome as I just upgraded from 3.2.2 (or 3.2.3?) to 4.0.2.1462. Assertion Failure with reference to SQL script on M: drive (which I don't have). I keep my music and MM database on a fixed hard drive that Windows 7 labels as J.

I tried the beta of 4.0.3.1466, following your instructions to put the MM3 db in place, and it failed in the same way.

I just installed the debug version of 4.0.3.1466, putting the old MM3 db in place, and surprise - no failure! So I don't have a debug log to submit. Maybe that's a bad thing, or maybe I'm just working now and should keep quiet and wait for the official 4.0.3 release.

FYI, my MM db is about 81Meg, about 25,000 tracks of varying kinds and formats.

Lowlander
Posts: 46408
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Assertion Failure..

Post by Lowlander » Mon Jan 30, 2012 5:02 pm

Those who can should submit a debug log (step 4b) to support: http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=69
and reference Bug: http://www.ventismedia.com/mantis/view.php?id=9042
Lowlander (MediaMonkey user since 2003)

Peke
Posts: 12595
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Assertion Failure..

Post by Peke » Tue Jan 31, 2012 6:01 am

@marcsansoucie
I think when you want to update some app from one mayor version to new major version it is always advisable to firstly install latest old version in MM case 3.2.5, maintain library and than install MM4 in separate folder not on top old one.

It is unwritten rule that major updates can make issues see for example transitions from Win XP -> 7

Please keep us posted.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Rednroll
Posts: 319
Joined: Mon Feb 02, 2009 9:11 pm

Re: Assertion Failure..

Post by Rednroll » Sat Feb 25, 2012 2:40 pm

Sign me up on the list of users experiencing the Assertion Failure M: Drive path error. I just tried to upgrade today.

Steps taken during upgrade:
1. In previous latest v3.2.5 MM went to File>Maintain Library. Let MM do it's thing, and then closed out MM.
2. Backed up MM Install folder files, dB file,MediaMonkey.ini, entire music library to a separate HDD.
3. Installed MM v4.0.3.1476, over the top of previous version. (Now that I found this thread, this sounds like where my mistake happened. Also note, that's the Default install location that the MM v4.0 installer gives you. My thought in doing that, is that is probably what I wanted to do, since that's where all my scripts are located and didn't want to have to go through re-installing scripts also.)
4. Saw the Assertion fail error right after MM installer performed the MM.db update process.
5. Ran MM v4.0.3.1476 and I receive the Assertion Failure error anytime I click on the "Music" node, where it won't expand and show my music library.

The strange thing is, is that although it seems like MM v4.0 is not finding my music library, if I click on my Playlists which were created in v3.2, they all appear and the music files in the playlists show up and playback with no problem.

From reading this thread now, it sounds like a work around solution would be to replace my database file with the one I backed up.....but here's what I ended up doing instead.

1. I went to the "My Computer" node in the MM browser and browsed to where my music was located.
2. I browsed to a folder which contained "some" of my music files, right clicked and selected "Add/Rescan Tracks to Library".

Here's a picture of the folder I chose to do the Rescan....Note, I decided not to do an entire Rescan of the top "Music" folder where my entire Music for my library is located, since I have over 10K songs. This was more of a test to see what would happen.
Image

Here is the Rescan Message that MM provided. Note....MM added my entire library of 10K+ songs, although I didn't ReScan the folder that contained all my songs....which would have been the top level "Music" folder shown in the tree view. I just Rescanned the "Oldies" folder which only contains 271 Songs of my 10K+ library.
Image

3. I then restarted MM.

So, add this as a work around for anyone experiencing this problem. It seems much easier than replacing your MM.dB file. Especially, if you didn't happen to back it up before the upgrade of v4.0.

Work Around Steps:
1. Goto MyComputer Node in MM
2. Browse to a folder which contains some of your music files.
3. Right Click and select "Add/Rescan....."
4. Restart MM

So now, I am no longer getting the Assertion Failure error message when I click on the Music Node, where my entire music library now shows up when I click on the "Music" node.

The only error I'm getting now, is when I 1st start up MM, it gives me an error which seems to be tied to the "AdvancedDuplicate Find and Fix" script.....
Image

I tend to use this script quite often. So....off I go now to try and find a thread hopefully with that discussion and a solution for a work around. :lol:

PetrCBR
Posts: 1644
Joined: Tue Mar 07, 2006 5:31 pm
Location: Czech
Contact:

Re: Assertion Failure..

Post by PetrCBR » Sun Feb 26, 2012 12:07 pm

Can you send me your MM3 database and ini file ? Can you remember what assertion pops up in steps 4 and 5 ?

Rednroll
Posts: 319
Joined: Mon Feb 02, 2009 9:11 pm

Re: Assertion Failure..

Post by Rednroll » Sun Feb 26, 2012 8:38 pm

PetrCBR wrote:Can you send me your MM3 database and ini file ? Can you remember what assertion pops up in steps 4 and 5 ?
Hi PetrCBR,
I wish you had posted your request sooner. Today, I went through and figured out the problems I was having with the script mentioned above and got that all worked out. Right after that, I decided to again perform a backup since it seemed I had everything figured out for the transition of v3>v4. During my backup I overwrite my previous backup data.

I did notice, that MM seemed to make a copy of my MM.DB file, labeled with a "Pre4" extension. I'm just not certain if this is what you would need now. I do have an additional backup copy of MediaMonkey.ini file I keep in a separate archive location. So no problem there.

Image

The assertion error that popped up, is the one everyone else seems to be mentioning. Sorry, I didn't screen capture that one. It was "Assertion failure (M:\Sources\MediaMonkey401MM\MP3Datab\SQLiteDB.pas, line 1976)" . Like others mentioned, I never had an "M:" drive on my system. There was one other error that popped up during the install right before this, before the Database update process kicked off during the installation. Something along the lines of a "playback device" error message. Sorry, that error message I didn't screen capture either, and after I closed it out, it never appeared again and playback seemed fine.
Last edited by Rednroll on Sun Feb 26, 2012 9:21 pm, edited 3 times in total.

Rednroll
Posts: 319
Joined: Mon Feb 02, 2009 9:11 pm

Re: Assertion Failure..

Post by Rednroll » Sun Feb 26, 2012 8:59 pm

Here are the links to the requested files.

MM.DB File:
http://www.mediafire.com/file/avacfh60i ... MM.DB.Pre4

MM.INI File
http://www.mediafire.com/file/kcrllst9x ... Monkey.ini

For your reference. I keep MM installed on a portable HDD which is always assigned as my "T:" drive.
Here are the paths of each item.
MediaMonkey Install Folder with MediaMonkey.EXE file= T://MediaMonkey/
MediaMonkey.INI location= T://MediaMonkey/
MM.DB file Location= T://MediaMonkey/All Users/Application Data/Media Monkey/
Music Library Location= T://Music

Teri Floyd

Re: Assertion Failure..

Post by Teri Floyd » Sat Apr 21, 2012 1:41 am

I also just upgraded (from 3.2 to 4.something) and got the same assertion error as everyone else on this string. However, I am not a computer geek who is using MediaMonkey for everything musical. I'm a quasi-Audiophile who uses Sonos for the listening to flacs and MediaMonkey as a fairly straight forward organization system for a large collection. Can someone simply send me clear instructions on what to do? The computer that I am on has mirrored harddrives and is running Vista. You may want to send me instructions on how to take screen shots as well as I do not believe that Vista has the handy "snipping tool" that Windows 7 has. The database which is labeled as simply "MM.DB" without a number on it is located on my C drive in the application area for MediaMonkey as it about 20 MB in size.

Thanks, Teri

Prompel
Posts: 2
Joined: Wed Apr 18, 2012 2:51 am

Re: Assertion Failure..

Post by Prompel » Sun Apr 22, 2012 12:39 am

I just tested out a portable installation of 4.0.3, and got the same assertion failure:

Code: Select all

Assertion failure (M:\Sources\MediaMonkey403Official\MP3Datab\SQLiteDB.pas, line 1976)
The string "M:\Sources\MediaMonkey403Official\MP3Datab\SQLiteDB.pas" is found in "MediaMonkey.exe" and "MediaMonkey (non-skinned).exe", in unicode format. So, obviously not my "M:" drive. :wink:

The reference is of course to the original source code at Ventis Media, or wherever the developers are compiling the code.

The error occurs with "DBName=\\Server\Music\mm.db" and "DBName=..\..\Documents\Music\mm.db". If I remove the "DBName=" entry, and copies my "mm.db" file into the "Portable" folder, then the update process works flawlessly.

Possible workaround: Install a completely default install of MM4, copy the "mm.db" file to wherever MM4 expects to find it, and run MM4. If all goes well, then copy the updated "mm.db" back to where it belongs.

DC
Posts: 89
Joined: Sat Jul 24, 2004 1:01 pm

Re: Assertion Failure..

Post by DC » Sat Jul 21, 2012 1:37 pm

FWIW, here's another one. Upgraded today from 3.2.5.1306 to 4.0.6.1501. After upgrading the database, first I got this error message:
Error during player initialization.
Then, after having setup start MM it would give me this error:
Assertion failure (M:\Sources\MediaMonkey403MM\MP3Datab\SQLiteDB.pas, line 1976)
Curiously, the file path seems to indicate an older version,not 4.0.6. Everything seems to work normal it seems after clicking away those message boxes - or I did not yet find any problem it may have caused. Should I be worried? What is the assertion about if I may ask?

PS: the upgrade instructions on the site say that I would have to point MM4 in the inifile to my moved database location. I did not have to do that. Can you confirm that autodetection for this was added, maybe somewhere between 4.0.0 and 4.0.6?

Post Reply