MM playback freezes

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

ashenkin
Posts: 138
Joined: Sun Oct 30, 2005 12:03 pm

MM playback freezes

Post by ashenkin » Wed Oct 14, 2015 6:17 am

Hi all,

Strange problem cropped up in the past month or two. MM playback will occassionally freeze. Pressing pause/play doesn't fix it. I have to close and re-open MM to get it working again. No idea what's happening, and no idea how to debug. Nothing of note appears in the windows event log... any ideas how to look into this? I run the same setup on my laptop with no problems; not sure why it's happening on my desktop...

Thanks in advance...

Win 7 Ent x64
MM 4.1.9.1764 Gold, running with WASAPI exclusive mode to Fiio E17 via USB

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: MM playback freezes

Post by nohitter151 » Wed Oct 14, 2015 10:35 am

MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

ashenkin
Posts: 138
Joined: Sun Oct 30, 2005 12:03 pm

Re: MM playback freezes

Post by ashenkin » Thu Oct 15, 2015 8:39 am

Thanks. Caught the problem with Dbgview, but not able to log into the help desk (doesn't take my MM creds, and points me back here to create an account, so...).

So, hope I'm not breaking protocol too badly by posting here.

A clip around the freeze event can be seen here: http://pastebin.com/eiJgHfNr

I *think* the important lines are these:

Code: Select all

00442642	484.49291992	[5364] Winamp Playlist sim - message 49925 left to the default processing	
00442643	484.49328613	[5364] Winamp simulation window received messsage 49925	
00442644	484.49734497	[5364] Winamp Playlist sim - message 49925 left to the default processing	
00442645	484.49737549	[5364] Winamp simulation window received messsage 49925	
00442646	495.17156982	[5364] Winamp Playlist sim - message 49925 left to the default processing	
00442647	495.17199707	[5364] Winamp simulation window received messsage 49925	
00442648	495.17758179	[5364] Winamp Playlist sim - message 49925 left to the default processing	
00442649	495.17761230	[5364] Winamp simulation window received messsage 49925	
00442650	501.06030273	[5364] WASAPI: We have not got data for too long, probably device was disabled or unplugged	
00442651	501.06039429	[5364] WASAPI: New track not starting, finishing playback thread.	
00442652	501.06243896	[5364] WASAPI: Output thread is terminating	
00442653	501.06250000	[5364] WASAPI: Output thread is terminated	
I've been playing music the whole time... any thoughts?

thanks...

Peke
Posts: 12472
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: MM playback freezes

Post by Peke » Fri Oct 16, 2015 5:23 am

Problem looks like "WASAPI: We have not got data for too long, probably device was disabled or unplugged" Try to change output plugin
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

ashenkin
Posts: 138
Joined: Sun Oct 30, 2005 12:03 pm

Re: MM playback freezes

Post by ashenkin » Mon Oct 19, 2015 4:53 am

hmm, yeah, but... I want to use WASAPI... any other ideas about how to debug what's going on, or how to get WASAPI working?

ashenkin
Posts: 138
Joined: Sun Oct 30, 2005 12:03 pm

Re: MM playback freezes

Post by ashenkin » Mon Oct 26, 2015 3:58 am

sorry to bump, but wondering if anyone had any further thoughts on this... thanks...

Peke
Posts: 12472
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: MM playback freezes

Post by Peke » Wed Oct 28, 2015 4:43 pm

That error is System wide not for MMW, it is possible that some app requested Exclusive mode which makes MMW fail.

Try to reinstall drivers from manufacturerrs site and settings for sound card.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Post Reply