\INIFILE parameter ignored

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

TheAncient
Posts: 25
Joined: Sat Mar 08, 2008 4:13 pm

\INIFILE parameter ignored

Post by TheAncient » Sat Jul 02, 2016 1:38 pm

When invoking MediaMonkey via a desktop shortcut, I would like to be able to use the \INIFILE command line parameter. i.e. the TARGET of of the shortcut should contain
C:\Program Files (x86)\MediaMonkey\MediaMonkey.exe" /INIFILE="\\serverpath\MediaMonkey_Common.ini"
Madiamonkey appears to completely ignore this parameter and instead ALWAYS use the default ini file location C:\Users\TheAncient\AppData\Roaming\MediaMonkey\MediaMonkey.ini
I verified this by re-naming the default .ini file - Mediamonkey simply creates a new one with the default name in the default location.
I have had this problem before but it was never properly resolved (http://e8d327b5fb.site.internapcdn.net/ ... =1&t=81572)
Can anyone help?

Peke
Posts: 12204
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: \INIFILE parameter ignored

Post by Peke » Sat Jul 02, 2016 9:34 pm

Hi,
Have you tried to map "\\serverpath\"? and see if that works?
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

TheAncient
Posts: 25
Joined: Sat Mar 08, 2008 4:13 pm

Re: \INIFILE parameter ignored

Post by TheAncient » Sat Jul 02, 2016 11:42 pm

I have attempted to specify an INI file on a network drive using UNC nomenclature (\\server\path...) as well as
on a network drive using a mapped drive (M:\path...) as well as
on an external drive (D:\path...)
Not one of those options appears to work: it simply ignores the \INIFILE command parameter

(Elsewhere in the MediaMonkey documentation there are cautions against using mapped drives. That's why I usually stay away from them even though it would be practical to use them: One could probably map different drives (an external drive OR a network drive) to the same drive letter)

Peke
Posts: 12204
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: \INIFILE parameter ignored

Post by Peke » Sun Jul 03, 2016 9:02 am

I Just tried to replicate with no success it accepted INIFile command without any issues.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

TheAncient
Posts: 25
Joined: Sat Mar 08, 2008 4:13 pm

Re: \INIFILE parameter ignored

Post by TheAncient » Sun Jul 03, 2016 10:34 am

I'm glad it worked for you. Unfortunately that does not help me.
I am at the point where I am ready to build some sort of batch file to copy one of 3 ini files (one to point to "M", one for \\Server, and one for "D") over top of the existing mediamonkey.ini file. Oh yeah: I also uninstalled and re-installed MediaMonkey but I am still having the same problems.

I also ran into other problems which may or may not be related:

1. If my .ini file contains comments (lines prefixed by a semi-colon) Mediamonkey removes those lines as it re-writes the .ini file when it closes. I find that VERY annoying as I use comments to explain why I chose certain settings and to note alternatives such as different database locations.

2. Teamviewer appears to have a problem with MediaMonkey (or vice versa): If I start MediaMonkey first and then Teamviewer, everything works as expected. If I run Teamviewer first and then try to start Mediamonkey, Mediamonkey will not start. The error message is not informative at all and merely states "Mediamonkey has stopped working". This is only an issue when running the FULL version of Teamviewer. Everything works fine when using the HOST version of Teamviewer (run Teamviewer as a sevice)


I will open separate problems for these two issues - I am just mentioning them here in case they have any bearing on this problem.

Post Reply