Confusing Sorting Issue...

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

Confusing Sorting Issue...

Postby Agrajag » Tue Dec 05, 2017 3:37 pm

I'm sure this is something I goofed on, however I'll be darned if I can figure it out.

I'm working on cleaning up some artists and am working on Electric Light Orchestra right now.

Under Artist & Album Artist I have the following snippet:

(Title, Artist, Album)
....
Wild West Hero, Electric Light Orchestra, Out of the Blue
Without Someone, Electric Light Orchestra, Balance of Power
Xanadu, Electric Light Orchestra, All Over the World
Another Heart Breaks, Electric Light Orchestra, Time
Epilogue, Electric Light Orchestra, Time
From the End of the World, Electric Light Orchestra, Time

In other words, all of Electric Light Orchestra appears in this sort just fine until it gets to the end and suddenly nearly all (but oddly not two) tracks from the Album Time appear at the end of the list. I've looked over most everything in Properties and don't see the issue.

The Title is correct. The Artist is correct. The Album Artist is correct. The album is correct.

What are the most likely culprits for this screw-up on my part?
Agrajag
 
Posts: 193
Joined: Tue Mar 13, 2007 2:34 pm
Location: Cherry Hill, NJ

Re: Confusing Sorting Issue...

Postby Lowlander » Tue Dec 05, 2017 4:09 pm

What Column(s) are you sorting on?

Make sure that Album, Album Artist, Disc# and Track# are correct.
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43641
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Confusing Sorting Issue...

Postby Agrajag » Tue Dec 05, 2017 5:21 pm

Track seems to have been the offender. Not entirely sure which element, but I edited all of them and changed the field from, for example, "02" to "2/16".

That seemed to make it happy. NO idea. Oddly the two songs that didn't have the issue from the album were tracks "05" and "09". I thought it was the leading zero, but apparently not.
Agrajag
 
Posts: 193
Joined: Tue Mar 13, 2007 2:34 pm
Location: Cherry Hill, NJ

Re: Confusing Sorting Issue...

Postby Lowlander » Tue Dec 05, 2017 6:38 pm

No, leading zero doesn't cause sort issues.
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43641
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5


Return to Need Help? (mmw)

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 24 guests