'Last Played' Cleared When Rating Currently Playing Track

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

David Hillman
Posts: 7
Joined: Wed Jan 03, 2018 2:22 pm

'Last Played' Cleared When Rating Currently Playing Track

Post by David Hillman » Mon Jan 29, 2018 11:59 pm

I am a fairly new MM user, so ~95% of my library is unrated at the moment. I am working on that, but I have noticed a slightly annoying issue. Whenever I rate a track while it is playing, the 'Last Played' and 'Play Count' are reset ( in my case, usually to 'blank' and 'zero' respectively ) once the song finishes. If I wait until a few seconds after the song completes, and then rate it, everything is fine. This happens both when I rate the track within MMW and when I do so with MMRemote from my phone. But it also happens whether or not the MMRemote Server is running.

I am running MMW version 4.1.19.1859. I have only installed two extensions at this point; 'Find Currently Playing Track' version 1.3.2 and 'Played Date & Counter' version 1.2. The latter is obviously a suspect here, and when I uninstall it, the problem goes away.

So that's an easy fix... but I like the functionality of 'Played Date & Counter' and my understanding is that many people use it successfully. Would anyone happen to know why it doesn't work in my very basic setup? And/or, what I can change so that I can re-install 'Played Date & Counter' and still rate tracks while they play?

Thanks.

Lowlander
Posts: 44882
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 'Last Played' Cleared When Rating Currently Playing Trac

Post by Lowlander » Tue Jan 30, 2018 12:22 pm

I can't reproduce on 4.1.20. Are files from the My Computer node?
Lowlander (MediaMonkey user since 2003)

David Hillman
Posts: 7
Joined: Wed Jan 03, 2018 2:22 pm

Re: 'Last Played' Cleared When Rating Currently Playing Trac

Post by David Hillman » Tue Jan 30, 2018 2:38 pm

Lowlander wrote:I can't reproduce on 4.1.20. Are files from the My Computer node?
No, sir. They are either from the Music node, or from the Random Album playlist.

Thanks.

Lowlander
Posts: 44882
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 'Last Played' Cleared When Rating Currently Playing Trac

Post by Lowlander » Tue Jan 30, 2018 2:49 pm

Strange. You can capture it in a debug log (step 4b) and attach the log to a Support Ticket: http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=69
Lowlander (MediaMonkey user since 2003)

David Hillman
Posts: 7
Joined: Wed Jan 03, 2018 2:22 pm

Re: 'Last Played' Cleared When Rating Currently Playing Trac

Post by David Hillman » Tue Jan 30, 2018 6:06 pm

Hmmm... after some more testing, I now see two different failure modes. I will capture a debug log and create a ticket, but in the meantime, just going to document here.

First, I upgraded to MMW 4.1.20.1864. Then I downloaded and re-installed 'Played Date & Counter' version 1.2 ( same version I had previously ). I set the Elapsed Time threshold to 20 seconds ( which turns out to be interestingly important ).

Then I resumed testing using the 'Random Album' playlist, which has all my ~1k albums. I found that if I rated a track before the Elapsed Time threshold ( 20 seconds ), everything worked correctly. But, if I waited until beyond the threshold to rate the track, the Played Date and Count would be reset once the track finished playing.

So I thought I had a handle on it. Per the 'How to Report a Bug' instructions linked in the previous message, I tried to replicate the behavior with "a small set of tracks" instead of my entire library. So I selected one mostly-unplayed album from the Music node, and tried again. That album was Aimee Mann's 'Charmer', as you can see below. When I started testing with it, only Track 8 had ever been played ( a couple weeks ago ).

Image
http://planet-torque.com/mediamonkey/bug2.PNG (link to original image in case your screen truncates it)

For Track 1, I rated it before the 20 second threshold elapsed, and everything worked fine -- same as before. For Tracks 2 and 3, I waited until after 20 seconds... and here we see a second failure mode, the 'Last Played' is maintained correctly, but the Count was incremented twice.

I had never previously seen that happen. Now I'm going to try and replicate each, and get debug logs.

Here, for kicks, is a screenshot of some earlier testing. I played this album through in its entirety, every track start to finish. No tracks had ever been played previously. Different tracks were rated at different points, or not-at-all.

Image
http://planet-torque.com/mediamonkey/bug1.PNG (link to original image in case your screen truncates it)

Lowlander
Posts: 44882
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 'Last Played' Cleared When Rating Currently Playing Trac

Post by Lowlander » Tue Jan 30, 2018 6:51 pm

Are Play Counts not added by the Addon remembered? It sounds like it may be an issue with the way the Addon updates Play Count that causes the problem.
Lowlander (MediaMonkey user since 2003)

David Hillman
Posts: 7
Joined: Wed Jan 03, 2018 2:22 pm

Re: 'Last Played' Cleared When Rating Currently Playing Trac

Post by David Hillman » Tue Jan 30, 2018 9:17 pm

Not sure, but I just successfully logged what I will call Failure Mode 1 -- which is when the Last Played Date and Count are reset incorrectly. Ticket #QTR-966-54602 if anyone needs that.

I have zero idea why the failure mode is different when playing a playlist, versus when playing a single album... but I'm going to re-run that test and log it too.

Okay, there's a lot of wonky shit going on here. So, a couple minutes ago, this Otis Rush album looked like this ->

Image

I quit Media Monkey and restarted it. Now, it looks like this ->

Image

WTF.

Post Reply