Page 1 of 1

Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 5:12 am
by JOOP
Hallo,

ich nutze MM4 Gold - funktioniert wunderbar.

Nun habe ich die Song-Nummern meiner Musikdateien mit Hilde von MP3 Tag jeweils mit einer führenden Null versehen, die Dateinamen sind ebenfalls dahingehend geändert.

Auch nach einer Aktualisierung der mm-Datenbank tauchen aber in der Song# nicht die führenden Nullen auf, sondern lediglich 1...9 statt 01...09. Der Dateiname wird dagegen mit dem aktuellen Namen angezeigt. Auch in MP3 Tag tauchen die führenden Nullen auf, wenn ich das Album nach Speichern erneut einlese.

Woran kann es liegen, dass die führenden Nullen in MM4 nicht angezeigt werden ?

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 5:39 am
by MMuser2011
In welcher MM-Ansicht genau siehst Du die führende Null in der Song# nicht?

Bei mir sieht ein Suchergebnis so aus:
Image
Die ersten paar Einträge haben keine führende Null (weil diese Tracks nur einstellig sind), die Songs von «Alexander O'Neil» zeigen führende Nullen.

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 5:57 am
by JOOP
Hallo,

z.B. in der Albumansicht:

http://www.directupload.net/file/d/4882 ... rx_jpg.htm

Zum Vergleich gleiches Album in MP3Tag:

http://www.directupload.net/file/d/4882 ... 98_jpg.htm

In Playlists ebenfalls.

Sicher liegt es irgendwie wieder auf meiner Seite, nur wo ?

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 6:40 am
by MMuser2011
Was zeigt MM an, wenn Du z.B. die Eigenschaften (SHIFT+ENTER) des dritten Song "Now I Fall" anzeigen lässt?
Wird die Song# dann MIT oder OHNE führende Null dargestellt?

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 7:10 am
by JOOP
Eigenschaften werden OHNE führende 0 angezeigt. Ich habe auch schon MP3Val darüber laufen lassen, Ergebnis "o.k.".
Eigenartig. Es liegt also vermutlich irgendwie am Einlesen. Aber eine weitere Aktualisierung war ohne Erfolg.

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 7:41 am
by MMuser2011
Versuche mal 1 komplettes Album (oder auch nur 1 einzelnen Song) aus Deinem MM zu entfernen:
Markiere also das Album oder den Song und drücke die DELETE-Taste.
WICHTIG:
Wähle nun unbedingt die Option "nur Archiveintrag löschen", also auf keinen Fall die Datei selber löschen!

Danach liest Du das eben gelöschte Album oder den Song wieder neu ein.
INSERT-Taste drücken, Ordner mit dem Album oder dem Song auswählen, OK drücken.

Wie sieht es dann mit der Anzeige aus?

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 9:44 am
by JOOP
a) ...dann stimmt die Anzeige. Das bedeutet dann, dass ich alle Archiveinträge löschen und neu einlesen muss, oder ?
b) Woran kann es liegen, dass das Einlesen nicht alle "Eigenschaften" aktualisiert ?

P.S.: Das Einlesen eines einzelnen Ordners (=Album) funktioniert nicht. Er liest stets den gesamten Pfad (="Musik") nebst Unterordnern ein.

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 10:01 am
by MMuser2011
a) Wenn Du nicht 100'000nde Dateien neu einlesen musst, würde ich das für die geänderten Songs mit "nur Archiveintrag löschen" -> "neu einlesen" lösen.
Dabei gehe ich davon aus, dass Du in MM keinerlei Änderungen an Deinen Dateien vorgenommen hast?
Wenn doch, wirds schwierig, bzw. dann verlierst Du die Änderungen aus MM!

b) Aus unklaren Gründen scheint MM Deine extern aktualisierten Tags nicht neu in die DB einzulesen. Eine mögliche Ursache wäre das nicht aktualisierte Modifikationsdatum in Deinen Dateien. Dann erkennt MM nicht, welche Dateien er tatsächlich neu einlesen soll.

P.S.: Das funktioniert nur, wenn Du beim Einlesen zuerst links im Dialogfenster "Ordner scannen/aktualisieren" das richtige Unterverzeichnis auswählst (und alle darüber liegenden Verzeichnisse abwählst = das Häkchen wegmachst).

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 10:30 am
by JOOP
zu a) ich habe (irgendwo... :wink: ) eingestellt, dass Änderungen in den Eigenschaften in der Datei gespeichert werden - das hat bisher funktioniert. Daher denke ich, dass ich bei erneutem EInlesen alles wieder am richtigen Platz habe.... Oder habe ich einen Denkfehler ?

Jedenfalls hat es bei dem Album, bei dem wir es getestet haben, funktioniert, auch die automatische Playlist ist aktualisiert.

Es ist schon eine Menge, aber man kann das ja über Nacht laufen lassen.

zu b) Hm. Ich habe beim Ergänzen der führenden Nullen auch den Dateinamen aktualisiert (Albuminterpret-Album-Jahr-Track#-Titel.mp3). Im Windows Explorer erscheint das Datum der Aktualisierung.

zu P.S.: Verstanden, danke.

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 10:42 am
by MMuser2011
a) Wenn es im Testlauf für Dich passte, dann steht diesem Schritt nichts mehr im Weg.

b) Leider kommt mir da auch keine einleuchtendere Erklärung in den Sinn. Ich hab es aufgegeben, jeweils zu lange zu suchen und mache es mit löschen-> neu einlesen. Funktioniert immer.

Viel Erfolg.

Re: Song# - Führende 0 anzeigen

PostPosted: Sat Oct 21, 2017 10:44 am
by JOOP
Alles klar.

Erneut vielen Dank für Deine prompte und ausgiebige Unterstützung !