[SOLVED] iPhone upgrade - cannot use MM, please help.

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

Tr3mb1ay
Posts: 1
Joined: Thu Aug 22, 2019 10:44 pm

[SOLVED] iPhone upgrade - cannot use MM, please help.

Post by Tr3mb1ay » Thu Aug 22, 2019 11:16 pm

I've just spent the last 4 hours attempting to get MM to view my iPhone Xs (iOS 12.4) without any success.

Windows & iTunes sees my Apple device correctly but MM keeps giving me a popup stating: An iPhone connection was detected. Please install iTunes in order to sync this device.

All software has been reinstalled, all devices & computer rebooted several times, all software up to date as of today (August 22nd 2019). Attempted a factory reset on the phone as well as two different desktop/laptops. Is MM just not compatible anymore with iOS 12? I would have saved myself a lot of time by using iTunes but that might involve puking on a daily basis & stabbing myself in the eyes while waiting for a software that cannot handle 100,000+ music collection. Thanks for any other ideas, as I've ran out completely...

Lowlander
Posts: 46080
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: iPhone upgrade - cannot use MM, please help.

Post by Lowlander » Fri Aug 23, 2019 11:35 am

Make sure you have the desktop version of iTunes installed: https://www.mediamonkey.com/wiki/index. ... zation/4.0
Lowlander (MediaMonkey user since 2003)

harry66

Re: iPhone upgrade - cannot use MM, please help.

Post by harry66 » Sat Sep 14, 2019 4:53 am

i have exactly the same problem!

I have also reinstalled everything, Windows & iTunes ok, but MM message: "An iPhone connection was detected. Please install iTunes in order to sync this device."

I tried too CopyTrans, but CopyTrans can also not connect to the iPhone.

My configuration: Windows 7 / iPhone 6s (iOS 12.4) / MM 4.1.24.1883


I do not know how to continue :-(

BR Harry

Lowlander
Posts: 46080
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: iPhone upgrade - cannot use MM, please help.

Post by Lowlander » Sat Sep 14, 2019 12:07 pm

Are you sure you have the desktop version of iTunes installed and not the Windows Store version? The Windows Store version won't work: https://www.mediamonkey.com/support/ind ... -touchipod
Lowlander (MediaMonkey user since 2003)

harry66

Re: iPhone upgrade - cannot use MM, please help.

Post by harry66 » Sat Sep 14, 2019 1:36 pm

yes, i use Windows 7 ;-)

I have read and done all steps from the wiki (https://www.mediamonkey.com/wiki/index. ... zation/4.0)

But it works now !
I find the problem in your last Link (but not in the wiki):

- In the iTunes menu, go to Edit>Preferences>Devices and enable "Prevent iPods, iPhones and iPads from syncing automatically"


Many thanks Lowlander !!!

Harry

Peke
Posts: 12368
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: [SOLVED] iPhone upgrade - cannot use MM, please help.

Post by Peke » Sun Sep 15, 2019 4:05 pm

Hi,
We have never found why but on some PCs iTunes locks Device for exclusive use and no other application can recognize it.

As you pointed that option fixes it and also once it is plugged you can change default behavior on connection to DO NOTHING in order to prevent iTunes to start.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Post Reply