[Solved] artist name missing, but track is there....

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

[Solved] artist name missing, but track is there....

Postby markeh » Sun Jun 12, 2011 5:23 pm

I have a weird problem. One of the artists I sync to my ipod doesn't show up in the artist list. The music is there, I'm listening to it now, and I can find it other ways. But it doesn't show up in the artist listing. (I use the artist tag for composer with classical music)

It's chamber music by Luigi Boccherini, but I don't think the iPod is making an artistic comment :D

I have tried the obvious - changing the artist name to see if there is something strange about the characters in the artist name - but it made no difference.

Playing the tracks, the artist name shows up correctly.

Any suggestions?? I can't figure this out.

thnx

+++ more data +++

clean (both) tags and synchronize tags - no effect.

What is it about these tracks that causes them not to show up in the artist listing???







.
markeh
 
Posts: 246
Joined: Fri May 25, 2007 1:30 am

Re: artist name missing, but track is there....

Postby nohitter151 » Mon Jun 13, 2011 9:35 pm

I'm pretty sure the iPod uses album artist in the track listing, not artist.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
nohitter151
 
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA

Re: artist name missing, but track is there....

Postby lobojon » Thu Aug 04, 2011 10:59 am

Which means what exactly? I do not understand your reply nohitter. My artist and album artist fields are the same for the artists in question. Is this what you meant?

I have rebuilt my ipod database and several artist names do not show up under the view artists shortcut, but do show up once I click on the albums shortcut. I am still trying to find a thread that addresses this. I am sure it is out there in the forum, but I have had no luck so far.
Cheers
MM Lifer since 2008. Still apprentice (noob) level.
Windows 7 Ultimate 64bit
Toshiba Satellite laptop
Music collection of 2 TB located on an external hard
Spybot Search & Destroy / Iobit Anti Malware
Avast Antivirus Free Edition

I love the Monkey and the forum.
Thanks to all who provide advice, assistance, add ons and scripts. It is very much appreciated!
lobojon
 
Posts: 45
Joined: Sun Nov 02, 2008 11:02 pm

Re: artist name missing, but track is there....

Postby secretsubscriber » Sat Mar 30, 2013 1:23 pm

hello

Posting on this old thread because I've just experienced the same issue.
I reloaded all my music onto my ipod classic 160gb and I noticed that one of the artists doesn't show up under the Artist menu but the album is accessible.
Has anyone else experienced this?

Thanks
secretsubscriber
 
Posts: 1
Joined: Tue Nov 03, 2009 4:34 pm

Re: artist name missing, but track is there....

Postby dtsig » Sat Mar 30, 2013 1:28 pm

No, i am using a classic 160 also and all bits are there.

For one of the songs where the artist is missing, where do you have the artist name in the tags? Album Artist(s) and/or Artist(s)
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig
dtsig
 
Posts: 2739
Joined: Mon Jan 24, 2011 6:34 pm

Re: artist name missing, but track is there....

Postby Ansley240824 » Thu Apr 18, 2013 2:46 pm

I have the same problem guys

Certain artists tracks cannot be found under the artist tag, but are under album/genre etc, no idea why. I have managed to fix a few artists but just by chance and I still haven't figured out what exactly I had done, can't seem to recreate the fix with certain artists tho :/
Ansley240824
 
Posts: 3
Joined: Sat Apr 13, 2013 5:30 am

Artist missing on iPod Classic

Postby markeh » Sat Oct 10, 2015 7:49 pm

I posted this quite a while ago, in 2011. I can put tracks on my iPod, I know they get there, but they don't show up under the "artist" listing.
I can find the tracks by looking under album. I can also see them when I look at the iPod while its connected to MM.

viewtopic.php?f=12&t=58555&p=365088&hilit=artist+missing#p365088

I mostly have classical music, and use the artist field for the composer name (eg: Mozart). The album artist field either has the performer, or is blank.

I never got an answer, the problem has persisted.

Recently, I tried something different. It seems when the "artist" and "album artist" field match, the problem goes away. This has proven to be a weird problem and doesn't seem always repeatable.

So my question - how are these two fields synced to an iPod?? Do they need to be the same, is one used and one ignored, etc....

My stuff: iPod 160 Classic; MM 4.1.9.1764;Window 7

.
markeh
 
Posts: 246
Joined: Fri May 25, 2007 1:30 am

Some artists randomly disappear from iPod classic 160GB

Postby johnson_iv » Tue Sep 27, 2016 11:03 pm

Hi,

I've been successfully auto-syncing my MM library with my iPod classic for some time now.

Recently however, many artists have randomly disappeared from the 'Artists' listing on my iPod (approximately 75% of artists aren't visible). The files themselves are still on the iPod. They are accessible through the 'Albums', 'Songs' and 'Genre' listings, and through MM when connected to my PC. Everything appears to be working normally with this sole exception.

Newly added files appear correctly in the 'Artist' listing, and occasionally, re-tagging individual files and re-syncing solves the problem.

I've tried re-building the database without success. All 'Album Artist' tags are blank. Deleting and re-adding songs makes no difference.

This problem appeared out of the blue, and I can't identify any patterns that would explain why some files work as expected and others do not.

This appears to be a fairly common problem (similar unresolved cases listed below) and if anybody has any information that might help identify a cause, it would be greatly appreciated.

viewtopic.php?f=12&t=58555
viewtopic.php?f=12&t=76327
viewtopic.php?f=12&t=80487&p=405912&hilit=ipod+sync+artists#p405912

Running Windows 10, MM 4.1.13, mp3tag 2.78, iPod Classic 160GB (7th Gen)

Thanks
johnson_iv
 
Posts: 11
Joined: Tue Aug 30, 2016 12:43 am

Re: Some artists randomly disappear from iPod classic 160GB

Postby Peke » Wed Sep 28, 2016 4:42 am

You should update to 4.1.14 as it includes several iPod Classic improvements.
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
Peke
 
Posts: 10409
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia

Re: Some artists randomly disappear from iPod classic 160GB

Postby johnson_iv » Wed Sep 28, 2016 8:17 am

Thanks for the reply.

I've since downloaded MM 4.1.14 and tried rebuilding the database, deleting and re-adding problematic files, etc. with no success. The update seems to have made no discernible difference.

Do you have any further recommendations?
johnson_iv
 
Posts: 11
Joined: Tue Aug 30, 2016 12:43 am

Re: Some artists randomly disappear from iPod classic 160GB

Postby Peke » Wed Sep 28, 2016 10:04 am

Unfortunately only way to do more is to debug why and what is going on your PC and that can be done by opening Support ticket and supply Debug log as described in viewtopic.php?f=12&t=69
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
Peke
 
Posts: 10409
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia

Re: artist name missing, but track is there....

Postby markeh » Wed Sep 28, 2016 8:01 pm

The one thing I've tried that seems to work is to make sure the artist and album artist field exactly match. I don't know why this is.
markeh
 
Posts: 246
Joined: Fri May 25, 2007 1:30 am

Re: artist name missing, but track is there....

Postby johnson_iv » Thu Sep 29, 2016 4:07 am

My iPod worked perfectly fine for years without aligning the fields (I always keep Album Artist blank). And the problem randomly arose following an ordinary sync. The few Artists that still appear in the listing do not have matching fields. This can't be the sole factor.

Nonetheless I've gone through a subset of files and matched the two fields. All these files now appear in the Artist listing.

It might not solve the problem, and 'falsifying' every tag is less than ideal, but it seems to be the most consistent work-around solution for now
johnson_iv
 
Posts: 11
Joined: Tue Aug 30, 2016 12:43 am

Re: artist name missing, but track is there....

Postby Peke » Thu Sep 29, 2016 4:10 am

Hi,
Because some Apple devices do not distinguish Artist from Album Artist and actually use Album Artist and Compilation flag is sometimes interpreted incorrectly.

Main Problem with Debugging is that we would need clone of iPod Drive and library, along with sample files observing the issue and iPod classic can have GB of Data :(
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
Peke
 
Posts: 10409
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia

Re: artist name missing, but track is there....

Postby johnson_iv » Thu Sep 29, 2016 10:14 pm

Ah I see. Thanks for the explanation.

I've matched the two fields and my iPod is now working perfectly again.

I'm satisfied with this 'solution', and submitting a bug report is not necessary given the problems you highlighted.

Thanks
johnson_iv
 
Posts: 11
Joined: Tue Aug 30, 2016 12:43 am

Next

Return to Need Help with Device Synchronization?

Who is online

Users browsing this forum: No registered users and 9 guests