Can't Sync Playlist to Sony NWZ-E465

Get answers about syncing MediaMonkey 4 with iPods and other devices.

Moderator: Gurus

Lowlander
Posts: 54224
Joined: Sat Sep 06, 2003 10:53 pm
Location: MediaMonkey 5

Re: Can't Sync Playlist to Sony NWZ-E465

Post by Lowlander »

Have you made sure that in Supported Formats it only has PLA enabled? Feel free to add a screenshot of the Auto Conversion settings.
jasonblu
Posts: 14
Joined: Sun Mar 20, 2016 1:59 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by jasonblu »

Lowlander wrote:Have you made sure that in Supported Formats it only has PLA enabled? Feel free to add a screenshot of the Auto Conversion settings.
Thank You very much for going with me through this nonsense. I really appreciat appreciate it !

Here's screen. Maybe it's because that Im on free version of MediaMonkey?
Image
Lowlander
Posts: 54224
Joined: Sat Sep 06, 2003 10:53 pm
Location: MediaMonkey 5

Re: Can't Sync Playlist to Sony NWZ-E465

Post by Lowlander »

Looks good as far as Playlists go. However you'd also want some media formats listed in Support Formats as otherwise everything gets converted.

The problem you're facing was supposedly fixed: http://www.ventismedia.com/mantis/view.php?id=9216
jasonblu
Posts: 14
Joined: Sun Mar 20, 2016 1:59 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by jasonblu »

" We'd need a log to see what's going on there. I wouldn't expect m3u being synced when pla is selected in MM. "
I checked PLA box in Set Formats, but it still shows m3u.
http://postimg.org/image/c5q7crgb5/

How can I provide You log file?
Lowlander
Posts: 54224
Joined: Sat Sep 06, 2003 10:53 pm
Location: MediaMonkey 5

Re: Can't Sync Playlist to Sony NWZ-E465

Post by Lowlander »

Step 4b and send it to support in a ticket: http://www.mediamonkey.com/forum/viewto ... ?f=12&t=69
Lowlander
Posts: 54224
Joined: Sat Sep 06, 2003 10:53 pm
Location: MediaMonkey 5

Re: Can't Sync Playlist to Sony NWZ-E465

Post by Lowlander »

Can you capture the sync in a debug log (step 4b) and send the log to support: http://www.mediamonkey.com/forum/viewto ... ?f=12&t=69
jasonblu
Posts: 14
Joined: Sun Mar 20, 2016 1:59 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by jasonblu »

Lowlander wrote:Can you capture the sync in a debug log (step 4b) and send the log to support: http://www.mediamonkey.com/forum/viewto ... ?f=12&t=69
Yes, ofcourse :) . I was busy today. I will provide you the log today asap.

Cant get rid of winamp in that debug. Though I ended winamp process tree in task manager... Unistalled winamp, still its in DebugView ......

Submited a ticket in helpdesk. Attached Log file.
And uplouded it too . http://www.filedropper.com/asuspc

I can uploud more log files, if its needed or this one is bad.

Uplouder one more. http://www.filedropper.com/mediamonkeylog
From #415
Ludek
Posts: 4742
Joined: Fri Mar 09, 2007 2:00 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by Ludek »

Hi, based on the log the device isn't MTP connected, but UMS connected with drive letter H:\ , that explains why PLA abstract playlist cannot be synced.

1) I wonder how Windows Media Player could sync the PLA. Can you re-verify that WMP can sync the PLA (if the device is connected as drive H:\) and attach the sample PLA?

2) Could you please generate one more log, but start the DbgView before MM start? When the device is connected (or MediaMonkey started while the device is connected) then it reports its capabilities (this is not seen in the previous log).

Thanks.
jasonblu
Posts: 14
Joined: Sun Mar 20, 2016 1:59 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by jasonblu »

Ludek wrote:Hi, based on the log the device isn't MTP connected, but UMS connected with drive letter H:\ , that explains why PLA abstract playlist cannot be synced.

1) I wonder how Windows Media Player could sync the PLA. Can you re-verify that WMP can sync the PLA (if the device is connected as drive H:\) and attach the sample PLA?

2) Could you please generate one more log, but start the DbgView before MM start? When the device is connected (or MediaMonkey started while the device is connected) then it reports its capabilities (this is not seen in the previous log).

Thanks.
Im really very sorry, I couldnt make it today. I will provide log tomorrow.
A little bit information. In MediaMonkey I see Walkman (as device) and Walkman H:\ . I will uploud screenshot tomorrow.
Abut WMP. Im sorry if I said WMP. I meant Media Go, it's Sony program. When I sync playlist with Mediago, it appears in walkmans playlists folder, but walkman itself, gives error that there's no playlist available. And Im not 100% sure now, but I think that those playlists dissapear from walkmans folder after a while. In WMP when I sync playlist, it only trasnfers songs to walkmans Music folder, playlist isnt created at all, no file appears in Walkman>Playlists folder.
Again, really sorry that I couldnt make it today :( .

And,
Thanks to You !
jasonblu
Posts: 14
Joined: Sun Mar 20, 2016 1:59 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by jasonblu »

Ludek wrote:Hi, based on the log the device isn't MTP connected, but UMS connected with drive letter H:\ , that explains why PLA abstract playlist cannot be synced.

1) I wonder how Windows Media Player could sync the PLA. Can you re-verify that WMP can sync the PLA (if the device is connected as drive H:\) and attach the sample PLA?

2) Could you please generate one more log, but start the DbgView before MM start? When the device is connected (or MediaMonkey started while the device is connected) then it reports its capabilities (this is not seen in the previous log).

Thanks.

1) http://www.filedropper.com/untitledplaylist . pla playlist via mediago, uplouded directly from walkman.

2) Log file http://www.filedropper.com/mediam2
#6-56 Sony walkman connected
62-.... MediaMonkey strarted
9668-9997 Playlist Sync
Ludek
Posts: 4742
Joined: Fri Mar 09, 2007 2:00 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by Ludek »

Hi, sorry, I overlooked the links as I haven't subscribed this topic. Subscribed it now to catch your update.

Are the filedropper links still valid? I am unable to downlood the files.
jasonblu
Posts: 14
Joined: Sun Mar 20, 2016 1:59 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by jasonblu »

Ludek wrote:Hi, sorry, I overlooked the links as I haven't subscribed this topic. Subscribed it now to catch your update.

Are the filedropper links still valid? I am unable to downlood the files.
Hi,
I checked filedropper, they are not valid anymore :)
I reuplouded:

1) http://www.filedropper.com/newplaylist . pla playlist via mediago, uplouded directly from walkman.

2) Log file http://www.filedropper.com/mediam2
#6-56 Sony walkman connected
62-.... MediaMonkey strarted
9668-9997 Playlist Sync
Ludek
Posts: 4742
Joined: Fri Mar 09, 2007 2:00 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by Ludek »

Hi, thanks, I got them now.

The "Media Go" app sync PLA playlists, but the content of PLA playlist is actually M3U content.
So the solution should be to sync the M3U with PLA extension (like Media Go does).

Tracked as: http://www.ventismedia.com/mantis/view.php?id=13228

Just please confirm that Media Go synced the NEWPLAYLIST.pla to /Playlists/ directory? Or it is another directory.

And also please do this test: rename the synced M3U file using MediaMonkey ( H:\Playlists\adddaa.m3u )
to H:\Playlists\adddaa.pla
Does it the trick to show the playlist on the device then? Or it can be even M3U but in another directory?

Thanks!
jasonblu
Posts: 14
Joined: Sun Mar 20, 2016 1:59 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by jasonblu »

Ludek wrote:Hi, thanks, I got them now.

The "Media Go" app sync PLA playlists, but the content of PLA playlist is actually M3U content.
So the solution should be to sync the M3U with PLA extension (like Media Go does).

Tracked as: http://www.ventismedia.com/mantis/view.php?id=13228

Just please confirm that Media Go synced the NEWPLAYLIST.pla to /Playlists/ directory? Or it is another directory.

And also please do this test: rename the synced M3U file using MediaMonkey ( H:\Playlists\adddaa.m3u )
to H:\Playlists\adddaa.pla
Does it the trick to show the playlist on the device then? Or it can be even M3U but in another directory?

Thanks!
Hi,
Yes, MediaGo and MediaMonkey synced playlist file goes to Playlists folder in walkman.
I renamed synced M3U playlist via windows explorer, later I try to rename it using media monkey :) . Renaming it with windows explorer, didnt help.

Im afraid that it can be some kind of miscommunication between walkman and PC(windows). I deleted/reinstalled drivers hundred times, and it didnt help. Maybe reinstalling windows might help :/ .

Edit. I cant rename synced playlist via MediaMonkey, (In MediaMonkey i select H>Folders>PLaylists and click right mouse button on playlist, there's no option to rename it. I just can rename playlist in MediaMonkey library, i renamed playlist to playlist.pla, synced it to walkman, but it still is m3u format : playlist.pla.m3u
Ludek
Posts: 4742
Joined: Fri Mar 09, 2007 2:00 pm

Re: Can't Sync Playlist to Sony NWZ-E465

Post by Ludek »

Hi, thanks for the update.

So renaming the M3U in Windows Explorer to PLA doesn't do the trick?
It would really mean that Media Go uses some kind of own protocol to sync it.

To confirm, could you please do the following test:
1) Copy music+playlist using Media Go
2) Download the music and playlist from the device to PC (using Windows Explorer)
3) Delete the music+playlist on the device
4) Copy the music+playlist (previously synced by Media Go) to the same location on the device, but using Windows Explorer
=> this way we can confirm that plain file copy isn't enough to sync the playlist?
Post Reply