Batch Art Finder 4.2 - Updated 03/07/2012

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

Guest

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by Guest » Thu Jan 06, 2011 9:02 pm

This error appear only when multiples results are enabled. With one cover all work fine.

cpsnowman

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by cpsnowman » Thu Jan 06, 2011 9:16 pm

Hey, First of all... Thank you!!

Second.. I get an error saying "The MSInet component cannot be found..." so I installed the MSInet and ran MM as Administrator. Everything works like a dream. Thanks again!
Chris

mjm
Posts: 30
Joined: Sun Mar 29, 2009 7:39 pm

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by mjm » Thu Jan 06, 2011 9:32 pm

Hey Trixmoto!

Okay I ran the script on my whole library (nearly 3000 albums) and whilst it found all bar 9 of the desired images, it didn't save them for some reason. I selected "check all" and then "save" (which then greyed out so I assumed it was done) followed by "next", which took me back to the usual MM browser.

It's intermittent with single album searches too - sometimes it saves the image, other times not.

Should I be waiting longer for it to save the images? Anyone managed to get it to save a decent number of images at once? :)

trixmoto
Posts: 10024
Joined: Fri Aug 26, 2005 3:28 am
Location: Hull, UK
Contact:

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by trixmoto » Fri Jan 07, 2011 4:16 am

@jonp - thanks, works for me though.

@mjm - thank you! :)

@ojk12 - thanks, works for me though.

@Guest - ok, I'll take a look.

If you're going to report that something isn't work, you need to tell me more than "it's not working". At least let me know whether you're using single or multiple image mode, as they are very different now.
Download my scripts at my own MediaMonkey fansite.
All the code for my website and scripts is safely backed up immediately and for free using Dropbox.

HappyWEirdo

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by HappyWEirdo » Fri Jan 07, 2011 4:35 am

trixmoto wrote:@jonp - thanks, works for me though.

@mjm - thank you! :)

@ojk12 - thanks, works for me though.

@Guest - ok, I'll take a look.

If you're going to report that something isn't work, you need to tell me more than "it's not working". At least let me know whether you're using single or multiple image mode, as they are very different now.
Thank you for waisting your time for us!
still got a problem, when i start to search with your art finder there is a mistake and it says: "Batch Art Finder- invalid pointer error,please try running IE and completing the default options" Its still only with google.
I dont know if i use it with single or multiple mode!
do you got a answer for me? do i make something wrong? maybe you got a screnbe with the best settings for art finder!
Thanks you very much!
will make a donaute for you! I spend the wine for your meal ;-)

HappyWeirdo

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by HappyWeirdo » Fri Jan 07, 2011 4:55 am

HappyWEirdo wrote:
trixmoto wrote:@jonp - thanks, works for me though.

@mjm - thank you! :)

@ojk12 - thanks, works for me though.

@Guest - ok, I'll take a look.

If you're going to report that something isn't work, you need to tell me more than "it's not working". At least let me know whether you're using single or multiple image mode, as they are very different now.
Thank you for waisting your time for us!
still got a problem, when i start to search with your art finder there is a mistake and it says: "Batch Art Finder- invalid pointer error,please try running IE and completing the default options" Its still only with google.
I dont know if i use it with single or multiple mode!
do you got a answer for me? do i make something wrong? maybe you got a screnbe with the best settings for art finder!
Thanks you very much!
will make a donaute for you! I spend the wine for your meal ;-)
SORRY, MY MISTAKE! JUST INSTATLL COMPLETE NEW AND ITS RUNS NOW LIKE HELL!!!!! THANKS!!!!!!!!!!!!!!

tooone7
Posts: 39
Joined: Tue Jan 04, 2011 7:17 am

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by tooone7 » Fri Jan 07, 2011 5:12 am

Thanks for this much anticipated release :)

It works 110%!

Thanks

Alikalix
Posts: 16
Joined: Sun May 23, 2010 9:57 am

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by Alikalix » Fri Jan 07, 2011 11:18 am

I don't know what is wrong. Before the update were no results, with the update there are no results and even with new instalation there still aint no results. :(

ojk12
Posts: 30
Joined: Sun Jun 13, 2010 1:58 am

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by ojk12 » Fri Jan 07, 2011 11:31 am

trixmoto wrote:@jonp - thanks, works for me though.

@mjm - thank you! :)

@ojk12 - thanks, works for me though.

@Guest - ok, I'll take a look.

If you're going to report that something isn't work, you need to tell me more than "it's not working". At least let me know whether you're using single or multiple image mode, as they are very different now.

I think you got reason Trix.

You'll see, I already have my entire collection with their album art completed but I use to test the new script versions. At first the 'results' option was 1, and I had 'check for image before searching' activated so when I run the script it only displayed the existing image in the Album folder, then I changed the 'results' to 5 and it still only showed the first image in the album folder and 4 empty spaces, then I deactivated 'check for image before searching' and I see the script found 5 album art images (I think like should be) in all cases the links didn't work (Select all, select none, Select inverse, Try next image for all, Try next image, Skip this album, etc...)

The save button works well. I use XP

JuBe
Posts: 70
Joined: Sat Dec 30, 2006 7:15 am

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by JuBe » Sat Jan 08, 2011 4:03 am

Good stuff Trixmoto. I wasn't able to use 3.5 because of the variable is undefined error, even after reinstallation of the script and resetting defaults in IE, but this update fixed it. :D

I like the multiple view mode. I'm getting the same error though as a previous post, ONLY when doing multiple view. Single view works fine.

Error #424-Microsoft VBScript runtime error
Object required: 'data'
File: "C:\Program Files (x86)\MediaMonkey\Scripts\Auto\BatchArtFinder.vbs", Line: 2557, Column: 22


Also I have a suggestion for the multiple view. It would be cool if you could control the output as a grid... so that in the options you could do 2x2 or 3x3 and get a total of 4 or 9 pictures, respectively in a table form. Right now if I set a higher number they all go horizontally and it runs to the side so that you have to scroll sideways. Not a super critical function, but I think it would be neat!

trixmoto
Posts: 10024
Joined: Fri Aug 26, 2005 3:28 am
Location: Hull, UK
Contact:

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by trixmoto » Sat Jan 08, 2011 6:49 am

Thanks, I'll take a look at this error. I've added your suggestion to my list for the next version. :)
Download my scripts at my own MediaMonkey fansite.
All the code for my website and scripts is safely backed up immediately and for free using Dropbox.

newuser

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by newuser » Sat Jan 08, 2011 10:06 am

@ojk12: i have the same problems. nothing happens when i click on these buttons

Guest

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by Guest » Sun Jan 09, 2011 4:49 am

Everything Works Like A Charm except google search :P.. well for me :( i don't know the reason but itcould find only 41 album covers.. it can't find any other albums like "cooler than me" for example :( and many easy to find album covers so i don't think the problem is in not finding them :? all other sources have little pictures and google is way better in that way, it would be great if you could find the reasone for next realease maybe ;) thanks for your hard work though :)

rovingcowboy
Posts: 14153
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by rovingcowboy » Sun Jan 09, 2011 4:58 am

trouble with google started about mid summer last year. ----snipped cause i read amazon not google even though i typed google.----------. i'm sure trixmoto will get it working he's one of the best script authors here maybe bex or if steegy ever shows up again they might see the error and tell him. 8)
Last edited by rovingcowboy on Sun Jan 09, 2011 5:09 pm, edited 1 time in total.
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy 5 Android 5) 6. Proscan tablet Android 4.3 ) 7. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.

trixmoto
Posts: 10024
Joined: Fri Aug 26, 2005 3:28 am
Location: Hull, UK
Contact:

Re: Batch Art Finder 4.0 - Updated 06/01/2011

Post by trixmoto » Sun Jan 09, 2011 8:13 am

@Guest - could you enable the debug log and then send me the logfile to take a look at? It probably explains why the images are not being found.

@rovingcowboy - I'm not sure any of your post makes sense. The script uses the Google Images search, they haven't changed "their songs or albums to mp3 downloads" because Google don't provide downloads, only search results. They add new servers every day, I'm not sure what changing "some servers" has to do with anything, nor have they changed the urls. What they have done is changed the results page, so I have had to change the script to accommodate these. I have tested this script with MM4 and haven't found any changes that needed making, same with Windows 7.
Download my scripts at my own MediaMonkey fansite.
All the code for my website and scripts is safely backed up immediately and for free using Dropbox.

Post Reply