Page 1 of 113

Batch Art Finder 4.2 - Updated 03/07/2012

PostPosted: Wed Jun 07, 2006 8:55 am
by trixmoto
This has been requested since I first released my Google Art Finder script. And now it's here and downloadable from my website.

Basically it checks your library for albums without art, and then queries google for each album. Then you check the results and decide which you want. Hit save and all your tracks will be updated.

Lastly, enjoy! :)

PostPosted: Wed Jun 07, 2006 11:52 am
by Teknojnky
Holy Cow! That's AMAZING!

8) :lol:

PostPosted: Wed Jun 07, 2006 3:46 pm
by Miki
Dang, this is what i needed :)

After letting it complete finding the images [some of which, for smaller unknown bands are rediclious, but i understand you cant change that :)]

If i try to click "Remove" i get the following error:
[Image not needed anymore]

If i click "Try Again" then the image is removed and replaced with "[Queued]" but it doesnt seem to do anything after that.

Thanks, Mike.

PostPosted: Wed Jun 07, 2006 9:09 pm
i get the same error msg

Batch Art

PostPosted: Wed Jun 07, 2006 11:52 pm
by Guest
My best guess iis that your security settings in Internet Explorer concerning Active X controls are too strong to allow the control to work. Tools - Internet Options - Security to change your settings. Play with the Active X settings until you find the one that is stopping this script from working.

PostPosted: Thu Jun 08, 2006 12:20 am
by rovingcowboy
i ran in to this trouble with an other program that uses batch files.

windows does not like programs that run batch files anymore. it thinks they program is doing something wrong. how ever the author of the other program was able to get it working with doing some more coding.

just what he did to the exe is unknown. but it does need trixmoto to adjust something.

and i would not go in to the internet options and just start changing the security options with out knowing what you want to change.
but there is some sense in that blocking the activex since ms has blocked them from downloading things. so go find the command to allow activex downloads. and set that to enable.

PostPosted: Thu Jun 08, 2006 3:14 am
by trixmoto
Guest 1 - rovingcowboy 0

When you hit the "Remove" link the script needs to connect back to MM to reset the data so that if you hit the "Try again" link afterwards the search will start from the beginning correctly. This connection is often blocked by activex security settings and/or paranoid antivirus software.

ActiveX warnings: In Internet Options, Local Intranet zone, enable "Initialise and script ActiveX controls not marked as safe".

If you are still getting the warning messages - try this:
1) Run regedit.exe
2) Goto HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0
3) Modify key 1201 = 0
This enables the above option in your My Computer zone.

@Teknojnky - I knew you'd love it! :D

PostPosted: Thu Jun 08, 2006 7:18 am
by rovingcowboy
okay differnt problems but sounded the same.

PostPosted: Thu Jun 08, 2006 8:20 am
by Teknojnky
I get:

error # -2147024891 - msxml3.dll
access is denied
file: J:\program files\mediamonkey\scripts\batchartfinder.vbs, line 446, column 2

I believe this is the same type of error as google art finder, when you try to save an invalid or non-existent picture (images that don't load, etc).

I've also got the script message linked above too.

PostPosted: Thu Jun 08, 2006 9:34 am
by trixmoto
Unless I can find another method for downloading files, there's not a lot I can do to fix that error. There's another possibility but it would need a license which either means everyone needs VS6 or I need to provide a hack. The solution really is to Remove any images which aren't found before hitting Save.

PostPosted: Thu Jun 08, 2006 12:10 pm
by Miki
Im also getting this.

By "arent found" do you mean [No Results] or ones that the picture doesnt load or is just a cross?

A possible bug - If it is still googling for images and you remove an unwanted image everything gets shunted down 1.

PostPosted: Thu Jun 08, 2006 12:11 pm
by Teknojnky
the red x that IE displays when an image doesnt load.

trix, would it be possible to add the possiblity to run the script only a selection instead of the whole library... IE do one artist or genre etc at a time?

Would make it a bit easier with extremely large libraries... I have 3600+ albums for it to process.

PostPosted: Thu Jun 08, 2006 12:13 pm
by Miki
Ok, Thanks.

What about images that just don't load, they havent found an image but they dont display a cross?

PostPosted: Thu Jun 08, 2006 12:57 pm
by Teknojnky
I get the active x warning when clicking the "remove" link, and my registry is already set as indicated in the post above.

Any other ideas?

PostPosted: Thu Jun 08, 2006 3:50 pm
by Miki
What version of IE are you using, it didnt seem to work for me in IE6.
When i upgraded to version 7 [Beta 2] it now seems to work flawlessly :)

Good Job!

Oh and since i never use IE i just changed the settings as posted here.

"ActiveX warnings: In Internet Options, Local Intranet zone, enable "Initialise and script ActiveX controls not marked as safe". "

But internet instead of intranet.