Trouble with OnPause and OnPlay events. ...Help?

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

Plazma
Posts: 52
Joined: Thu Nov 03, 2005 9:59 am

Trouble with OnPause and OnPlay events. ...Help?

Post by Plazma » Sun Nov 05, 2006 8:36 pm

Hi again,

So I'm trying to use the onpause as a trigger to tell if the song is being paused or is no longer paused, because i'm using it to invoke the ispaused event.

This works fine when the player is paused and when the pause button is pressed to come out of the pause.

BUT - when the player is paused and the play button is pressed, neither the onplay nor the onpause event seem to capture that the player is now again playing.

Am i messing these trigger events up? Is there a trigger that tells when they player is being unpaused by the play button?

(I have a workaround for this - but I just was wondering if there was a trigger for this event)

trixmoto
Posts: 10024
Joined: Fri Aug 26, 2005 3:28 am
Location: Hull, UK
Contact:

Post by trixmoto » Mon Nov 06, 2006 4:13 am

This sounds like a scripting bug. Hopefully Jiri can provide some answers for you.
Download my scripts at my own MediaMonkey fansite.
All the code for my website and scripts is safely backed up immediately and for free using Dropbox.

jiri
Posts: 5395
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Post by jiri » Mon Nov 06, 2006 6:16 am

Ok, you are right, OnPause event isn't fired even though it should. It will be fixed in the next version.

Jiri

Post Reply