PrettyPictures (Album Art Browser) [MM 3]

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

Post by DaledeSilva » Sun May 13, 2007 5:51 am

FYI, I had a brainwave the other day and it should have been obvious to me earlier.

the reason there is alot of memory that doesn't get freed after this script ends is because flash cannot be told to free the memory when MM is closed - flash just gets closed before it realises what's happening...

I may be able to register some sort of onClose event in MM so that tells PP to unload the images before it closes. I'm not sure this will work because the flash window might be closed before the onClose event is run - but if anyone can help me with the code for this method it would be helpful as I don't know when I'll have the time to look into it myself.

Dale.
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

Guest

Post by Guest » Mon May 14, 2007 4:16 am

Sorry, I didn't check all the pages!
If its not on the first page or the last page, I don't know it... :S
At least my little foray into your script reminded me all the VB I'd make mischieviously in college.

I haven't used the Alpha, but I really like yours, it runs smoother than the itunes one, and is great fun to customise :D
Your plugin made me get album art. My scanners been on overload!

I would try out the MM3 one when its stable, and if it is as customisable as yours, it'd depend on memory usage... So I hope theres a method of releasing memory!

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

Post by DaledeSilva » Mon May 14, 2007 8:02 am

Anonymous wrote:Your plugin made me get album art. My scanners been on overload!
jesus man.. use tag from amazon or google cover finder.

Dale.
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

MadBan
Posts: 1
Joined: Mon May 14, 2007 9:55 am

Post by MadBan » Mon May 14, 2007 9:59 am

I must say, this is a FANTASTIC plug-in!
I had been searching for a jukebox application, even trying out MythTV (or KnoppMyth to be more specific) BeeXbox OS's. But now with your plugin, MediaMonkey does exactly what I need.

Thank you!

-MadBan

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: Pretty Pictures (new Album Art Browser)

Post by nohitter151 » Mon May 14, 2007 10:48 am

DaledeSilva wrote:Hello everyone, Pretty Pictures is currently at BETA version 0.51

It is an organic method of browsing your albums by flicking through their album Art.

here's the link to the page where you can download it and read some information which may not be present in this forum:
http://prettypictures.oiltinman.com
Just wanted to let you know this link doesn't work, I used the link in your sig and got there but this first one is down or doesn't point to the right location.

BTW: Once I got it up and running, I've found this script to be amazing! Great work!

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

Post by DaledeSilva » Mon May 14, 2007 9:07 pm

thanks.. fixing now
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

theta_wave
Posts: 309
Joined: Fri Apr 13, 2007 12:54 am

Post by theta_wave » Wed May 16, 2007 9:00 am

DaledeSilva wrote: I'm pretty sure that the earlier versions of hte script were doing his by default, but then I added the sorting methods... I can definitely put this back in. Not sure when I'll get a chance though.

Dale.
If you have it on you by any chance, could you post up this portion of the old code? If not, then I'll be looking forward to the next update. Thanks!

BONJOVI

Post by BONJOVI » Thu May 17, 2007 11:24 am

thanks for this outstanding plugin !!!!!

it now makes mediamonkey the only mediaplayer i use

and i really mean !!!! :)

squirt

Future Development

Post by squirt » Wed May 30, 2007 5:08 pm

Great plugin - I'm very impressed with what you've done. I saw in a previous post that you aren't planning to update until MM3 alpha is released. Any reason why? I have a feeling a lot of other scripts aren't going to work for quite a while after MM3 comes out & I'm not sure if I'll update MM until all my old scripts work. I'd love to see some of the items on your to do list come out prior to MM3. Specifically, the displaying of the album information on hover would make PP complete in my eyes. :o

pah68
Posts: 1496
Joined: Wed Apr 07, 2004 5:26 pm
Location: Sydney, Australia

Post by pah68 » Wed May 30, 2007 6:46 pm

Dunno if this is an issue for this particular script but the final database structure hasn't been settled on yet.
Image
Image

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

Post by DaledeSilva » Thu May 31, 2007 10:08 am

I agree squirt, I'd like to see all those things too... right now I just don't have time though.

pah68 is correct about the database structure... though the main reason is I initially said that was because MM 3.0 was offering an album view... it has one.. and it's decent.. but I will still be updating this eventually..

when I do get a chance though, I would rather fix bugs and add the needed features than update to MM3.0 before it's even out.

I don't think the changes to update to 3 would take long anyway.. most of PP's programming is based around the visuals... it doesn't talk to the database in a complex manner.

Dale.
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

jgc
Posts: 6
Joined: Thu Jun 07, 2007 11:37 am

Trying to get the art to show

Post by jgc » Thu Jun 07, 2007 11:45 am

Hi,

Just come across this great piece of work (and art!). Thanks for your hard work, and good support to others on this forum.

I haven't managed to get the art showing, but I do get all the white boxes and text, and it scrolls nicely. I have read through the whole of this thread ( :o ) and haven't found a cure. However here is some info to help debug the problem:

MM: v 2.5.5.996
PP: v 0.5.1
IE: v 6.0.2800 on Win 2000 (could this be the problem?)
Flash: v 9.0

The auto/prettypictures/cache/_curAlbums.xml file has the right structure that changes as I move around the nodes. However, it always contains this attribute

Code: Select all

hasart='0'
. This is despite running both quick cache and cache several times, and it scrolling through about the right number of files. And all the albums have got cover art embedded into the MP3s, and these show quite happily in the Album Art browser in MM.

So I'm a bit stumped. I hope someone can work out what I've not done right :(

I'm also getting Access Violations when trying to resize the PP window.
Last edited by jgc on Thu Jun 07, 2007 11:49 am, edited 1 time in total.

jgc
Posts: 6
Joined: Thu Jun 07, 2007 11:37 am

Caching instructions

Post by jgc » Thu Jun 07, 2007 11:48 am

Another small point: various posts on this thread say that the instructions to cache before the art will show are on the website (http://www.oiltinman.com/plugins/PrettyPictures/). This doesn't appear to be mentioned at the moment on this page, and I encourage you to add this back.

jgc
Posts: 6
Joined: Thu Jun 07, 2007 11:37 am

Re: Trying to get the art to show

Post by jgc » Sat Jun 09, 2007 12:14 pm

jgc wrote:So I'm a bit stumped. I hope someone can work out what I've not done right :(
Good news!

It has gradually started showing the album art, after a couple of restarts and re-CACHEs. At first it just showed a few albums per node. And then it showed a few more albums, but only when it was in the large central position - when it was either side of the centre it went back to black writing on the white square. But another few changes of node later it stopped doing this. Most strange. Another run of the CACHE ALL picked up the rest of the album art, I think.

So, I'm enjoying the art, but thought I better post in case it shows up a subtle bug.

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

Post by DaledeSilva » Sat Jun 09, 2007 10:50 pm

that's happened before... it usually results from when you cache... but then you don't change nodes or restart afterdoing so...

what happens is that the low res images on the sides are taken from the xml file which was loaded in when the node initiated (before the cache) but the high res middle is loaded according to the information on the fly - so the middle is up to date but the sides are not...

I will try and update the information on the website in the next week or so.

Dale.
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

Post Reply