Page 84 of 162

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Nov 27, 2009 6:56 am
by surfer1
Hi Nyn, I'm sorry but I'm lost with that.
Is there place where I can juust tell W7 to give me administrative right with everything?
I typed MagicNodes.mmip into run and hit enter. Then a window appeared telling me that Windows couldn't find the file. Yet I'm staring at it in my downloads folder. Something creepy is happening here.
Sorry Nyn, any other suggestions?

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Nov 27, 2009 7:07 am
by nynaevelan
You can right click on the shortcut of MM and select Properties and then select the Compatibility tab, then check the Run as Administrator option. That way it always runs as an admin. Also check your UAC settings, as a previous Vista user I always have it turned off but I know other users have problems with installing scripts with it turned on.

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Nov 27, 2009 9:10 am
by surfer1
Hi Nyn, ok, what you suggested worked. I opened the MM link as administrator and installed the script fine. No problem. My question now is: how do I set MM to open as administrator every time in the future without me having to right-click the icon everytime I open the program. This situation has never happened before while using MM or W7? Thanks for the advice, nyn. That was driving me crazy. Cheers.

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Nov 27, 2009 10:36 am
by nohitter151
surfer1 wrote:Hi Nyn, ok, what you suggested worked. I opened the MM link as administrator and installed the script fine. No problem. My question now is: how do I set MM to open as administrator every time in the future without me having to right-click the icon everytime I open the program. This situation has never happened before while using MM or W7? Thanks for the advice, nyn. That was driving me crazy. Cheers.
Right click the MediaMonkey icon and go to "Properties". In the "Compatibility" tab, check "run this program as administrator". Alternatively you could just disable the UAC in the control panel security settings.

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Nov 27, 2009 1:39 pm
by Vyper
There are arguments for and against disabling the UAC entirely. Disabling it defeats the purpose of that layer of security protection but it's a user-based decision. :)

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Nov 27, 2009 1:41 pm
by nynaevelan
nohitter151 wrote: Right click the MediaMonkey icon and go to "Properties". In the "Compatibility" tab, check "run this program as administrator".
You only have to do this once, from that point on MM will always run as an admin. I do not know what effects having UAC on will do to this because I never have mine on.

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Nov 27, 2009 5:32 pm
by Vyper
If you have it off, then you don't need to run MM as administrator. I just found that out this morning when I installed a script with UAC off, MM not in Administrator mode. :)

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Nov 27, 2009 5:39 pm
by nynaevelan
Vyper wrote:If you have it off, then you don't need to run MM as administrator. I just found that out this morning when I installed a script with UAC off, MM not in Administrator mode. :)

Vyper:

I learned on Vista that you have to have installed MM at least once as an admin then the problems do not persist. Try installing a test installation without running as an admin and then installing a script or skin, it's a no go. Which is why I always install as an admin and run as an admin, it eliminates problems. I also tried turning UAC back on to see what the outcome would be. Of course it gave me a message about my backup and export m3us scripts running, which wouldn't run without intervention from me, no thank you M$.

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Nov 27, 2009 5:43 pm
by Vyper
Ah, okay. Good to know. Thanks. :D

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Sun Dec 06, 2009 8:14 pm
by Robokopi
hey,

can someone tell me, what i have to do, to get the icon for the magicnode tree entry displayed?

since i installed the latest version, the icon has disappeared. i recently uninstalled and installed magicnodes again, just to make sure, that i did not delete or renamed anything. but it's still away.

the App.ico with the typical magicnodes icon (the same which you can found unter tools -> extensions) is shown in the mediamonkey3 -> scripts -> auto file. do i have to relocate it?

greetz

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Mon Dec 07, 2009 11:00 am
by DreadM
Greetings

@Robokopi
Rename App.ico to MagicNodes.ico

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Mon Dec 07, 2009 11:03 am
by Robokopi
worked

:D

thanks a lot

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Fri Dec 11, 2009 7:12 pm
by Weatherman
Hello,
Can someone help with an explanation of the field called "Date/Time Played" and when it is possible to use it? I am assuming that this should show the date and the time a song was played, as opposed to just the date ("Date Played"). However, I can't seem to get this one to display. Any advice would be appreciated.
Jim

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Sun Dec 13, 2009 5:36 pm
by olle
Hi,

First off all: love this script. And your help with the Artist and Album Rating nodes works like a charm.

Now the, I've got some problems with the following nodes:

Code: Select all

Mask189=<Group|Name:Random|Show tracks:No>\One random Track from each Artist who has at least 3 stars|Icon:Top level|Filter:Songs.ID IN (SELECT (SELECT A1.IDSong FROM ArtistsSongs AS A1 WHERE A1.IDArtist = ArtistsSongs.IDArtist ORDER BY Random() LIMIT 1) FROM ArtistsSongs WHERE (ArtistsSongs.PersonType = 1 OR ArtistsSongs.PersonType IS NULL) GROUP BY ArtistsSongs.IDArtist HAVING Avg(Rating) >= 60)\<Artist|Trim:1>\<Artist>

Mask311=<Group|Name:Random|Show tracks:No>\One random Track from each Artist who has at least 3,5 stars|Icon:Top level|Filter:Songs.ID IN (SELECT (SELECT A1.IDSong FROM ArtistsSongs AS A1 WHERE A1.IDArtist = ArtistsSongs.IDArtist ORDER BY Random() LIMIT 1) FROM ArtistsSongs WHERE (ArtistsSongs.PersonType = 1 OR ArtistsSongs.PersonType IS NULL) GROUP BY ArtistsSongs.IDArtist HAVING Avg(Rating) >= 70)\<Artist|Trim:1>\<Artist>
Mask312=<Group|Name:Random|Show tracks:No>\One random Track from each Artist who has at least 4 stars|Icon:Top level|Filter:Songs.ID IN (SELECT (SELECT A1.IDSong FROM ArtistsSongs AS A1 WHERE A1.IDArtist = ArtistsSongs.IDArtist ORDER BY Random() LIMIT 1) FROM ArtistsSongs WHERE (ArtistsSongs.PersonType = 1 OR ArtistsSongs.PersonType IS NULL) GROUP BY ArtistsSongs.IDArtist HAVING Avg(Rating) >= 80)\<Artist|Trim:1>\<Artist>
Mask313=<Group|Name:Random|Show tracks:No>\One random Track from each Artist who has at least 4,5 stars|Icon:Top level|Filter:Songs.ID IN (SELECT (SELECT A1.IDSong FROM ArtistsSongs AS A1 WHERE A1.IDArtist = ArtistsSongs.IDArtist ORDER BY Random() LIMIT 1) FROM ArtistsSongs WHERE (ArtistsSongs.PersonType = 1 OR ArtistsSongs.PersonType IS NULL) GROUP BY ArtistsSongs.IDArtist HAVING Avg(Rating) >= 90)\<Artist|Trim:1>\<Artist>
Mask314=<Group|Name:Random|Show tracks:No>\One random Track from each Artist who has at least 5 stars|Icon:Top level|Filter:Songs.ID IN (SELECT (SELECT A1.IDSong FROM ArtistsSongs AS A1 WHERE A1.IDArtist = ArtistsSongs.IDArtist ORDER BY Random() LIMIT 1) FROM ArtistsSongs WHERE (ArtistsSongs.PersonType = 1 OR ArtistsSongs.PersonType IS NULL) GROUP BY ArtistsSongs.IDArtist HAVING Avg(Rating) >= 100)\<Artist|Trim:1>\<Artist>
When I try to run them MM just locks up and doesn't answer and I've got to force it to close. Mask311-314 is my own modification off Mask189.

I hope some off you folks who's a bit more clever than me can help me out on this one.

Re: Magic Nodes 3.0 w/ 245 masks & real GUI (2009-09-08) [MM2+3]

Posted: Mon Dec 14, 2009 7:13 am
by Vyper
I know about zilch in regards to this but searched the thread and this is the only reference to half stars I could find:

Go to Tools / Options / General - Magic Nodes Options, uncheck Display sorting/statistic results for Rating rounded to the nearest half star.


Also, in your nodes, is it correct to list half stars as 4,5 rather than 4.5?