TweakMonkey causes error if My Computer node is hidden

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

RonSD
Posts: 15
Joined: Fri Sep 14, 2007 6:44 pm

TweakMonkey causes error if My Computer node is hidden

Post by RonSD » Fri Sep 14, 2007 6:51 pm

Unchecking "Visible" for "My Computer" on the TweakMonkey>Tree Node Options page causes MM to generate the following error message while closing:

"Access violation at address 0063460D in module 'MediaMonkey.exe'. Read of address 00000000."

The session during which the option is changed closes OK, but during subsequent sessions the error message appears six times while MM is closing. The error seems to occur independently of other option settings.

Environment:
WinXP-SP2
MediaMonkey 2.5.5.998
(fresh install, gold or ungold, with no changes other than TM installation)
TweakMonkey 1.02

Steegy
Posts: 3452
Joined: Sat Nov 05, 2005 7:17 pm
Location: Belgium
Contact:

Post by Steegy » Sat Sep 15, 2007 1:50 am

MediaMonkey 2.5 throws AV's for some reasons, when exitting MM when TweakMonkey is installed. MM 3 is supposed to fix that. For now I haven't seen any issues using TM on MM3.

Unfortunately, TM will probably continue to give AV's on MM 2.5, as there's nothing much to do except to trim functionality from TM. The strange thing is that sometimes the functionality just works, and other times it works but also gives an AV. When you're using the debug version of MM2.5, these errors are very rare.
Extensions: ExternalTools, ExtractFields, SongPreviewer, LinkedTracks, CleanImport, and some other scripts (Need Help with Addons > List of All Scripts).

Post Reply