AutoRateAccurate 2.4.3 (22/10/2009) - for MM3

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

sakurakessho
Posts: 76
Joined: Sat Jun 23, 2007 6:15 pm

Post by sakurakessho » Mon Dec 31, 2007 9:17 pm

@Big_Berny: Yeah I tried. And I got it working now after a restart and for some reason after reinstalling the last.fm client. I think it was an issue with pidgin. I was trying to install a now playing plugin for pidgin but it made last.fm stop working. So after I deleted the pidgin plugin and reinstalled last.fm and restarted my computer it worked. :roll:
Thanks for helping even though it was my own silliness that caused it to crash. lol It's working now though as far as I can tell.

svenni
Posts: 87
Joined: Wed Feb 16, 2005 6:14 pm

Post by svenni » Tue Jan 01, 2008 5:54 am

Hi
When I upgraded to MM3 and AUtoAcc 2 things does not work properly.
- the installer is unavailible
- the skip on/off button is inunderstandable
- each time MM starts up AutoAcc asks if you would like to keep settings or store in MM.ini or something like that. You can choose yes/no, what is this?


Thx
Music is great!
MM with:
AutoAccRate 2.4.2, Blue Monkey 2.1, Backup 5.1, AutoAlbumDJ 3.5, Last100.. node, ClearNowPlayingButton 1.2, Monkey Rok, Last FM DJ and Scrobbler that scrobbles!

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Wed Jan 02, 2008 9:52 am

Spazz wrote:New Feature Request. An option to auto calibrate and rerate all songs after every x songs played.
Hi Spazz :)
yes, I've to think about an option like that. Since all songs you play get rerated automatically there should not be a big difference like when you rerate all. But I'd like to change the script because the AutoCalibrate at startup isn't perfect as it needs a bit too much time to start MM.

So, I'll have a look. But now I have exams again so I need some time.
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Wed Jan 02, 2008 9:57 am

@svenni: Have you done a clean install of MM3? Or just updated MM2 to MM3 with all old scripts?

I'd try this: Download the installer of the first page and install AutoRateAccureate again. After that restart MM. Does it work? Now you also could try to uninstall AutoRateAccurate, so your MM-setup is clean again. If you want you can now install AutoRateAccurate again.

The message which you get probably is from the uninstaller of AutoRateAccurate. IF the message really means the settings of the script they can be deleted. Because when you reinstall it it configure these settings again.
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

Spazz
Posts: 243
Joined: Tue Jan 11, 2005 9:49 pm

Post by Spazz » Wed Jan 02, 2008 12:47 pm

Big_Berny wrote:
Spazz wrote:New Feature Request. An option to auto calibrate and rerate all songs after every x songs played.
Hi Spazz :)
yes, I've to think about an option like that. Since all songs you play get rerated automatically there should not be a big difference like when you rerate all. But I'd like to change the script because the AutoCalibrate at startup isn't perfect as it needs a bit too much time to start MM.

So, I'll have a look. But now I have exams again so I need some time.
I was more thinking this would be nice so all your songs would stay in sync as the number of played songs increases. It would be more dramatic in the beginning but slow down and be less useful later.
Image

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Wed Jan 02, 2008 1:23 pm

Yes, you're right. At the beginning it would be useful. But I did some tests some versoins go and noticed that it almost has no effect when the database isn't completely fresh. And you can always click on the star-icon in the toolbar to do an AutoClaibration and complete rerating of the library.

But I'll think about that when I work on the next version.
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

svenni
Posts: 87
Joined: Wed Feb 16, 2005 6:14 pm

Post by svenni » Wed Jan 02, 2008 7:28 pm

Big_Berny wrote:@svenni: Have you done a clean install of MM3? Or just updated MM2 to MM3 with all old scripts?

I'd try this: Download the installer of the first page and install AutoRateAccureate again. After that restart MM. Does it work? Now you also could try to uninstall AutoRateAccurate, so your MM-setup is clean again. If you want you can now install AutoRateAccurate again.

The message which you get probably is from the uninstaller of AutoRateAccurate. IF the message really means the settings of the script they can be deleted. Because when you reinstall it it configure these settings again.
HI
I did update MM3 from MM2 with some old scripts so that might be the problem. But when I try to download the script it¨s only possible to get the zip file. there is no installer. Or is it just me being stupid?

Edit: Still can't find the installer, but I managed to get everything working by looking in the install.ini where the files should go. :D
Music is great!
MM with:
AutoAccRate 2.4.2, Blue Monkey 2.1, Backup 5.1, AutoAlbumDJ 3.5, Last100.. node, ClearNowPlayingButton 1.2, Monkey Rok, Last FM DJ and Scrobbler that scrobbles!

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Wed Jan 02, 2008 7:55 pm

You have to download this version: Link removed - Check first post It's a installer which should automatically start MM3...
Last edited by Big_Berny on Wed Jul 02, 2008 4:39 pm, edited 1 time in total.
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Post by nynaevelan » Thu Jan 03, 2008 12:44 am

svenni wrote:
Big_Berny wrote:@svenni: Have you done a clean install of MM3? Or just updated MM2 to MM3 with all old scripts?

I'd try this: Download the installer of the first page and install AutoRateAccureate again. After that restart MM. Does it work? Now you also could try to uninstall AutoRateAccurate, so your MM-setup is clean again. If you want you can now install AutoRateAccurate again.

The message which you get probably is from the uninstaller of AutoRateAccurate. IF the message really means the settings of the script they can be deleted. Because when you reinstall it it configure these settings again.
HI
I did update MM3 from MM2 with some old scripts so that might be the problem. But when I try to download the script it¨s only possible to get the zip file. there is no installer. Or is it just me being stupid?

Edit: Still can't find the installer, but I managed to get everything working by looking in the install.ini where the files should go. :D
Your computer might be like mine where it automatically changes the extension to .zip, when I save it I just rename it to .mmip. Then when I double-click it, it installs in mm3 like it is supposed to.

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Thu Jan 03, 2008 3:29 am

@Nyn: That's good to know. Thanks!
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Thu Jan 03, 2008 5:56 am

Hi guys,
just found out how to improve the speed of the script. Instead of 17.6 seconds the AutoCalibration now only needs 6.8 seconds on my system. Also the AutoRating-process is faster by about the same factor but it depends on how much it has to tag.
Also two little bugs have been fixed. One affected the BaseRating.

Have fun with 2.0.2! :)
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

svenni
Posts: 87
Joined: Wed Feb 16, 2005 6:14 pm

Post by svenni » Thu Jan 03, 2008 4:51 pm

nynaevelan wrote:
svenni wrote:
Big_Berny wrote:@svenni:
Your computer might be like mine where it automatically changes the extension to .zip, when I save it I just rename it to .mmip. Then when I double-click it, it installs in mm3 like it is supposed to.

Nyn
Aha! Thanks a lot.
Music is great!
MM with:
AutoAccRate 2.4.2, Blue Monkey 2.1, Backup 5.1, AutoAlbumDJ 3.5, Last100.. node, ClearNowPlayingButton 1.2, Monkey Rok, Last FM DJ and Scrobbler that scrobbles!

drjboulder
Posts: 1119
Joined: Mon Apr 09, 2007 12:03 am
Location: Boulder, Colorado, USA

Post by drjboulder » Sat Jan 05, 2008 12:59 am

Since updating to the latest version, I am getting these error messages every time a song begins:

Image

Then,

Image

Any ideas on this?
D Rock
Image
MediaMonkeyGoldv3.0.3.1183
Vista Home Basic|4thGen 20GPod
Zune Small Player Skin w/ Aqua 4 Player Mod
Backup | Last FM Node | Scrobbler DJ | TopTracks | StayInSameStyleDJ
RadioDJ | RadioFreeMonkey | PrettyPictures | MiniLyricsEmbedder
LyricsViewer | Lyricator | LyricsPlugin | VisualizationEmbedder | MonkeyRok
RightClickForWeb | WebSearchPanels | WebNodes | MagicNodes | FavoritesNodes
NowPlayingArtNode |AutoRateAccurate | TaggingInconsistencies
AdvancedDuplicateFind&Fix | CaseModify | PlayHistory&Stats | Etc...

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Sat Jan 05, 2008 3:14 am

Hmm... That's strange...
Try this: Go to the MediaMonkey options and open 'AutoRateAccurate', then 'Advanced' and click on 'OK'. Now the AutoCalibration and the AutoRating should run and after that the bug should be fixed.

Did it work?

PS: Did you really only updated to 2.0.2? Did you uninstall the older version first? (Should not be needed...)
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

drjboulder
Posts: 1119
Joined: Mon Apr 09, 2007 12:03 am
Location: Boulder, Colorado, USA

Post by drjboulder » Sat Jan 05, 2008 3:54 am

Big_Berny wrote:Hmm... That's strange...
Try this: Go to the MediaMonkey options and open 'AutoRateAccurate', then 'Advanced' and click on 'OK'. Now the AutoCalibration and the AutoRating should run and after that the bug should be fixed.

Did it work?

PS: Did you really only updated to 2.0.2? Did you uninstall the older version first? (Should not be needed...)
Hmmm.....
Yep that fixed it.

:oops: Do not remember if I uninstalled first....
Did it first thing in the morning before my bearings were straight.

All seems well now.
Thanks BB for all your work on this script and your response. :D

EDIT:
PostPosted: Sat Dec 29, 2007 4:48 pm Post subject: Reply with quote
Got it! You have to open the "Advanced"-sheet before enabling the script the first time.
I probably did uninstall first and this was the issue. :oops:

Thanks, again.
D Rock
Image
MediaMonkeyGoldv3.0.3.1183
Vista Home Basic|4thGen 20GPod
Zune Small Player Skin w/ Aqua 4 Player Mod
Backup | Last FM Node | Scrobbler DJ | TopTracks | StayInSameStyleDJ
RadioDJ | RadioFreeMonkey | PrettyPictures | MiniLyricsEmbedder
LyricsViewer | Lyricator | LyricsPlugin | VisualizationEmbedder | MonkeyRok
RightClickForWeb | WebSearchPanels | WebNodes | MagicNodes | FavoritesNodes
NowPlayingArtNode |AutoRateAccurate | TaggingInconsistencies
AdvancedDuplicateFind&Fix | CaseModify | PlayHistory&Stats | Etc...

Post Reply