Last.fm Scrobbler help

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

codo
Posts: 15
Joined: Tue Dec 22, 2009 12:12 am
Location: Newfoundland

Re: Last.fm Scrobbler help

Post by codo » Wed Jul 13, 2011 11:33 am

Having an odd problem. When I skip songs, it continues to scrobble the previous track instead of the new one. If I let a song play through and go on to the next its fine. Just updated to the latest beta build and scrobbler plugin, same thing. Also get some weird instances where in the middle of a bunch of songs scrobbled, one says it was played days ago instead of in line with the rest. Suggestions?
Image

GrimMonolith

Re: Last.fm Scrobbler help

Post by GrimMonolith » Sat Jul 16, 2011 2:48 pm

Hi guys!

I tried to install the plu-in but it always gives me an error.

Image

It something about a "runtime error" or something. I'm sorry, but I cannot translate this from German to English. Maybe the pic helps.

Thanks

doomy304

Re: Last.fm Scrobbler help

Post by doomy304 » Wed Jul 20, 2011 10:34 am

altmank wrote:I'm not able to get the Last.FM scrobber to work.



Here is an example log:

Code: Select all

6/25/2011 13:26:22.829: MediaMonkey v3.2.5
6/25/2011 13:26:22.831: Loading Last.fm Scrobbler
6/25/2011 13:26:22.833: ----------------------------------------
6/25/2011 13:26:22.835: Last.fm Scrobbler v1.0.2.26
6/25/2011 13:26:22.837: ----------------------------------------
6/25/2011 13:26:22.975: Last.FM: Player got Command wParam (1)
6/25/2011 13:26:22.977: Last.FM: Player got Command wParam (1)
6/25/2011 13:27:20.345: Last.FM: Player got Command wParam (1)
6/25/2011 13:27:20.351: Last.FM: Player got Command wParam (1)
6/25/2011 13:27:20.356: Last.FM: Player got Command wParam (0)
6/25/2011 13:27:20.360: Last.FM: Player got Command wParam (2)
6/25/2011 13:27:20.368: Last.FM: Nowplaying Play Detected at 1309026440
6/25/2011 13:27:20.373: Last.FM: Handshake Session Started
6/25/2011 13:27:20.812: Last.FM: Handshake OK
6/25/2011 13:27:20.988: Last.FM: Handshake Session ID is 6301abdf1b29448782c95b504c1311ba
6/25/2011 13:27:21.009: Last.FM: Handshake NowPlaying URL is http://post.audioscrobbler.com:80/np_1.2
6/25/2011 13:27:21.030: Last.FM: Handshake Submission URL is http://post2.audioscrobbler.com:80/protocol_1.2
6/25/2011 13:27:21.047: Last.FM: NowPlaying Song Obel, Agnes - Riverside
6/25/2011 13:27:21.064: select Songs.ID from Songs where Songs.id=9794 AND Songs.TrackType=1 
6/25/2011 13:31:04.366: Last.FM: Player got Command wParam (2)
6/25/2011 13:31:04.383: Last.FM: Player got Command wParam (1001)
6/25/2011 13:31:04.391: Last.FM: Submit Started at 1309026664
6/25/2011 13:35:39.932: Last.FM: Player got Command wParam (1)
6/25/2011 13:35:39.937: Last.FM: Player got Command wParam (1)
6/25/2011 13:35:39.943: Last.FM: Player got Command wParam (0)
6/25/2011 13:35:39.947: Last.FM: Player got Command wParam (2)
6/25/2011 13:37:39.077: Last.FM: Player got Command wParam (2)
6/25/2011 13:37:39.097: Last.FM: Player got Command wParam (1001)
6/25/2011 13:37:39.281: Last.FM: Player got Command wParam (1)
6/25/2011 13:37:39.285: Last.FM: Player got Command wParam (1)
6/25/2011 13:37:39.289: Last.FM: Player got Command wParam (0)
6/25/2011 13:37:39.293: Last.FM: Player got Command wParam (2)
6/25/2011 13:40:31.018: Last.FM: Player got Command wParam (2)
6/25/2011 13:40:31.049: Last.FM: Player got Command wParam (1001)
6/25/2011 13:40:31.253: Last.FM: Player got Command wParam (1)
6/25/2011 13:40:31.257: Last.FM: Player got Command wParam (1)
6/25/2011 13:40:31.262: Last.FM: Player got Command wParam (0)
6/25/2011 13:40:31.265: Last.FM: Player got Command wParam (2)
6/25/2011 13:40:32.969: Last.FM: Player got Command wParam (2)
6/25/2011 13:40:32.976: Last.FM: Player got Command wParam (1)
6/25/2011 13:40:32.980: Last.FM: Player got Command wParam (1)
6/25/2011 13:40:32.984: Last.FM: Player got Command wParam (0)
6/25/2011 13:40:32.988: Last.FM: Player got Command wParam (2)
Any ideas?
I'm having this exact same issue. Scrobbler shows that the submit was started but it never completes. Nothing ever shows in my last.fm page as now playing. Help would be appreciated!

mcow
Posts: 820
Joined: Sun Sep 21, 2008 9:35 pm
Location: Cupertino, California

Re: Last.fm Scrobbler help

Post by mcow » Wed Jul 20, 2011 8:46 pm

The scrobbler addon hasn't been updated on mediamonkey.com/addons, but the current version (1.0.2.29, at this writing) can be found here:
http://www.happymonkeying.com/plugin.php?q=300016

This was working fine for me in MM3 and continues to work fine in MM4.

Stigg
Posts: 269
Joined: Wed May 18, 2011 7:56 pm

Re: Last.fm Scrobbler help

Post by Stigg » Wed Jul 20, 2011 9:25 pm

Why is everyone still using this old thread to get this old version of the Last.fm Scrobbler?

mcow
Posts: 820
Joined: Sun Sep 21, 2008 9:35 pm
Location: Cupertino, California

Re: Last.fm Scrobbler help

Post by mcow » Thu Jul 21, 2011 10:58 am

Why don't you post a pointer to the correct thread instead of just implying that everyone else is stupider than you?

Pman
Posts: 169
Joined: Fri Jan 02, 2009 11:57 am

Re: Last.fm Scrobbler help

Post by Pman » Mon Aug 01, 2011 6:14 am

I've noticed a lot of people are posting last.fm help here when using MM4. Well if you are using MM4 or MM3, as posted on an earlier thread, here's some help for you to get last.fm working:

First things first, make sure you are using the very latest MM and very latest last.fm plugin.
Now, when installing last.fm plugin, make sure you run MM under "run as admin". Then double click the last.fm file, it will ask to install, untick the option for current user, ie you want it to work for all users on your computer, click install and it should work.

Things to check are:

1. Under Tools>Extensions there's only 1 Last.fm ext installed. If there's two then uninstall the one "for current user only"
2. Under C:\Users\User\AppData\Roaming\MediaMonkey delete all last.fm entries, most likely a auto file with last.fm in it too (if exists).
3. Under Tools>Options, under submission rules that only ".....submit tracks if Album metadata exists" is ticked NOTHING else.
(Note. on the "...part of the library" option ticked does also work but it depends on your luck)

If all that dont work, DONT uninstall MM, keep it be but do the following:

1. Uninstall last.fm
2. Under C:\Users\User\AppData\Roaming\MediaMonkey delete all last.fm entries (if exist)
3. Under same folder in 2., open the file Extensions.ini (in notepad) and delete any last.fm rubbish in there (if exists). Also open the file MediaMonkey.ini, search for last.fm and delete the big section (Should look like [Last.FM] then a bunch of lines of stuff, delete all this).
4. Under C:\ProgramData\MediaMonkey check Extensions.ini and delete any last.fm stuff and also delete the LastFMScrobbler folder if exists.
5. Under C:\Program Files\MediaMonkey\ make sure no last.fm stuff is left like in Scripts>Auto folder and Plugins folder (delete gen_LastFMScrobbler)
6. Restart MM with "run as admin"
7. Install last.fm (new one) with "install for current user" UNTICKED and then tweak the settings like in 3. under Tools>Options

Note: if using Windows XP, folders to consider are C:\Documents and Settings\User\Application Data\ or C:\Documents and Settings\User\Local Settings\Application Data

Hopefully that should work! Good Luck!
  • W7Ultimate x32 - MM4 - SHABBA!
Image

Cozzamara
Posts: 3
Joined: Sat Jul 25, 2009 1:34 am

Re: Last.fm Scrobbler help

Post by Cozzamara » Mon Oct 10, 2011 7:17 pm

Nothing of the above works for me. I tried plug-in versions 1.0.2.29 and 1.0.2.26.
Worse, after trying the above suggestions, extension options are no longer remembered, and nothing is written to the last.fm log file.

bonzo728
Posts: 40
Joined: Tue Mar 31, 2009 7:43 pm

Re: Last.fm Scrobbler help

Post by bonzo728 » Tue Oct 11, 2011 2:26 pm

I deleted my post from before since it seems there are several people on this thread with similar issues.

This happened several days ago. I was listening to an album and the songs were scrobbling fine, then all of a sudden they stopped about ten songs in (the album has 14 songs on it). I have tried uninstalling then reinstalling the add-on but that has not worked. I was wondering if there are any known issues right now or if anyone else has faced the same issue. The add-on has always worked for me; I am confused as to why it all of a sudden stopped working. When I listen through Spotify or other methods my songs will scrobble, so that leads me to believe that the problem is connected to MM. The songs show up as now playing but when they are completed they are not submitted to my profile. Also, let me reiterate that songs were scrobbling as normal then randomly stopped without me changing settings, etc. (I noticed people mentioning the time format as a possible issue but I did not touch/change anything) I emailed support about this as well, but figured I'd try the forum to see if anyone else has a possible solution. I just put on a couple songs and copied the log file. Here are the contents of that file:

Code: Select all

10/9/2011 15:58:04.426: MediaMonkey v3.2.4
10/9/2011 15:58:04.426: Loading Last.fm Scrobbler
10/9/2011 15:58:04.426: ----------------------------------------
10/9/2011 15:58:04.426: Last.fm Scrobbler v1.0.2.29
10/9/2011 15:58:04.442: ----------------------------------------
10/9/2011 15:58:04.442: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:04.442: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:11.082: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:11.082: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:11.114: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:11.942: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:11.957: Last.FM: Player got Command wParam (Title)
10/9/2011 15:58:11.957: Last.FM: Player got Command wParam (Status)
10/9/2011 15:58:12.004: Last.FM: Nowplaying Play Detected at 1318190291
10/9/2011 15:58:12.067: Last.FM: Handshake Session Started
10/9/2011 15:58:12.536: Last.FM: Handshake OK
10/9/2011 15:58:13.082: Last.FM: Handshake Session ID is b909767caf5d46949efa9202752468d1
10/9/2011 15:58:13.098: Last.FM: Handshake NowPlaying URL is http://post.audioscrobbler.com:80/np_1.2
10/9/2011 15:58:13.098: Last.FM: Handshake Submission URL is http://post2.audioscrobbler.com:80/protocol_1.2
10/9/2011 15:58:13.114: Last.FM: NowPlaying Song The London Souls - Intro
10/9/2011 15:58:13.129: Last.FM: NowPlaying Accessing Last.FM Site
10/9/2011 15:58:13.348: Last.FM: NowPlaying OK
10/9/2011 15:58:45.911: Last.FM: Player got Command wParam (Status)
10/9/2011 15:58:45.973: Last.FM: Player got Command wParam (Play Counter)
10/9/2011 15:58:45.989: Last.FM: Submit Started at 1318190325
10/9/2011 15:58:45.989: Last.FM: Session ID b909767caf5d46949efa9202752468d1
10/9/2011 15:58:46.051: Last.FM: Player got Command wParam (Status)
10/9/2011 15:58:46.067: Last.FM: Nowplaying Play Detected at 1318190326
10/9/2011 15:58:46.067: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:46.067: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:46.082: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:46.145: Last.FM: Player got Command wParam (Volume)
10/9/2011 15:58:46.161: Last.FM: Player got Command wParam (Title)
10/9/2011 15:58:46.176: Last.FM: Player got Command wParam (Status)
10/9/2011 15:58:46.192: Last.FM: Nowplaying Play Detected at 1318190326
10/9/2011 15:58:46.207: Last.FM: Session ID b909767caf5d46949efa9202752468d1
10/9/2011 15:58:46.270: Last.FM: NowPlaying Song The London Souls - She's So Mad
10/9/2011 15:58:46.364: Last.FM: NowPlaying Accessing Last.FM Site
10/9/2011 15:58:46.582: Last.FM: NowPlaying OK

bonzo728
Posts: 40
Joined: Tue Mar 31, 2009 7:43 pm

Re: Last.fm Scrobbler help

Post by bonzo728 » Wed Oct 12, 2011 4:41 pm

**UPDATE**

Updating to MM 3.2.5 seems to have done the trick for me. I also uninstalled last.fm from my computer and re-installed it. Not sure which of those two things made it work, but I have a feeling it was updating MM.

bonzo728
Posts: 40
Joined: Tue Mar 31, 2009 7:43 pm

Re: Last.fm Scrobbler help

Post by bonzo728 » Sat Oct 15, 2011 1:22 pm

bonzo728 wrote:**UPDATE**

Updating to MM 3.2.5 seems to have done the trick for me. I also uninstalled last.fm from my computer and re-installed it. Not sure which of those two things made it work, but I have a feeling it was updating MM.
I guess I spoke too soon. Worked perfectly again for all of four days and now it is back to not scrobbling. I was listening to an album and the first two songs were scrobbled and the rest were not, and now nothing scrobbles. I am not changing anything that would cause this to not work. Any help would be really appreciated.

at_oussama
Posts: 11
Joined: Tue Jan 03, 2012 2:50 pm

[Last.fm]Problem When scrobbling Unicode songs in cache-mode

Post by at_oussama » Tue Jan 03, 2012 3:07 pm

I'm using the official mediamonkey scrobbler and the latest version.

When trying to scroble my music in the cache mode, everything is normal, but when i got songs with Unicode tags ( Japanese, Chinese and all non-latin characters ), they are written to the cache file as ?????? and when i activate the normal mode ( the green button ) they are submitted to last.fm as ?????????? too.

i think this is a problem of the plugin since i got ??? in the cache data file too, is there any solution ? or are u working on that for future ? please help me :(

meto

Re: Last.fm Scrobbler help

Post by meto » Tue Jan 10, 2012 1:01 pm

ММ4 v. 4.0.2.1462 + Scrobbler v.1.0.2.29: scrobbling works well -> change user to another (with no MM running) -> change back to first user -> scrobbling don't works untin MM restart.
MM running as admin (and during scrobbler intallation too).

SyncMusic
Posts: 5
Joined: Mon Mar 08, 2010 12:42 pm

Last.fm Scrobbler doesn't scrobble after hibernation

Post by SyncMusic » Thu Jan 12, 2012 11:14 am

The Last.fm Scrobbler (1.0.2.29) doesn't Scrobble any tracks after I wake my PC up after Suspend to Disk. The Log of the Scrobbler also shows no activity after the PC went into Hibernation mode for the first time. If you close mediamonkey (4.0.2.1642) and restart it, the Scrobbler works fine again.
Update:
Suspend to Ram doesn't cause this problem, only Suspend to Disk seems to cause this.
I'm using Win 7 x64 if that helps

Varder
Posts: 3
Joined: Wed Jan 18, 2012 9:18 am

Re: Last.fm Scrobbler help

Post by Varder » Wed Jan 18, 2012 9:33 am

Okay so I'm having a very very annoying issue with my Last.fm scrobbler. It started to happen since I installed MediaMonkey 4. Everytime I listen to music from MediaMonkey and I start playing some game, it stops scrobbling. It happens with most games, though there are a few that don't seem to create a problem for MediaMonkey. I am using the latest Last.fm Scrobbler v1.0.2.29, my MediaMonkey is 4.0.2.

Post Reply