Last.fm Scrobbler help

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

Alex Scott
Posts: 17
Joined: Mon May 28, 2007 7:41 am
Location: Dublin
Contact:

Re: Last.FM Scrobbler not Submitting?

Post by Alex Scott » Sun Oct 04, 2009 7:20 am

You're excluding the tracks in your filters. Go to Options > Last.fm Service > Submission Rules and uncheck the boxes by 'Exclude tracks that match the following filters:'.

Guest

Re: Last.FM Scrobbler not Submitting?

Post by Guest » Tue Oct 06, 2009 12:41 am

Okay, when I goto my last.fm options it does not have anything about filters. only fields for username and pw as well as three boxes to check underneath.. Is there a different plugin that you have? My last.fm plugin has not worked for media monkey in probably over a year. Once in awhile it will actually scrobble something but there are no filters in my plugin to mess with.

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: Last.FM Scrobbler not Submitting?

Post by nohitter151 » Tue Oct 06, 2009 9:06 am

Guest wrote:Okay, when I goto my last.fm options it does not have anything about filters. only fields for username and pw as well as three boxes to check underneath.. Is there a different plugin that you have? My last.fm plugin has not worked for media monkey in probably over a year. Once in awhile it will actually scrobble something but there are no filters in my plugin to mess with.
Click the "Submission rules" button. If it isn't there, you need to download the latest version of the plugin:
http://www.mediamonkey.com/addons/general/
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Peke
Posts: 11100
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Last.FM Scrobbler not Submitting?

Post by Peke » Fri Oct 09, 2009 4:44 pm

I have not received any additional issues recently and no feedback from those that had issues.

Can you people confirm that it is OK now?
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
How to add Images to forum

Owyn
Posts: 2018
Joined: Fri Mar 21, 2008 10:55 am
Location: Canada

Re: Last.FM Scrobbler not Submitting?

Post by Owyn » Fri Oct 09, 2009 5:29 pm

Peke wrote:I have not received any additional issues recently and no feedback from those that had issues.

Can you people confirm that it is OK now?
Submission and caching have been working fine for me for some time. Survived quite nicely through the recent extended Last.Fm maintenance.

Only problem is that the new exclusion submission rules do not work. Now playing is properly filtered but the play complete is still submitted.
Cogito cogito ergo cogito sum. (Ambrose Bierce)
I drink therefore I am. (Monty Python)
Vista 32bit Home Premium SP2 / MM3.2.1.1297 Gold / Last.Fm 1.0.2.22 / IE8
Dell Inspiron 530 (1.8 Core2 / 2GB)
Skin: Vitreous Blue
Scripts: Add/Remove Playstat|Advanced Duplicate Find & Fix|Album Art Tagger|Backup|Batch Art Finder|Calculate Cover Size|Case&Leading Zero Fixer|DB_Audit|DB_Clean|DB_Schema|Event Logger|Genre Finder|Lyricator|Magic Nodes|MM2VLC|Monkey Rok|MusicIP Tagger|PUID Generator|RegExp Find & Replace|Right Click for Scripts|Scriptreloader|SQL Viewer|Stats(Filtered)|Tagging Inconsistencies

Guest

Re: Last.FM Scrobbler not Submitting?

Post by Guest » Sat Oct 10, 2009 10:49 am

hi, it seems i have the same problem. my log file:

Code: Select all

11.10.2009 17:38:10.851: Last.FM: Cache add 36 Crazyfists - The All Night Lights
11.10.2009 17:38:10.863: Last.FM: Cache track added 36 Crazyfists - The All Night Lights
11.10.2009 17:38:10.874: Last.FM: Handshake Session Started
11.10.2009 17:38:15.759: Last.FM: Handshake Bad System Clock Time
11.10.2009 17:38:15.803: Last.FM: NowPlaying Skipping
11.10.2009 17:41:14.429: Last.FM: Submit Started at 1255275674
11.10.2009 17:41:14.455: Last.FM: Handshake Session Started
11.10.2009 17:41:14.581: Last.FM: Nowplaying Play Detected at 1255275674
11.10.2009 17:41:16.735: Last.FM: Handshake Bad System Clock Time
11.10.2009 17:41:16.755: Last.FM: Cache add 36 Crazyfists - We Gave It Hell
11.10.2009 17:41:16.767: Last.FM: Cache track added 36 Crazyfists - We Gave It Hell
11.10.2009 17:41:16.778: Last.FM: Handshake Session Started
11.10.2009 17:41:18.787: Last.FM: Handshake Bad System Clock Time
11.10.2009 17:41:18.805: Last.FM: NowPlaying Skipping
11.10.2009 17:45:21.048: Last.FM: Submit Started at 1255275921
11.10.2009 17:45:21.075: Last.FM: Handshake Session Started
11.10.2009 17:45:21.112: Last.FM: Nowplaying Play Detected at 1255275921
11.10.2009 17:45:23.050: Last.FM: Handshake Bad System Clock Time
11.10.2009 17:45:23.068: Last.FM: Cache add 36 Crazyfists - The Back Harlow Road
11.10.2009 17:45:23.079: Last.FM: Cache track added 36 Crazyfists - The Back Harlow Road
11.10.2009 17:45:23.090: Last.FM: Handshake Session Started
11.10.2009 17:45:25.069: Last.FM: Handshake Bad System Clock Time
11.10.2009 17:45:25.107: Last.FM: NowPlaying Skipping
my submission rules are activated.
i've execluded only podcasts and audio books.
also i checked the boxes 'must be in library' and 'album information must exist'...
my time zone is correct, UTC+1.

Peke
Posts: 11100
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Last.FM Scrobbler not Submitting?

Post by Peke » Sun Oct 11, 2009 3:04 pm

Have you tried to sync your clock with some time server using app like http://freelabs.info/AtomicClock.aspx ?

BTW if you are in Summer time like me than it is UTC+2 (GMT+2)
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
How to add Images to forum

Guest

Re: Last.FM Scrobbler not Submitting?

Post by Guest » Sun Oct 11, 2009 4:17 pm

hi, thx for the reply. my time zone seems to be correct, berlin, UTC+1. the time on my pc matches with the one in my home, too ;-) .

i come to think of it - perhaps it's not mediamonkey, nor the plugin, but windows 7. :roll:
forgot to add this hint to my previous post.

i have no idea how MM gets the time, but perhaps the interface is different in win7, as it was in xp or vista!?
but the logfile shows the right time...
i have absolutely no idea ^^ on winX,P with the same MM and plugin version, it works like a charme.

any more ideas on this? or info i can post, to help solving this?

Peke
Posts: 11100
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Last.FM Scrobbler not Submitting?

Post by Peke » Sun Oct 11, 2009 7:29 pm

@guest
Just had tested with Win 7 RC1 x64 and absolutely no issues.

Anyone else?
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
How to add Images to forum

Guest

Re: Last.FM Scrobbler not Submitting?

Post by Guest » Wed Oct 14, 2009 4:25 pm

came to think of the regional setting, postet on site one. but no changes there had any effects on the scrobbling. but there are more configuration possibilities than in xp (and vista!? don't remember actually...).
i think this could be the "source of evil"... just a thought. but an error, not expierienced by everybody. great! ^^ couldn't be better ;-)

Guest

Re: Last.FM Scrobbler not Submitting?

Post by Guest » Mon Oct 19, 2009 12:48 pm

BIG SORRY. it was my fault. not seeing the tree in front of all the wood. damn.

my date was wrong! so simpel. i checked it many times, thought i checked the time, which was perfectly correct. however, win7 got the date wrong, i was one day in future.
sorry for (perhaps) causing trouble and bug-searching.

thanks for the great plugin, anyway! keep up the good work. i love scrobbling ;-) and now - MM does.

hatsharpener

Re: Last.fm Scrobbler help

Post by hatsharpener » Fri Oct 23, 2009 1:08 pm

Everything was working fine up until Oct 20th, at which point my "Now Playing" submissions are the only part working. The "OK, I completed this song" submissions are not.

The log shows this:

10/23/2009 11:04:55.744: Last.FM: Cache Submission Unknown Error <HTML><HEAD>
10/23/2009 11:04:55.807: Last.FM: Cache Submission Unknown Error <HTML><HEAD>

I've tried clearing the cache (which doesn't seem to work it always submits a ton of songs), tried restarting MediaMonkey and my computer...

My timezone and date settings are correct.

Not sure what to make of the "Unknown Error." Any ideas?

Thanks!

- Derek

Peke
Posts: 11100
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Last.fm Scrobbler help

Post by Peke » Fri Oct 23, 2009 9:13 pm

@Derek/hatsharpener
Can you please do these steps and then send me compressed LastFM_Log.txt and LastFM_Cache.dat to pavle mediamonkey com:
1. Delete LastFM_Log.txt and LastFM_Cache.dat *
2. Start MM
3. Play few tracks
4. close MM
5. send me mail with logs.

* - http://www.mediamonkey.com/support/inde ... ticleid=17
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
How to add Images to forum

hatsharpener
Posts: 2
Joined: Fri Oct 23, 2009 1:09 pm

Re: Last.fm Scrobbler help

Post by hatsharpener » Mon Nov 02, 2009 10:37 am

Peke wrote:@Derek/hatsharpener
Can you please do these steps and then send me compressed LastFM_Log.txt and LastFM_Cache.dat to pavle mediamonkey com
OK, I sent these. Thanks.

xandermac05

Re: Last.fm Scrobbler help

Post by xandermac05 » Thu Nov 12, 2009 3:29 pm

The Windows 7 date format issue appears to be fixed by replacing the short date setting with d/M/yyyy (rather than dd/MM/yyyy) in Control Panel. No idea why, but it works!

Post Reply