Page 1 of 24

Last.fm Scrobbler help

PostPosted: Tue Aug 04, 2009 7:06 pm
by Alex Scott
I've tried all the information in the Last.FM FAQs but without any success.

I'm scrobbling using MediaMonkey 3.1 and the latest official plug-in. The tracks show as 'Now Playing', but aren't added to 'recently played tracks' or the charts when they complete. Weirdly, the logs for the scrobbler report that the tracks are submitted OK:

8/5/2009 00:44:25.034: Last.FM: Submit Started at 1241739865
8/5/2009 00:44:25.061: Last.FM: Session ID fa52995551c14ca49f0629b367a40d74
8/5/2009 00:44:25.646: Last.FM: Submit Testament - Signs of Chaos
8/5/2009 00:44:25.917: Last.FM: Submit Started
8/5/2009 00:44:26.184: Last.FM: Submit OK

For some reason this is only happening on one of my machines. The only difference between the two is that one is a clean install of Windows 7 x64, and the other is an upgraded Windows 7 x86.

Any ideas?

Re: Last.FM Scrobbler not Submitting?

PostPosted: Tue Aug 04, 2009 9:56 pm
by Peke
Are you sure that last.fm didn't filtered your submissions plugin log shows that site accepted scrobbling?

Re: Last.FM Scrobbler not Submitting?

PostPosted: Wed Aug 05, 2009 4:42 am
by Alex Scott
Yep, certain, I actually turned off all the filters (and have tried various other combinations, to no success). I'm pretty sure the log shows when a song is filtered, anyway.

Re: Last.FM Scrobbler not Submitting?

PostPosted: Wed Aug 05, 2009 3:12 pm
by Peke
Log shows only Last.fm server/service reply and after Submit OK is received that means that plugin submissions are accepted and proceeded by Last.fm Site so that they can update users page. Are you using latest v1.0.2.21 plugin version.

Re: Last.FM Scrobbler not Submitting?

PostPosted: Wed Aug 05, 2009 3:24 pm
by Alex Scott
Yes, definitely the latest plugin.

Thanks for looking into this, I appreciate it.

Re: Last.FM Scrobbler not Submitting?

PostPosted: Sat Aug 08, 2009 5:12 am
by Extranion
Did you play the music what is in your libary?

It scrobbles only the files that are in your mediamonkey libary!

Re: Last.FM Scrobbler not Submitting?

PostPosted: Sat Aug 08, 2009 7:15 am
by Alex Scott
Yes, all the music to be scrobbled is in my library. Also, I'm pretty sure that if I was trying to scrobble something that the submission rules 'cancel out', it wouldn't appear as 'now playing' on the Last.FM website, and there would be some sort of message in the logs indicating that.

Re: Last.FM Scrobbler not Submitting?

PostPosted: Sat Aug 08, 2009 8:07 am
by Peke
@Alex
Have you tried to log on last.fm and see their logs. I use both Windows 7 x64 RC and Windows XP without problems.

"Last.FM: Submit OK" indicates that last.fm accepted mediamonkey scrobbling and it will add it to your library, In the past I've seen such issues that their server show tracks with delay and/or playcounter increases but no tracks are added to personal last.fm page

Re: Last.FM Scrobbler not Submitting?

PostPosted: Sat Aug 08, 2009 12:44 pm
by Alex Scott
No, I haven't tried that - how do I see the logs on Last.FM?

Re: Last.FM Scrobbler not Submitting?

PostPosted: Sat Aug 08, 2009 9:31 pm
by Peke
If I remember correctly once I've seen an option when I log on my account and selects library view that Site informed me that I have Submission errors.

Re: Last.FM Scrobbler not Submitting?

PostPosted: Tue Aug 11, 2009 4:27 pm
by Alex Scott
I can't find that option anywhere unfortunately.

There's another weird thing I've noticed. Before August 1st all my tracks were submitting correctly on this machine, but since August 1st they are not.

Could I have done something on August 1st that caused this to happen, do you think? Is there a log file I can look at that would tell me?

Re: Last.FM Scrobbler not Submitting?

PostPosted: Tue Aug 11, 2009 4:39 pm
by Alex Scott
Looking at my OLD Last.FM logs, I can see that the date format in the old files is DD/MM/YYYY, but in the NEW files it's MM/DD/YYYY. Seems like this could easily be the problem.

Where does MediaMonkey get the date from, and why might it have changed? On my machine, the date still displays as DD/MM/YYYY.

Re: Last.FM Scrobbler not Submitting?

PostPosted: Tue Aug 11, 2009 5:19 pm
by Alex Scott
I fixed it. It was an issue with the date format.

I checked the region settings between the two machines, one of which works and one doesn't. The machine that didn't work had a slightly different value for 'Short Time', which is found in the 'Region and Language' control panel. I switched the value to 'h:mm tt' and the scrobbler works perfectly again.

Weird, but I'm glad I worked it out.

Re: Last.FM Scrobbler not Submitting?

PostPosted: Tue Aug 11, 2009 7:08 pm
by Peke
Strange, mine is in "H:mm:ss" and had no issues. Especially as Last.fm works on Unix Time (Eg. seconds passed from 01.01.1970 00:00), but I'm glad that you worked it out.

Re: Last.FM Scrobbler not Submitting?

PostPosted: Tue Aug 11, 2009 7:12 pm
by Alex Scott
Me too - but it might be worth looking into how MediaMonkey gets the date / time format from the machine. The machine that had problems was a fresh install of Windows 7, whereas the one that didn't have any problems was upgraded from Vista. Both are set to United Kingdom as the region.

Just saying, in case this problem is reproducible with other fresh installs of Win 7, in which case it will come up quite a lot come October.