Discogs Tagger 3.62 (Updated: 2013-02-09)

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

Let
Posts: 204
Joined: Mon Jun 15, 2009 1:46 am
Location: İstanbul, Turkey

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by Let » Wed Aug 03, 2011 1:01 am

Sounds like an error occurs in a loop. Have you installed MSXML6 ? It uses Internet Explorer rather than Firefox. You're not using IE9 beta, right?

r0k
Posts: 54
Joined: Wed Jul 27, 2011 11:13 am

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by r0k » Wed Aug 03, 2011 2:15 am

Let wrote:you can "disregard and continue" for this installation.
Yes, except that i can't. As i already said in my last post.
Too much redirections in the link. I always end up on the Commodo page even if i try to bypass the warning, probably because the link does not link to the installer itself, but to a page with another link, and from link to link the Commodo Secure DNS will always block me from reaching it.

It's impossible for me to download this script. Even if i want to bypass all warning, i can't because of redirections occuring on top of redirections.

scottyoope

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by scottyoope » Wed Aug 03, 2011 6:53 am

Let wrote:Sounds like an error occurs in a loop. Have you installed MSXML6 ? It uses Internet Explorer rather than Firefox. You're not using IE9 beta, right?
I'm pretty sure I have MSXML6 installed but how do I check for sure? I vaguely remember installing it previously for another issue I was having.

I am definitely NOT using IE9. So, when you say that MSXML6 uses Internet Explorer, how does that affect me? Firefox is my default browser and pops up once I try to auto-tag. IE doesn't even open, but is installed on my machine.

What do you think I should do next?

Thanks!

Let
Posts: 204
Joined: Mon Jun 15, 2009 1:46 am
Location: İstanbul, Turkey

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by Let » Wed Aug 03, 2011 8:55 am

discogs tagger depends on two things. 1) MSXML6 (download it from microsoft and install) 2) Shell.Explorer ActiveX which depends on IE. I can't think of any reason. Have you tried uninstalling and reinstalling?

Queseuq
Posts: 111
Joined: Sat Apr 05, 2008 8:30 am

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by Queseuq » Sun Aug 07, 2011 12:58 pm

Now that the Discogs api dosn't need a key are you working on a new version which doesn't ask for a key? Just wondering if I should sign up now or wait until I don't have to.

Let
Posts: 204
Joined: Mon Jun 15, 2009 1:46 am
Location: İstanbul, Turkey

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by Let » Mon Aug 08, 2011 5:39 am

i'm working on it but you'd better use the current version (which works as well as v2). i am adding more features like master release, label and artist loading, which might take some time.

huge
Posts: 48
Joined: Sun Mar 28, 2010 9:12 pm

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by huge » Tue Aug 09, 2011 1:49 pm

I just installed discogs and am using it for the first time. I keep getting the message:

"Cannot query the web site - The download of the specified resource has failed."


I see some instances of this problem in past posts in this thread, but not a clear solution that seems to apply to me. I can log in to the discogs website and execute the same query and get good results. I tried disabling my firewall just in case - no luck. But I'm guessing it's some simple MM configuration problem...

Any advice?

ed9838

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by ed9838 » Wed Aug 10, 2011 12:13 am

Hello,
I love the Discogs tagger and it has been working wonderfully for me. For some reason though, when I try to autotag Discogs release 1863851, I am missing quite a few involved people. Like I said, this is the first time I've seen this issue, have I found some strange bug?
Thanks for your help!

Let
Posts: 204
Joined: Mon Jun 15, 2009 1:46 am
Location: İstanbul, Turkey

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by Let » Wed Aug 10, 2011 1:16 am

huge: are you using proxy? do you have msxml6 installed?

ed9838: it's not a bug but you can call it a missing feature. It doesn't support credits with track numbers (like 3tracks: 6,7, 10 to 15) I never thought this can be used as in this release.

huge
Posts: 48
Joined: Sun Mar 28, 2010 9:12 pm

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by huge » Wed Aug 10, 2011 3:27 am

Let wrote:huge: are you using proxy? do you have msxml6 installed?
I'm not using a proxy. I believe I have msxml6 installed ... I'm running Windows 7 64-bit, and I have a file in Windows/System32 called msxml6.dll with file description: "MSXML 6.0 SP3". Is there some further test to verify that I have it properly installed?

Any other ideas about why I'm getting the "Cannot query the web site - The download of the specified resource has failed." error message?


thanks for the reply...

Let
Posts: 204
Joined: Mon Jun 15, 2009 1:46 am
Location: İstanbul, Turkey

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by Let » Wed Aug 10, 2011 4:15 am

when I google "The download of the specified resource has failed" i get many results. it's best you check them.

ed9838

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by ed9838 » Wed Aug 10, 2011 11:59 am

Hi Let,
Thanks for your response. Is the ability to get involved people designated by tracks from Discogs planned for a future update?
Thanks!
Colter

Let
Posts: 204
Joined: Mon Jun 15, 2009 1:46 am
Location: İstanbul, Turkey

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by Let » Thu Aug 11, 2011 1:17 am

It is a bit tricky business since I'll need a parser and change the place of extra artist processing.

I'am testing the new version (v3.3) and I'll be releasing it soon. I don't promise but I'll try to include it in the following version.

huge
Posts: 48
Joined: Sun Mar 28, 2010 9:12 pm

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by huge » Thu Aug 11, 2011 1:45 pm

Let wrote:when I google "The download of the specified resource has failed" i get many results. it's best you check them.
Let ... thanks for the reply, but after looking at several google hits for that error message, I must confess that I'm not any closer to knowing why I'm getting that error when I try to use Discogs Tagger 3.2 in MediaMonkey. Every page I found discussing that error message was written by people trying to figure out how to rewrite their own scripts/code to avoid the error, or talking about how that error was a server-side problem. I'm very willing to believe that I just haven't found the right link yet that will open my eyes and answer my questions, but I've waded through quite a few of them.

Is it possible that you could give me more info or a more specific pointer to some info that might help me to make Discogs Tagger work on my system? I'm guessing that I need to do something to reconfigure msxml, but I don't know enough about msxml to even guess at what that might be. There is nothing unusual that I can think of about my system that might be causing this, and MediaMonkey in general seems to be working fine, including being able to access the internet to auto-tag (before I installed Discogs Tagger).

Thanks for your help - sorry if I'm testing your patience...

bmcclure
Posts: 78
Joined: Wed Jan 09, 2008 8:04 pm

Re: Discogs Tagger 3.2 (Updated: 2011-07-08)

Post by bmcclure » Thu Aug 11, 2011 2:25 pm

@Huge:

That could be related to a number of things. I don't receive this error so it's hard to tell from my end, but will try to provide a couple suggestions to hopefully assist. Apologies in advance if it's not helpful :)

1. Could there be a problem with your Discogs API key?
-Are you sure you copied it correctly? You could check the key listed inside the <AppData>\MediaMonkey\Scripts\DiscogsAutoTagWeb.vbs file to make sure it is exactly right.
-Has it worked for you before, and if so, when did it stop working? Was it after updating something?


2. Is it possible you could have an outdated version of MSXML on your machine?

I see this error occurring a lot with MSXML prior to version 6.0.

If you're not sure, you can check what current version of MSXML you have by using the following tool from Microsoft: http://support.microsoft.com/kb/278674

There can be more than one XML parser installed (and reported by that tool), but make sure MSXML 6 is present.

Just to make sure, you could always try updating MSXML with the latest version from Microsoft: http://www.microsoft.com/download/en/de ... en&id=3988
--
Ben

Post Reply