Sync back ratings & play counts (MSC) v1.9.3 2013-12-03

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

bettertthan74
Posts: 53
Joined: Sun Sep 16, 2012 2:59 pm

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by bettertthan74 » Mon Sep 17, 2012 11:33 am

I've read through the thread a few times and I'm still not sure if playcounts are synced the way Ithought..

I deleted all the music on my phone and synced a few playlists using MM 4. I did a sync back and imported stats into player pro.
I listened to music for a few days using just my skyrocket and went through the steps so update MM but didn't see any changes.

Here is what I did.
1) in player pro exported stats in songbird format
2) connected using usb drives to media monkey. Selected sync back. Checked options, sync playcounts is selected.
3) Checked MM and lastplayed and playcounts not updated.

One example from my imported imported_Mon_Sep_17_110015_import.xml from playerpro

- <mediaitem>
<last-played>1347843751285</last-played>
<artist>Foo Fighters vs. Starsailor</artist>
<track>Foo To The Floor [DJ Zebra]</track>
<album>Mash-Up Your Bootz Party Vol. 15</album>
<duration />
<rating>0</rating>
<play-count>39</play-count>
<skip-count />
</mediaitem>

when I check the same song on MM it has a playcount of 38. I don't know how to read the date in the xml, but MM has is played on 9-10-2012.
The song also shows up as the most recently played song on Playerpro..

I'm sure I'm doing something wrong. Any help is appreciated, like so many people I just want to get away from Itunes, but I use playcounts and play dates in most of my playlists

Thanks.

Aff
Posts: 301
Joined: Sun Oct 05, 2008 4:46 pm
Location: Switzerland

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by Aff » Mon Sep 17, 2012 3:04 pm

I can't see any reason why it shouldn't have been updated in MM as both play count and play date are higher than in MM. Have you seen the song file in the update list?
How did you sync the playlists? Only the last auto-sync is relevant!
Please activate the debug log, run SyncBackRatings again and send me a PM with it.

bettertthan74
Posts: 53
Joined: Sun Sep 16, 2012 2:59 pm

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by bettertthan74 » Wed Sep 19, 2012 12:28 pm

I think I see a possible issue. I look in the export file from playerpro and the same song is in there twice. Once with 38 plays and once with 1. I only have one copy in my media monkey library and one copy on the phone. I resync all the music from a folder called syncr to a folder called music. I wonder if Playerpro isn't able to clear out its statistics properly after moving a library. I have it set to only look for music in the /music folder. I've PMed you the file for reference.

Aff
Posts: 301
Joined: Sun Oct 05, 2008 4:46 pm
Location: Switzerland

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by Aff » Thu Sep 20, 2012 2:23 pm

The PM has not arrived in my inbox.
What do yo mean with resync from syncr to music?
What do you mean with moving a library?

bettertthan74
Posts: 53
Joined: Sun Sep 16, 2012 2:59 pm

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by bettertthan74 » Thu Sep 20, 2012 4:28 pm

I guess I did it wrong, but I think I figured out what was happening and it has to do with how playerpro handles its library.

I had all my music under a directory called syncr under a folder per artist. I erased them and changed MM's settings so that all music was synced to a folder called /music and just files were there in the root of that directory.

I kept seeing duplicates in my playerpro export. One song with the right stats from the import and the duplicate would have 0 plays.
I cleared all of playerpro's app data but it rebuilt the database with the same info. I then cleared the app data for the mediaserver service on my phone after a half hour player pro is creating exports without dupes. I reimported statistics into Playerpro and it still is not showing Duplicates in the songbird file.
I am having my phone play a bunch of songs randomly and will synch with MM tonight and let you know if the stats work.

It looks like ultimately androids Mediaserver was giving the wrong info to Playerpro. The songs were physically removed days ago, but there were still in the index.

FlickTheBean

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by FlickTheBean » Sat Sep 22, 2012 1:35 pm

Hi Aff,

Sorry I havent responded since my last post...been super busy.

I finally had some time to play around with your new SyncBackRatings (v1.5) and so far its working quite well. It can update play counts and last played dates when I sync. There has been some instances however, when it only updates the last play date but not the play count. So it recognizes that it was played recently and updates the last played date, but the play count remains the same. This seems to happen wehn I play the song on MM, then play the song on my phone, then try to sync back - though I'm not 100% sure of this, I will test it some more to see why its not updating on these occasions.

redeuxx
Posts: 5
Joined: Mon Mar 30, 2009 11:24 pm

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by redeuxx » Sat Sep 22, 2012 9:57 pm

Do I have to import/export every time I re-sync my library with different tracks?

Aff
Posts: 301
Joined: Sun Oct 05, 2008 4:46 pm
Location: Switzerland

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by Aff » Sun Sep 23, 2012 6:58 am

You mean Export and Import :)
Yes, you have to, because only the last auto-sync is relevant. Tracks that were in previous auto-syncs and not in the last one won't be updated anymore.

What you can do is to run Export+SyncBackRatings+Import several times before a next auto-sync in order to keep the stats up-to-date on both sides.

I auto-sync pretty seldom (but e.g. 8 GBs at once) and Sync back ratings & play counts regularly in between.

FlickTheBean

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by FlickTheBean » Wed Sep 26, 2012 11:18 pm

Ok I'm not sure why this is happening to me but everytime I sync back now it will update everything EXCEPT for play count. Any ideas?

Aff
Posts: 301
Joined: Sun Oct 05, 2008 4:46 pm
Location: Switzerland

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by Aff » Sat Sep 29, 2012 9:07 am

Could you please enable the option to write a debug log file and send me a PM with the log and the xml (formatted as code).

Please keep in mind that play counts are not added up, i.e. if you played a track once in MM and once in PlayerPro, it won't sync back a play count of 2, but stays at 1 on both sides.

Guest

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by Guest » Sat Sep 29, 2012 4:25 pm

Aff, do I have to enable that and then sync back agian then send you the report??

Aff
Posts: 301
Joined: Sun Oct 05, 2008 4:46 pm
Location: Switzerland

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by Aff » Sat Sep 29, 2012 5:36 pm

Yes, if you think there is at least one song with higher play count that you have exported from Android PlayerPro than in MM. If you know the song, could you please PM me artist and title as well.

thiagorobis

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by thiagorobis » Sun Sep 30, 2012 6:07 pm

Hello,
Can I make a suggestion that might help the users too?
For example, it would be easier to implement an option where indicated PlayerPro the file generated by the script and then updates the biblitoeca in MM?
For example, my phone only supports MTP mode. But I can access the folder and grab the PlayerPro. Generated xml. In would create an option to have displaced this file. Generated in xml mobile, so even manual, and update the library of MM?
Unfortunately I know nothing of VB to be able to help! = (

Aff
Posts: 301
Joined: Sun Oct 05, 2008 4:46 pm
Location: Switzerland

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by Aff » Mon Oct 01, 2012 3:14 pm

Thanks for your suggestion. If I understand it correctly:
  1. You've got an Android device that supports MTP only
  2. You would copy the XML file exported from PlayerPro to the PC manually, execute SyncBackRatings, then copy the import.xml file manually back to the phone
  3. An option would be needed to set the path to the XML file on the PC.
Some more changes would be needed to the script:
  1. Read ratings from XML instead of MM node
  2. Change matching for the songs on the device because MTP has no drive letter
As you can see, it would be quite complicated for the user to handle the XML file and a lot of work would be needed on the script.

There are workarounds for MTP devices via SD card (see OP), and I don't have enough time to work on the script currently, but never say never...

toyzrme

Re: Sync back ratings & play counts (MSC) v1.5 2012-09-02

Post by toyzrme » Sun Oct 07, 2012 4:45 pm

Hi -
I have SBR half working....LOL

FYI, I am fairly new to MM, and Player Pro, so be gentle...

By half, I mean I am able to sync back the ratings from the internal flash on my phone, but not the external mSD card I put in the phone (64GB). Unfortunately, I was traveling a while before getting back to my MM desktop to sync back, and have literally 1500 tracks rated on the external mSD card (I can see/count them in MM by selecting the 'all' node in music on the MSC drive, then sorting by rating). So I know the rating tags were saved to the mp3 files on the card.

BUT, when I do the PPro 'export ratings', change to MSC, plug in, and do 'sync back ratings' (v1.5), I see it only goes through the ~900 mp3's I have on the internal flash - never the ~4,300 on the mSD card. And given I got 1500 of them rated on my mSD, I'd really like to get those ratings sync'd back to MM!

FYI, when I originally sync'd the files onto the mSD, it acted weird - it never quite filled up all 64GB - I'm afraid it may have stalled/failed silently, and never written something that was needed for this process. I even tried 'Rescan files to the Library' on the SD card files, but that didn't seem to help.

Again, I've got the process working fine on the *internal* flash - I have done multiple cycles now.

Any suggestions or ideas what happened, what I'm doing wrong, or how I could fix this and not lose those 1,500 ratings?

Thanks!

Post Reply