Script Error

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

JulianX

Script Error

Post by JulianX » Wed Feb 14, 2018 12:15 pm

Sorry, I accidentally open this in Addon developers section instead of here.

Greetings all :D

I Am Using MM 4.1.19.1859 on WinXP SP3 very well maintained.
Everything is working perfect,
Unfortunately, I have one particular issue executing the built-in Script SwapArtistAlbum.Vbs.
Every time I try to use it I get this error message:

"Error #438 - Microsoft VBScript runtime error
Object doesn't support this property or method:
File C:/Program Files.../Script/SwapArtistAlbum.vbs" Line 15, column:4"

I've been googling for hours and the forum and couldn't find a way to fix it.
my scripting knowledge is very limited.
Can anyone please help me, I'm already going mad.
Thank you in advance.
Julian

Lowlander
Posts: 44883
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Script Error

Post by Lowlander » Wed Feb 14, 2018 12:20 pm

Install MediaMonkey 4.1.20, does that solve the problem? If not, did you modify the Script?
Lowlander (MediaMonkey user since 2003)

JulianX

Re: Script Error

Post by JulianX » Wed Feb 14, 2018 3:19 pm

Hi,

I recently uninstalled the latest version 4.1.20.1864 because I had a slow response while tagging artworks so I went back to 4.1.19.1859.

I didn't modify the script in any way, However, I compared it with the SwapArtistTitles.vbs which work flawlessly and they look similar to me.
I've also checked the Script.ini for inconsistency but I couldn't find any, again my Scripting knowledge is very limited and maybe I'm looking in the wrong direction.
I've read somewhere regard another script, that it can cause a conflict with other scripts? I don't know, I'm clueless. :(
Your help is highly appreciated. Thanks.

Peke
Posts: 11279
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Script Error

Post by Peke » Wed Feb 14, 2018 4:16 pm

Make sure you have Internet Explorer 8 (it should install vbscript 5.8 along) or at least VBScript 5.7 installed.
Best regards,
Pavle
MediaMonkey lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

JulianX

Re: Script Error

Post by JulianX » Thu Feb 15, 2018 1:02 am

Just last month I've installed IE8. Can I download a standalone vbs5.8 and install it manually?
The thing is that all the other scripts are working flawlessly. that is what's driving me crazy :cry:

Is there should be a certain order for this script in the Script.ini or what really counts is the order value?
What about duplicate installations, I have MM 4.0.7.1511(the best build for my system, so I keep it) in the same location? can that cause a conflict?
Thank you.

Peke
Posts: 11279
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Script Error

Post by Peke » Thu Feb 15, 2018 9:08 am

You should at least try MMW 4.1 as portable which will not interfere with your regular version.

I'm not sure but 5.8 come with IE8 on XP and if not you can download 5.7 from https://www.microsoft.com/en-us/downloa ... px?id=8247
Best regards,
Pavle
MediaMonkey lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

Post Reply