Sync problems

Report bugs & feature requests for MediaMonkey for Android and learn about the newest beta build.

Moderator: Gurus

hintergrundrauschen
Posts: 180
Joined: Sat Mar 29, 2008 6:20 pm

Sync problems

Post by hintergrundrauschen » Sun Dec 08, 2013 1:05 pm

Running the latest build 189 I got enerving sync errors. Before updating/syncing, I had quite some albums sorted automatically and correctly into the "Albums" or "Audiobooks" sections, correspondingly. After updating to build 189 (and probably syncing, I don't know for sure) all audiobooks were displayed in the Albums category and the album art was lost for the majority of albums/tracks. Syncing again (to get the problem solved...) I now have most (though not all) albums twice on my Android device, and one of the (five) audiobooks is displayed once in Albums and once in Audiobooks.

Running on Galaxy SIII, Android 4.3.1, CM 10.2 final, MMW 1672 (no change in MMW since last MMA update).

log ID xzx85wsxhe
Claude

hintergrundrauschen
Posts: 180
Joined: Sat Mar 29, 2008 6:20 pm

Re: Sync problems

Post by hintergrundrauschen » Sun Dec 08, 2013 4:00 pm

I just noticed that most albums/tracks are not stored twice, the albums are ripped apart in tracks that say "Various Artists" as album artist and those that display a specific artist as album artist. This is an error, the songs in question as stored and displayed in MMW all have "Various Artists" as album artist.

The audiobook that is displayed in "Albums" AND "Audiobooks" is in fact doubled, having the same album artist in both cases (actually, 1x with 30 tracks and 1x with 26 tracks).
Claude

rusty
Posts: 7183
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: Sync problems

Post by rusty » Wed Dec 11, 2013 12:44 pm

Hi,

It sounds as if at some point during the transition to build 189, your mma database was deleted (that would account for the loss of the Collection information), and upon rescanning MM failed to match up the existing tracks to those already in the Libary ( http://www.ventismedia.com/mantis/view.php?id=11552 ) which should be fixed in the next build.

Is it possible that you uninstalled MMA prior to upgrading?

-Rusty

hintergrundrauschen
Posts: 180
Joined: Sat Mar 29, 2008 6:20 pm

Re: Sync problems

Post by hintergrundrauschen » Fri Dec 13, 2013 5:37 pm

rusty wrote: Is it possible that you uninstalled MMA prior to upgrading?
No. I frequently updated Android (CM nightlies update, no wipe), but they have been extremely stable and reliable to me in that regard.
Claude

rusty
Posts: 7183
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: Sync problems

Post by rusty » Wed Dec 18, 2013 3:05 am

Hi Claude,

How's build MMA 202 / MMW 1681 working for you re. sync? There were a lot of changes in both MMA and MMW.

-Rusty

hintergrundrauschen
Posts: 180
Joined: Sat Mar 29, 2008 6:20 pm

Re: Sync problems

Post by hintergrundrauschen » Wed Dec 18, 2013 2:09 pm

rusty wrote:How's build MMA 202 / MMW 1681 working for you re. sync? There were a lot of changes in both MMA and MMW.
Fine so far, though I am puzzled. Using a file explorer on Android, I deleted all music files. Then I started MMA 202, unchecked sync folder / closed / re-scanned local folders / re-checked sync folder, then synced. Outcome: the audiobooks section was fine (all audiobooks displayed well), but the music section had the same old problem with split-up multi-artist albums, some audiobooks showing and a few missing album art. So I thought: damn, mma database wasn't rebuilt by the above procedure.

Booting the device the next day everything was fine. I'm serious.

Now running 203, I'll let you know if anything happens.
Claude

hintergrundrauschen
Posts: 180
Joined: Sat Mar 29, 2008 6:20 pm

Re: Sync problems

Post by hintergrundrauschen » Sat Dec 21, 2013 1:15 pm

Running the latest beta (MMA, MMW) and adding one new album to my sync playlist on MMW, MMA first said "matching new files" (for all tracks), asked to delete one (unchanged) track (?) and now downloads all songs, again, to my Android device :(

At least everything is displayed correctly.

Syncing the second and following times, everything is fine (no more downloading).
Claude

rusty
Posts: 7183
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: Sync problems

Post by rusty » Sun Dec 22, 2013 4:20 am

Hi Claude,

The 'Matching' was added to fix a deficiency that if the device database was deleted at some point, then MMA would know that it's tracks were in sync with MMW, but it would know any metadata that is stored only in the DB (e.g. ratings). It should only be done whenever there are new tracks on the device that haven't been associated with their equivalents in the library.

As to why it re-downloaded all tracks, I'm not sure--normally once tracks are matched, they shouldn't be redownloaded, and I haven't been able to replicate that.

Thanks for the feedback--let us know if tthere's anything else..

-Rusty

Post Reply