Page 1 of 2

Wifi sync worked for a few days, and now nothing

Posted: Thu Dec 12, 2013 10:32 pm
by BenRad
I've just returned to the MM for Android fold after months of staying away, waiting for it to work out any bugs. I was surprised to fined that it started syncing right away and I was very happy. Then for no apparent reason, after syncing over the wifi for several days, it stopped working. Whenever I initiate a sync, it spins and spins (Connecting...) and then Connection Failed. MM is running on my PC and I've confirmed that the Library service is running. I noticed in the media library settings that the last time anything was allowed to connect to the server/MM was about 3 days ago.
What shall I do?

I am running Windows 8.1, and version 1672 of MM.
My phone is a HTC Rezound with Cyanogenmod 10.2 and I have MMA version 0189.

Thanks.

Re: Wifi sync worked for a few days, and now nothing

Posted: Fri Dec 13, 2013 10:21 am
by Lowlander
Try UPnP on MMA to see if you can see and connect to the MMW server. If you can't make sure that you're on the same network (not like a guest network) and that the security software (firewall) on your PC is still letting MMW through.

Re: Wifi sync worked for a few days, and now nothing

Posted: Fri Dec 13, 2013 10:06 pm
by BenRad
After moving up to the latest version from today, I was able to sync again. However, now MMA is not paying attention to my playlists. I've modified several lists, and it's not downloading any new music. It has also doubled up a couple records.

Re: Wifi sync worked for a few days, and now nothing

Posted: Fri Dec 13, 2013 10:31 pm
by Lowlander
Make sure you only have only 1 Device Profile for each memory in MMW (Tools > Options > Portable Device Sync).

Re: Wifi sync worked for a few days, and now nothing

Posted: Sat Dec 14, 2013 9:32 am
by BenRad
Yes, I checked that. The only profile I have active is for the external card, "Android Phone".

Re: Wifi sync worked for a few days, and now nothing

Posted: Sat Dec 14, 2013 12:53 pm
by Lowlander
As both MMA and MMW have been updated since I suggest you start by updating both to the latest.

Re: Wifi sync worked for a few days, and now nothing

Posted: Sat Dec 14, 2013 8:23 pm
by BenRad
Everything is up to date, and now I can no longer see the MMW server on the network (which I realize makes no sense).

Couple of things:

I'm starting to wonder if this might be a UPnP issue and not just a syncing issue. I was able to play music from my phone using BubbleUPnP streaming from MMW this morning, then MMA synched. After updating MMA, I could no longer sync.

I have two entries under Media Sharing and Wifi Sync, MM Server and MM Library, is that correct?

I set up port forwarding on my router, just for fun, to see if that would fix it, but it doesn't seem to make a difference.

Where are the logs for the server stored?

Re: Wifi sync worked for a few days, and now nothing

Posted: Sat Dec 14, 2013 8:32 pm
by BenRad
Bah. I just went and successfully streamed to my PS3 from MMW, so I guess that's not it.

Re: Wifi sync worked for a few days, and now nothing

Posted: Sat Dec 14, 2013 8:36 pm
by BenRad
I may have figured this out, but I haven't confirmed yet. I have two WAPs in my house, both connected to the same switch, but with different SSIDs. I may need to set up some port forwarding on the second AP, because when I connected to the other AP, syncing was successful.

Meanwhile, I'll just keep blathering on in this thread as I figure things out. :lol:

Re: Wifi sync worked for a few days, and now nothing

Posted: Sun Dec 15, 2013 12:29 pm
by Lowlander
The key is that both the client and the server are on the same network, as otherwise DLNA won't work. Besides that make sure ports used aren't blocked.

Re: Wifi sync worked for a few days, and now nothing

Posted: Wed Dec 18, 2013 11:50 am
by bkenobi69
FWIW, I have had a similar issue where for some reason MMA refuses to find MMW via WiFi. The solution I have come up with is to close MMW and restart it and to reboot the phone. I don't know which is the fix, but it always works.

Re: Wifi sync worked for a few days, and now nothing

Posted: Sat Jan 18, 2014 11:54 am
by BenRad
Lowlander wrote:The key is that both the client and the server are on the same network, as otherwise DLNA won't work. Besides that make sure ports used aren't blocked.
Obviously, they're on the same network, just different WAPs. I'm still having spotty luck with syncing, but I will soldier on.

Re: Wifi sync worked for a few days, and now nothing

Posted: Wed Jan 22, 2014 2:38 pm
by rusty
BenRad,

A couple of questions; Once MMA is failing to sync:
- can MMA connect to the MMW UPnP server?
- can Bubble UPnP connect to the MMW UPnP server? (I know that you wrote that you successfully streamed to your PS3 from MMW, but it's unclear whether that was at the same time as MMA was unable to connect to MMW UPnP)
- does restarting the device affect either of the above?

Also, you wrote that there are 2 servers in MMW: MM Server, and MM Library. Can you confirm which of those is used by your device's profile (i.e. in the device profile's home page there is a config "[x] Grant remote sync / access rights to the <MediaServerName>" -- what is the MediaServerName ? If you delete/disable the other Media Server, are the results any different?

Thanks.

-Rusty

Re: Wifi sync worked for a few days, and now nothing

Posted: Wed Jan 22, 2014 8:22 pm
by Peke
BenRad wrote:Obviously, they're on the same network, just different WAPs. I'm still having spotty luck with syncing, but I will soldier on.
Ok here is the basic Issue. Looks like your APs are both acting like separate DHCP Servers on devices that were connected to it. You would need to dedicate IP space for Wired and Wireless. I use 192.168.0.x for wired adn 192.168.1.x for wireless, my NAS is serving as DHCP Server (in all APs DHCP is set to bridged/relay mode pointing to NAS IP). That would assure all devices are in same network.

NOTE: Subnet mask in my case is 255.255.254.0

Hint: Try using ES file explorer to access different shared folder(s) on MMW PC

Hint2: I always use Static IP for NAS and LAN Connected PCs.

EDIT: To make things easier here is some URLs that can help you in network Administration ad settings http://www.subnet-calculator.com/

Re: Wifi sync worked for a few days, and now nothing

Posted: Fri Apr 11, 2014 11:36 am
by imusicman
Older thread but topic is right. I'm on latest versions of both mma and mmw as of 4/11/2014 at 9:30 mountain time. Seems like with all versions since a very early one, though, sync works only the first time after an installation of a new mma version. then it never works again. today, i did discover that at least part of the problem was that i don't normally start the wireless network adapter on my desktop machine, just connect to the wired network. both my wireless and wired networks have the same network name and share the same tcp/ip address space. Once I connected to the same network using the wireless adapter on my pc, then mma was able to see both the mmw server and library.

Shouldn't it work as long as it's on the same network, even if the mmw pc itself is connected via a wire? maybe this isn't a bug but a feature request.

Thanks and keep up the good work. (I bought mmw gold at least 5 years ago, so I know I've got my money back already. i did upgrade to mma pro :D )