BUG - Equalizer works for one song and turns off [#12462]

Report bugs & feature requests for MediaMonkey for Android and learn about the newest beta build.

Moderator: Gurus

Dennis
Posts: 22
Joined: Tue Apr 10, 2007 7:23 am
Location: Rotterdam, The Netherlands

Re: BUG - Equalizer works for one song and turns off [#12462

Post by Dennis » Mon Jan 19, 2015 8:40 am

I have the same problem with build 363. Didn't noticed it before.

rusty
Posts: 7131
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: BUG - Equalizer works for one song and turns off [#12462

Post by rusty » Mon Jan 19, 2015 3:58 pm

Thanks for the feedback. I've re-opened the bug.

If anyone is able to, please submit a debug log and post the log ID to this thread as soon as this bug occurs.

Thanks.

-Rusty

Dennis
Posts: 22
Joined: Tue Apr 10, 2007 7:23 am
Location: Rotterdam, The Netherlands

Re: BUG - Equalizer works for one song and turns off [#12462

Post by Dennis » Tue Jan 20, 2015 3:02 pm

I submitted a debug log with log ID: HG5JLBAF8H

I hope it's useful. Good luck!

rusty
Posts: 7131
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: BUG - Equalizer works for one song and turns off [#12462

Post by rusty » Wed Jan 21, 2015 10:59 am

Thank you!

creativconfusion
Posts: 123
Joined: Tue Dec 18, 2012 9:49 pm

Re: BUG - Equalizer works for one song and turns off [#12462

Post by creativconfusion » Wed Jan 28, 2015 3:48 pm

I am now on 385.
The equalizer is still broken.

I submitted Log ID: 5YSXLECDUW

rusty
Posts: 7131
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: BUG - Equalizer works for one song and turns off [#12462

Post by rusty » Mon Feb 02, 2015 4:25 pm

Thanks. We'll check into it.

-Rusty

martin.bohac
Posts: 99
Joined: Thu Nov 14, 2013 5:23 pm

Re: BUG - Equalizer works for one song and turns off [#12462

Post by martin.bohac » Mon Feb 09, 2015 9:21 am

Unfortunately I can't replicate it. Can you be more specific.
1) Does it occurs everytime after next song starts?
2) Must be previous song completed or it happens also on press next button?
3) Can you hear it, that equalizer doesn't work or just Equazlier UI doesn't respond on changes?
4) Is it related to some song or it doesn't matter?

Thanks.

creativconfusion
Posts: 123
Joined: Tue Dec 18, 2012 9:49 pm

Re: BUG - Equalizer works for one song and turns off [#12462

Post by creativconfusion » Wed Feb 11, 2015 9:31 am

Responses to your questions below:

1) Yes, it happens every single time a new song plays, regardless of whether it has progressed to the new song naturally or whether the skip button was pressed.

2) No, the previous song does not have to be completed. The new song just has to start.

3) There is no change to the UI, all checkboxes and sliders stay exactly the same, however, audibly it is easily identified that the equalizer is no longer working on the new song. Clearly MMA still thinks the equalizer is active, but whatever process actually implements the equalizer effect is reset when a new song plays.

4) It happens on every single song, it has nothing to do with the song. This problem is 100% replicated every single time.

rusty
Posts: 7131
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: BUG - Equalizer works for one song and turns off [#12462

Post by rusty » Wed Feb 11, 2015 10:37 am

I've tested this on: Samsung tablet / 4.4.2, Nexus 5 / 4.4.2, XPeria Pro / 4.1, Nexus 5 / 5.0.2 and couldn't replicate :-(

But I did notice a possibly related issue on the Xperia Pro (and only on that device): if the Equalizer is enabled, then rapidly disabling and re-enabling it sometimes results in the Equalizer displaying Status=enabled, even though the equalizer isn't enabled. Does that problem occur for you as well?

btw, what device are you using?

Thanks.

-Rusty

creativconfusion
Posts: 123
Joined: Tue Dec 18, 2012 9:49 pm

Re: BUG - Equalizer works for one song and turns off [#12462

Post by creativconfusion » Thu Feb 12, 2015 2:13 pm

I am using an HTC M8 Verizon.

The only thing I can think of is that the stock Android equalizer is broken/disabled on this phone by HTC. I think in order for them to implement their garbage "BoomSound" they had to wreck the stock equalizer. The phone did not come with an equalizer program, nor is it an option in the stock music player.

I have tried all of the Playstore 5-Band equalizers and none of them work, I think all of those just pass commands to the stock Android equalizer, but because its busted on the M8 nothing works.

I have tried PlayerPro DSP and Poweramp, and both of those are high-end 10-Band equalizers with fully developed independent code which does not rely on the stock Android equalizer. Both of those work extremely well with no problems whatsoever.

If MediaMonkey Android is only passing commands to the stock Android equalizer, then I think the problem is clear, and there is no way in hell it is ever going to work.

When are you guys going to implement your independently coded 10-band equalizer and crossfade anyway? If you do that, this whole problem goes away.

rusty
Posts: 7131
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: BUG - Equalizer works for one song and turns off [#12462

Post by rusty » Thu Feb 12, 2015 2:53 pm

I have tried all of the Playstore 5-Band equalizers and none of them work, I think all of those just pass commands to the stock Android equalizer, but because its busted on the M8 nothing works.
That explains things. MMA currently relies on Android's equalizer API. An in-app equalizer is on our todo list (tentatively planned for v1.1.1). See:
http://www.ventismedia.com/mantis/view.php?id=11907

-Rusty

Tim313

Re: BUG - Equalizer works for one song and turns off [#12462

Post by Tim313 » Tue Mar 31, 2015 11:43 am

Wow! I have the exact same problem with my HTC One M* (for AT&T).

I surely do hope that someone can help us so that we don't continue to have the Equalizer fail with every new song.

What I do presently, which is not a solution, but makes the equalizer work. Through the equalizer on Terra Music App. I go to the Equalizer every time a song starts, and click on the Midrange slider (my choice) and move it a bit forward and then back. Then the equalizer works for that that song. This has to be done for each song after it begins.

When the equalizer works sound is great. Get this fixed and I will absolutely love listening to my music on this overall great phone.

shockwave5280
Posts: 1
Joined: Mon Apr 06, 2015 11:33 am

Re: BUG - Equalizer works for one song and turns off [#12462

Post by shockwave5280 » Mon Apr 06, 2015 11:44 am

I'm also using an HTC One M8 on ATT; pro version 1.1.1.0412

If I skip to the next song, the EQ goes away. However if I just let it play through on to the next song the EQ will stay active.

I sent in a log: S1MOLUQSS8

marc bleuwart

Re: BUG - Equalizer works for one song and turns off [#12462

Post by marc bleuwart » Tue May 19, 2015 3:42 am

Similar issue here on Huawei P7
Equalizer stops working after first song.
Version 1.1.2.0415.

bloomer
Posts: 10
Joined: Fri Jan 01, 2010 5:13 am
Location: Melbourne, Australia

Re: BUG - Equalizer works for one song and turns off [#12462

Post by bloomer » Fri Dec 08, 2017 2:08 am

So this bug still exists a few years later?
Samsung Galaxy Tab 2 (SM-T713)
Android 7.0
MM: 1.3.1.0742

VLC's equaliser functions ok on the same device.

Post Reply