Horrible performance under Oreo [#14845]

Report bugs & feature requests for MediaMonkey for Android and learn about the newest beta build.

Moderator: Gurus

MaximusPrime
Posts: 403
Joined: Tue Aug 14, 2012 1:31 am

Horrible performance under Oreo [#14845]

Post by MaximusPrime » Mon May 28, 2018 7:59 am

Since my HTC U Ultra got updated to Oreo, it's nearly impossible to listen to music with MMA.
First I thought this was an Android problem because the performance of the smartphone wasn't the best after updating. But I've tested other media players and no one crashes.
MMA crashes and freezes after listening to a couple of songs.
Been uploading Debug logs automatically.
Please help, I don't want to use the google play music app any longer :D

Peke
Posts: 11766
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Horrible performance under Oreo

Post by Peke » Tue May 29, 2018 5:52 am

Hi,
Can you please when MMA crash start it again and manually send us Debug logs from ... -> About MediaMonkey -> Send Logs and write down here the log ID that we can pair it with this report?
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

MaximusPrime
Posts: 403
Joined: Tue Aug 14, 2012 1:31 am

Re: Horrible performance under Oreo

Post by MaximusPrime » Tue May 29, 2018 1:10 pm

Hi,


Log ID is: PXS1AJQ6L2

Peke
Posts: 11766
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Horrible performance under Oreo [#14845]

Post by Peke » Tue May 29, 2018 7:52 pm

Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

MaximusPrime
Posts: 403
Joined: Tue Aug 14, 2012 1:31 am

Re: Horrible performance under Oreo [#14845]

Post by MaximusPrime » Wed May 30, 2018 2:01 pm

Thank You

martin.bohac
Posts: 112
Joined: Thu Nov 14, 2013 5:23 pm

Re: Horrible performance under Oreo [#14845]

Post by martin.bohac » Thu May 31, 2018 12:07 pm

Hi I have tested it on my Oreo device and I am not able to replicate it. I see your crashlogs, the crash is really related to Oreo new features. Some service does not start correctly (maybe PlaybackService, the exception is not clear). Does it occur always during playback? How is playback initiated? Is initiated from widget, app or from an external device like android watch?

MaximusPrime
Posts: 403
Joined: Tue Aug 14, 2012 1:31 am

Re: Horrible performance under Oreo [#14845]

Post by MaximusPrime » Fri Jun 01, 2018 1:43 pm

martin.bohac wrote:
Thu May 31, 2018 12:07 pm
Hi I have tested it on my Oreo device and I am not able to replicate it. I see your crashlogs, the crash is really related to Oreo new features. Some service does not start correctly (maybe PlaybackService, the exception is not clear). Does it occur always during playback? How is playback initiated? Is initiated from widget, app or from an external device like android watch?
Yeah, always, often even only one track was played.
Mostly started from the widget. I will test tomorrow only starting via app if it crashes too.
I even did a complete reset of the phone after updating but that didn't help


EDIT:
Alright, doesn't seem to crash as fast when I start MMA via app and not via Widget but still crashes.
Something I thought about is my HTC U Ultra has this second display with a mini kind of widget for the music player, mma works with this. The second display stops every once in a while when using mma. Maybe this has something to do with the maa perfomance and crash? But I even turned the musicplayer option on the second display off and the whole second display too without any changes. Just wanted to offer this information anyway

martin.bohac
Posts: 112
Joined: Thu Nov 14, 2013 5:23 pm

Re: Horrible performance under Oreo [#14845]

Post by martin.bohac » Wed Jun 27, 2018 8:28 am

Can you confirm the issue is fixed with build 818 (819 will be published these days)?

MaximusPrime
Posts: 403
Joined: Tue Aug 14, 2012 1:31 am

Re: Horrible performance under Oreo [#14845]

Post by MaximusPrime » Mon Jul 09, 2018 10:21 am

martin.bohac wrote:
Wed Jun 27, 2018 8:28 am
Can you confirm the issue is fixed with build 818 (819 will be published these days)?
Tested it some days, unfortunatelly not fixed for me.

Sorry for my late response, I was on holidays

martin.bohac
Posts: 112
Joined: Thu Nov 14, 2013 5:23 pm

Re: Horrible performance under Oreo [#14845]

Post by martin.bohac » Tue Jul 10, 2018 7:40 am

I can't see any LOG from your device "HTC U Ultra", please send new LOG when the issue occurs.

MaximusPrime
Posts: 403
Joined: Tue Aug 14, 2012 1:31 am

Re: Horrible performance under Oreo [#14845]

Post by MaximusPrime » Tue Jul 24, 2018 11:52 am

martin.bohac wrote:
Tue Jul 10, 2018 7:40 am
I can't see any LOG from your device "HTC U Ultra", please send new LOG when the issue occurs.
Hi. Been very busy the last couple of weeks so there arent so many logs from me. Just send one a couple minutes ago. I really think the second display is somehow responsible for the crashs

bateye23
Posts: 8
Joined: Fri Jul 06, 2018 4:33 am

Re: Horrible performance under Oreo [#14845]

Post by bateye23 » Wed Jul 25, 2018 2:41 pm

That's weird I have oreo os too but it's not crashing are you using the latest version of mm?

MaximusPrime
Posts: 403
Joined: Tue Aug 14, 2012 1:31 am

Re: Horrible performance under Oreo [#14845]

Post by MaximusPrime » Fri Jul 27, 2018 3:07 am

bateye23 wrote:
Wed Jul 25, 2018 2:41 pm
That's weird I have oreo os too but it's not crashing are you using the latest version of mm?
Yes. The thing is, the whole phone becomes slow when MMA is running and after time, sometimes just 2 minutes, other times after an half hour, media monkey crashes and the whole phone freezes for couple seconds. Because I initially thought it's because of the music plaayer shortcuts at the second display I've tested a lot music app but only mma forces the crash.

Peke
Posts: 11766
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Horrible performance under Oreo [#14845]

Post by Peke » Fri Jul 27, 2018 4:57 pm

Hi,
I have the oposite issue where MMA is running in background for 4 days without crash. Send us debug log after crash and restart and write down Log ID here so that we track it for analyze.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

martin.bohac
Posts: 112
Joined: Thu Nov 14, 2013 5:23 pm

Re: Horrible performance under Oreo [#14845]

Post by martin.bohac » Fri Jul 27, 2018 5:24 pm

I have already some his debug logs from build 822. I have analyzed these logs and it seems to be a memory issue. In your logs, I can see many TRIM_MEMORY_RUNNING_CRITICAL, so MMA is killed by OS and crash log is not sent. I have never met with this issue on my devices, but I will check MMA with Memory Profiler and let you know.

Post Reply