Songs not showing up after scanning

Get answers about the current release of MediaMonkey for Android

Moderator: Gurus

Songs not showing up after scanning

Postby WallyWest » Thu Oct 19, 2017 12:25 am

First problem was that MMA would just give up on scanning after a while. Long before it found all the albums. So I kept making it scan again, and it would find some more. And so on.

Then I noticed a few missing albums, and one that was tagged incorrectly making each song show up individually under the artist - album artist view. The missing stuff turned out to be tagging issues as well.

So I fixed the tags, hit rescan, nothing. It thinks about it, but nothing in the list changes. The missing albums are still missing, the random songs still showing up as albums. The original files that caused this issue are gone, replaced with the fixed files, I confirmed this several times. At this point scanning does not seem to be doing anything.

This is on a Moto G5+ if it matters. Files are on a SD card, and the music folder is the only entry under the library settings. I do not currently have sync setup, I manually copied the files onto the SD card.
WallyWest
 
Posts: 6
Joined: Mon May 28, 2012 8:19 pm

Re: Songs not showing up after scanning

Postby Lowlander » Thu Oct 19, 2017 12:51 pm

Which program fixed the tags and how did you copy the fixed files? Did the Timestamp/Date Modified change for the fixed files?
Lowlander (MediaMonkey user since 2003)
Lowlander
 
Posts: 43410
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Songs not showing up after scanning

Postby WallyWest » Fri Oct 20, 2017 12:14 am

At first I plugged the phone into my PC and just browsed to the virtual drive it creates. I used MediaMonkey on the PC to try and edit the file tags that way, but it didn't work. It wouldn't let me enter any info, was read only I suppose.

So then I moved the files to the PC, used MediaMonkey to tag them correctly, and moved them back. Just checked and the modified time/date on the files is from last night, so yeah, that did change. Rescanned with MMA on the phone and nothing new showed up.

Today I also tried editing the tags through MMA on the phone. I was able to do that for the songs that were showing up just not in the right album. Got those fixed, but I can't see the missing album at all. I used the file browser in MMA to open the music directory, and I could see the album directory there. Editing the files didn't work though, I could see that the tag appeared to be empty but it wouldn't let me enter any info into it.

Oh, and the same files on my PC show up just fine in MediaMonkey. I can browse to them, edit the tags, and they show up in the album - album artist view.
WallyWest
 
Posts: 6
Joined: Mon May 28, 2012 8:19 pm

Re: Songs not showing up after scanning

Postby WallyWest » Sat Oct 21, 2017 12:04 am

So today I downloaded a different media player on my phone. One of the top rated ones, named Pi.

It has the same issue, except that it shows 7 albums in the artist view as <unknown>. Opening that "artist" shows the album names, but no songs are in any of them. Some of them have artwork, others don't.

From what I understand these players get the info from the tags and use that to organize the files. So how can it have the album names, which came from the tags, but no files (songs) in the album? I assumed that it was reporting them as <unknown> because the artist info wasn't in the tag, but it is. I checked them all. Doesn't make any sense to me how it can pull some info from the tag but then claim not to see any songs in the album, and not know what the artist entry says.

I also have an album that shows up twice, with a slightly different spelling. There is only one copy of the album in the folder, and I can't find anything in the tag that explains where the alternate spelling came from. Both of the albums have all the tracks listed in them, so it's not like a few tracks got tagged with the wrong spelling or something. This issue exists in both MMA and Pi.

I believe it's a tag issue, I just can't see anything in the tags that explain it. They all look fine.
WallyWest
 
Posts: 6
Joined: Mon May 28, 2012 8:19 pm

Re: Songs not showing up after scanning

Postby WallyWest » Sat Oct 21, 2017 12:21 am

Random question. Do these media players pull info about the songs/albums/artists from anywhere other than the tags?

Like, do the file and/or folder names matter? I have all the albums in their own folder. Named "Artist - Album". The file names are "Track number - track name". The tags I just enter the track number, track name, artist, album artist (usually the same thing), and genre.

Is that ok, or am I doing something that screws up the players?
WallyWest
 
Posts: 6
Joined: Mon May 28, 2012 8:19 pm

Re: Songs not showing up after scanning

Postby Peke » Sat Oct 21, 2017 6:08 pm

Hi,
Unfortunately many players rely on Android Music scanner to fill the tag info (MMA 2.0 will have of tag reader) and it is known to have many limitations and bugs.

Issues you are describing fall under that category and that is why Syncing from MMW -> MMA is recommended as MMW fill correct Tag info to MMA Library and user experience is much more enjoyable. Unfortunately that do not fix same issue in other players.

[EDIT: more on this at: https://www.mediamonkey.com/support/ind ... is-missing ]
Best regards,
Pavle
MM Core Developer and Admin of free MediaMonkey extensions Hosting
Image
Image
Peke
 
Posts: 10441
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia


Return to Need help (mma)

Who is online

Users browsing this forum: No registered users and 4 guests