Issues with Collections/Tree Nodes/Views

Report bugs & feature requests for MediaMonkey 5 and learn about the newest builds.

Moderator: Gurus

Peke
Posts: 12471
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Issues with Collections/Tree Nodes/Views

Post by Peke » Wed May 30, 2018 5:21 am

If I got you correctly, are you saying that subnodes like Genre show unfiltered collection files with all other files with different path?
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum

Davo
Posts: 296
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Issues with Collections/Tree Nodes/Views

Post by Davo » Wed May 30, 2018 6:42 am

Peke
Sorry about this, but i see most of the sub node issues are caused by my own classifications & not because of MM. eg I have many compilation albums which have many different genres but i save the album naturally to only one Collection & of course a number of the genres don't belong in that Collection. I need to think about this and sort it out myself.
David
____________________________
Windows 10
MM 5 Beta

Davo
Posts: 296
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Issues with Collections/Tree Nodes/Views

Post by Davo » Thu May 31, 2018 7:54 pm

Issue - Collections - Album sub node displays all albums from a prior & different Collection.
David
____________________________
Windows 10
MM 5 Beta

Ludek
Posts: 3038
Joined: Fri Mar 09, 2007 9:00 am

Re: Issues with Collections/Tree Nodes/Views

Post by Ludek » Fri Jun 01, 2018 2:05 am

Davo wrote:
Thu May 31, 2018 7:54 pm
Issue - Collections - Album sub node displays all albums from a prior & different Collection.
I cannot replicate, I have 1033 albums in my library and I marked 3 albums as Classical Music albums, only those 3 albums are shown under Classical Music collection as expected:
https://www.dropbox.com/s/cl8e79yvmrf29 ... 3.png?dl=0

Probably sharing your MM.DB and exact description of the issue could help us to replicate.

Davo
Posts: 296
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Issues with Collections/Tree Nodes/Views

Post by Davo » Fri Jun 01, 2018 2:34 am

Ok - here is the sequence
From the Media Tree
1. select a Collection (say Classical Music)
2. select sub node 'Album'
3. Classical albums display correctly
4. Select Collection (Classical) to contract the tree
5. Select a new Collection (say Jazz)
6. select sub node 'Album'
7. Classical albums previously displayed at 3 display (incorrect)
David
____________________________
Windows 10
MM 5 Beta

Ludek
Posts: 3038
Joined: Fri Mar 09, 2007 9:00 am

Re: Issues with Collections/Tree Nodes/Views

Post by Ludek » Fri Jun 01, 2018 4:46 am

I still cannot replicate, could you please elaborate what exactly are you doing in the step 6) select sub node 'Album' ??
Thx.

Davo
Posts: 296
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Issues with Collections/Tree Nodes/Views

Post by Davo » Fri Jun 01, 2018 5:19 am

Step 6 is the same as Step 2 ie expanding the sub node to display all the albums that are associated with the Collection
David
____________________________
Windows 10
MM 5 Beta

Davo
Posts: 296
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Issues with Collections/Tree Nodes/Views

Post by Davo » Sat Jun 02, 2018 5:11 pm

Same thing happens with other other sub - nodes, eg Artist, Composer, Conductor.
I can replicate the issue 100%
David
____________________________
Windows 10
MM 5 Beta

Davo
Posts: 296
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Issues with Collections/Tree Nodes/Views

Post by Davo » Sat Jun 02, 2018 5:30 pm

More testing on this reveals - The browser & Views show the correct info but the Media Tree does not.
David
____________________________
Windows 10
MM 5 Beta

Ludek
Posts: 3038
Joined: Fri Mar 09, 2007 9:00 am

Re: Issues with Collections/Tree Nodes/Views

Post by Ludek » Tue Jun 05, 2018 2:52 pm

Davo wrote:
Sat Jun 02, 2018 5:30 pm
More testing on this reveals - The browser & Views show the correct info but the Media Tree does not.
Ahh, I see, that's the difference, I haven't expanded the media tree nodes, but was looking just at the view nodes, thanks.

Ludek
Posts: 3038
Joined: Fri Mar 09, 2007 9:00 am

Re: Issues with Collections/Tree Nodes/Views

Post by Ludek » Fri Jun 08, 2018 4:46 am

It is fixed in 2111

Davo
Posts: 296
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Issues with Collections/Tree Nodes/Views

Post by Davo » Fri Aug 03, 2018 8:06 pm

Re: Issues with Collections/Tree Nodes/Views
Post by Ludek » Fri Jun 08, 2018 8:46 pm

It is fixed in 2111
Same problem in the latest release 2116
David
____________________________
Windows 10
MM 5 Beta

Ludek
Posts: 3038
Joined: Fri Mar 09, 2007 9:00 am

Re: Issues with Collections/Tree Nodes/Views

Post by Ludek » Mon Aug 06, 2018 3:51 am

Hi, I am no longer seeing the issue after the fix in 2011,
could you please catch this in a video (e.g. using ScreenCast) or add some screengraps to see how exactly to replicate the issue? Maybe I am still doing a little bit different steps than yours?

Davo
Posts: 296
Joined: Tue Nov 06, 2007 9:00 pm
Location: Australia

Re: Issues with Collections/Tree Nodes/Views

Post by Davo » Mon Aug 06, 2018 7:50 pm

Ludek. The steps are the same as the ones I set out previously.starting from my post on the 1St June & The problem is exactly the same. Perhaps there is a regression issue in 2116.
If I really need to do screen captures it will have to be later in the week
David
David
____________________________
Windows 10
MM 5 Beta

Barry4679
Posts: 812
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: Issues with Collections/Tree Nodes/Views

Post by Barry4679 » Mon Aug 06, 2018 8:45 pm

Hi David,

I tried your steps out of curiosity. I cannot replicate your issue either in 2116.

You mentioned a Jazz node. This is a custom collection that you have designed? Could you post the collection criteria options, as that may help.

Post Reply