Question Mark for Drive in Song Path

Report bugs & feature requests for MediaMonkey 5 and learn about the newest builds.

Moderator: Gurus

malkierian
Posts: 108
Joined: Wed May 10, 2017 1:38 pm

Question Mark for Drive in Song Path

Post by malkierian » Thu May 24, 2018 2:26 am

So, I don't really know when or why this happened, but I recently discovered that the paths for every song in my collection had had their drive letter replaced with a question mark. My currently playing playlist still had the appropriate data, and was playing everything just fine, but whether viewed through playlists or through the media browser (Artists, Songs, etc), every single song has a question mark now. Rescanning the folder didn't do a darn thing to it, and neither did adding another folder, moving all of my music to that folder, and then rescanning again. And, upon moving the files to another folder and rescanning, MM seems unable to remove the old items that are unavailable because of the path corruption.

I have all of those songs in there now, but I have duplicate listings of almost all of them (ones with the proper new path, and ones with the old, corrupted path with the question mark). And, since it's not removing the unavailable ones anymore (yes, I went to the options and made sure that was checked), it's not updating the paths for the tracks in my playlists either, so when I moved the files back, the playlist I saved of the Now Playing works fine again.

And on top of all that, I'm guessing since it was unable to find the files with corrupted paths, the option for "analyze for duplicates" was unsuccessful as well, and I still have sometimes 4 instances of the same file in my library. And, when manually removing said files with corrupted paths from the library, obviously instead of updating the playlists with the new files, it simply deleted all of the tracks from the playlists and I was left with blank playlists.

Long story short, manual editing of the database as a well-hidden advanced feature would be EXTREMELY useful (this was like the 5th time in the last month I wished I could edit the database directly).

Peke
Posts: 11342
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Question Mark for Drive in Song Path

Post by Peke » Thu May 24, 2018 4:19 am

Hi,
Your files got moved from MMW library location at time of scan and [?] means that Partition where files reside is not available anymore.

You got duplicates as you scanned new location in Library and MMW added them as new files. There is two ways to handle this:
a) If you do not have playlists and statistics tied to old files/path simply remove from library Locations that do not have assigned drive letter

b) Remove newly added tracks and use File -> Locate moved/Missing tracks option on all tracks that have [?]: and point to new location which should fix your [?]: and relocate/pair them on new location
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add Images to forum

malkierian
Posts: 108
Joined: Wed May 10, 2017 1:38 pm

Re: Question Mark for Drive in Song Path

Post by malkierian » Thu May 24, 2018 1:43 pm

As already explained in the OP (though I guess if it was tl;dr you wouldn't have seen it) I already tried removing them from the library directly. However, I tried the Locate Missing Files option just now, and when it was done it brought up the window with nothing in the list for Files Located, and when I tried to click on the second or third tabs (Unmoved Files and Unlocatable Files) it crashed. Also, I didn't see an option to do this scan only on the corrupted path files, if that's what you were implying by your directions. If not, then nothing to worry about there.

Post Reply