2110: the links for Album and Artist in Playing are missing

Report bugs & feature requests for MediaMonkey 5 and learn about the newest builds.

Moderator: Gurus

dtsig
Posts: 2847
Joined: Mon Jan 24, 2011 6:34 pm

2110: the links for Album and Artist in Playing are missing

Post by dtsig » Fri Jun 01, 2018 11:42 pm

the subject says it all .. installed 2110 tonight and just noticed that the artist and album link are missing. the data is there they just aren't links anymore.
Not sure that it is just 2110 to tell the truth as i have been minimizing mm5 a lot and just letting play while I work on other things.
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

malkierian
Posts: 112
Joined: Wed May 10, 2017 1:38 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by malkierian » Sat Jun 02, 2018 12:01 am

I think you're going to need to elaborate on that more, dtsig. Where are these links supposed to be? The Artists and Albums nodes are still there on the Media Tree, and going into Artists and clicking on a picture, I still have the artist name clickable, and I honestly can't think of what else you could be referring to.

dtsig
Posts: 2847
Joined: Mon Jan 24, 2011 6:34 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by dtsig » Sat Jun 02, 2018 12:10 pm

This is in the Playing window below the now playing list. There is Title, Artist, Album, Track No and Lyrics Lookup. Note that the Lookup text is a link .. but Artist and Album have lost their linkness.

This has nothing to do with media tree
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

dtsig
Posts: 2847
Joined: Mon Jan 24, 2011 6:34 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by dtsig » Sat Jun 02, 2018 4:48 pm

I just noticed that a track did have the link showing ... then the next tracks didn't ... odd very much
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

malkierian
Posts: 112
Joined: Wed May 10, 2017 1:38 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by malkierian » Sun Jun 03, 2018 2:03 pm

Very odd indeed. I just went through 200 songs in a 2000 song playlist, and every one of them had proper link for artist, album and lyrics.

dtsig
Posts: 2847
Joined: Mon Jan 24, 2011 6:34 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by dtsig » Sun Jun 03, 2018 2:36 pm

When I loaded MM5 today it showed the links ... then I pressed play and the link went away .. and hasn't been back

In fact I just tried pause .. next track and the highlight shows for a blink until the artwork gets set.

If i change it to Selected the links stay highlighted correctly
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

malkierian
Posts: 112
Joined: Wed May 10, 2017 1:38 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by malkierian » Sun Jun 03, 2018 11:57 pm

Oh, I just had it happen. They show just fine as long as track change doesn't happen. If you double click, it happens. If you have the next track highlighted, and then click the Next button (while playing), they disappear once the track starts playing. If you have any other track highlighted, then click the next button, that highlighted track's info sticks around.

In case there was any confusion, this is in regards to the "Selected" track info under the now playing list.

dtsig
Posts: 2847
Joined: Mon Jan 24, 2011 6:34 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by dtsig » Mon Jun 04, 2018 9:38 am

That is weird as it happens for me consistently under "Playing". It looks like when the song changes the text changes first and it is right with the links .. then the image is written and the text gets refreshed with no links.
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Ludek
Posts: 2523
Joined: Fri Mar 09, 2007 9:00 am

Re: 2110: the links for Album and Artist in Playing are missing

Post by Ludek » Tue Jun 05, 2018 7:29 am

This sounds similar like issue b) here https://www.ventismedia.com/mantis/view ... 844#c50430 , re-opened...

Anyhow, I cannot replicate.
Which A&D layout are you using? "Advanced", "Simple" or "Side by side" ?
Are there any consistent and exact steps to reproduce? Any other relevant things? e.g. some tracks without album/artist values (unknown) and some with album+artist?

EDIT: Maybe I see it now, the key seems to be:
layout: Advanced
mode: Selected
double-click a track
=> track starts playing, but after a while the links changes to standard text that is not clickable, right?

dtsig
Posts: 2847
Joined: Mon Jan 24, 2011 6:34 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by dtsig » Tue Jun 05, 2018 10:05 am

Yes Advanced ... no I am using Playing and I am just clicking Play button. Links are good until then and then disappear each new track. I am simply on All Tracks view also
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

malkierian
Posts: 112
Joined: Wed May 10, 2017 1:38 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by malkierian » Tue Jun 05, 2018 3:12 pm

I don't know how to know or change which A&D layout I'm using, but my info panel is Selected. And yes, double clicking the track makes it go away immediately, but I've some disappear after a long time when I selected a track previous to the Now Playing.

EDIT: Oh, just uncovered another part to it. If I have the currently playing track selected, and hit the next button, the album and artist links also disappear.

dtsig
Posts: 2847
Joined: Mon Jan 24, 2011 6:34 pm

Re: 2110: the links for Album and Artist in Playing are missing

Post by dtsig » Tue Jun 05, 2018 10:16 pm

Just to add to the confusion .. i turned it on just a minute ago and IF i 'next' to the next song in playing list ... it is now working correctly. BUT if i let the song change by itself the links go away ...
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig

Ludek
Posts: 2523
Joined: Fri Mar 09, 2007 9:00 am

Re: 2110: the links for Album and Artist in Playing are missing

Post by Ludek » Wed Jun 06, 2018 3:07 am

Thanks for the info, fixed in 2111 as https://www.ventismedia.com/mantis/view ... 844#c50430

Post Reply