How to configure ipod properly [#15836] [#15704]

Report bugs & feature requests for MediaMonkey 5 and learn about the newest builds.

Moderator: Gurus

Weatherman
Posts: 136
Joined: Sun Nov 19, 2006 11:08 am

How to configure ipod properly [#15836] [#15704]

Post by Weatherman » Fri Jul 19, 2019 5:40 pm

I have an ipod touch which is recognised. I have configured the device to scan at connection and to sync a playlist. The playlist is an auto playlist which contains tracks which have 0 plays. In MM4 I would connect the ipod to MM and it would scan, update the play number on the track in the main library, the auomatic playlist would not include that track anymore, and the track would display the new playcount plus the last-played date. All this happened before I then synced the ipod with the updated playlist, where a fresh selection of tracks would be synced, and any tracks on the ipod which were not on the list were deleted.

Now, I have to sync before the main library track gets updated with the playcount, and although the play number is visible, the date played is not. It remains empty. How do I configure correctly in MM5 so that:
1. When I connect the ipod, it scans and updates the info on my MM library
2. Gives the played number and date last played in MM5
3. So that when I look at the playlist, it is an updated playlist based on the info that is sent from the ipod to MM?
Any help would be appreciated.

Ludek
Posts: 3000
Joined: Fri Mar 09, 2007 9:00 am

Re: MM 5.0.0.2186 - How to configure ipod properly

Post by Ludek » Sun Jul 21, 2019 5:38 am

Now, I have to sync before the main library track gets updated with the playcount, and although the play number is visible, the date played is not. It remains empty
1) There is still the '[x] Auto-sync as soon as the device is connected' checkbox on the Summary page of the iPod profile. Are you saying that it does not auto-sync after connecting with this choice enabled?

2) Maybe you just need to enable the "Last Played" column in the file-listing, or are you saying that the value is empty after updating play info from the iPod back to MM library?

Which iPod model are you testing?

Weatherman
Posts: 136
Joined: Sun Nov 19, 2006 11:08 am

Re: MM 5.0.0.2186 - How to configure ipod properly

Post by Weatherman » Sun Jul 21, 2019 8:41 am

Hi.
Using the most modern "nano" - the little shorter rectangular one, not the previous long rectangle. It is 7th Gen I believe.

I have configured the iPOD Nano to auto sync and to scan when connected. With MM4 what would happen is that it would write the Last Played date and update the played #. It would then sync the ipod with a fresh set of tracks from my playlist and delete old content from the ipod. Easy peasy.

Now, I connect the ipod ("Jim's nano"). First thing that happens is I get a duplicate ipod device appearing ("Jim's nano(1)").
Anyway, I ignore that. I have an auto sync set up whereby I sync 50 tracks that haven't been played recently.
I click "sync". The MM5 machine deletes old content and updates the ipod.
I "safely remove" the device. Play a song. The song hasn't been previously played and on MM5 the played# is 0.
After playing the song, I reconnect ipod to PC. The tracks are scanned. On MM5 my song appears with Played# = 1. But no date appears in the cell "Last Played".
Meanwhile I still have this second mysterious second device "Jim's Nano(1)" appearing.

I even tried uninstalling and reinstalling MM5 and maiing sure all MM references were deleted on the ipod when I opened it under File explorer.

I'm stuck and don't know how to get things working as smoothly as they did under MM4.

Ludek
Posts: 3000
Joined: Fri Mar 09, 2007 9:00 am

Re: MM 5.0.0.2186 - How to configure ipod properly

Post by Ludek » Mon Jul 22, 2019 6:40 am

Hi,
I've just tested with iNano 7th gen and I can confirm that the 'Last Played' is not updated,
to be fixed as https://www.ventismedia.com/mantis/view.php?id=15836

As for the duplication of the iPod profile, I cannot replicate, but sounds like https://www.ventismedia.com/mantis/view.php?id=15704 that has been already fixed in 2180

Could you please generate debug log (item 4b here: https://www.mediamonkey.com/forum/viewt ... 30&t=86643) ?
1) Start DbgView app
2) Start MM5 and wait until the two iPod instances appears
3) Save the output from the DbgView to a file, upload the file to a free file hosting service (DropBox, RapidShare, FileDropper, MediaFire, ...) and share the link to the file with us (e.g. send me private message with the link or share it here)

Thanks!

Weatherman
Posts: 136
Joined: Sun Nov 19, 2006 11:08 am

Re: How to configure ipod properly [#15836]

Post by Weatherman » Mon Jul 22, 2019 10:10 am

Hi Ludec
Have just PM'd you.
Thanks.
Jim

Ludek
Posts: 3000
Joined: Fri Mar 09, 2007 9:00 am

Re: How to configure ipod properly [#15836]

Post by Ludek » Mon Jul 22, 2019 3:02 pm

Hi Jim,
thanks for the log and info submitted.

Both issues will be fixed in the build 2187 as:
https://www.ventismedia.com/mantis/view.php?id=15836
https://www.ventismedia.com/mantis/view.php?id=15704

Weatherman
Posts: 136
Joined: Sun Nov 19, 2006 11:08 am

Re: How to configure ipod properly [#15836] [#15704]

Post by Weatherman » Mon Jul 22, 2019 3:18 pm

Thanks, Ludec

Post Reply