RC2 Auto playlist & CPU issue

Beta Testing for Windows Products and plugins

Moderator: Gurus

Posts: 55
Joined: Sat Jul 09, 2005 7:29 am
Location: Marietta, GA

RC2 Auto playlist & CPU issue

Post by nduke » Thu Nov 15, 2007 5:03 pm

I didn't have this problem in the past Beta & RC versions, but it has brought MM to a screeching halt everytime.

I have an autoplaylist that references another autoplaylist (i.e. one of the criteria for the playlist is "Playlist is ...". I do this as a way to combine multiple playlists.

In the past it would take a second or so to populate the list, but in RC2 the CPU usage jumps to 100% and the memory usage starts to skyrocket. This playlist worked fine in RC1 and the betas, but has been hanging since my first time running RC2. Even right clicking to try and delete the playlist hangs the program.

I've played with a few test autoplaylists, and it doesn't seem to be a problem with smaller playlists, but started freezing when I got up to about 300 songs in the list. The test lists were simple. AutoList1 was all tracks starting with the letter A. AutoList B is all songs in AutoList1 over 240 seconds. Once I found a letter with a few hundred titles, clicking on AutoList2 would freeze MM. This original playlist that started all this typically has about 700 songs once it's populated.

I've tried to get info from the debug log, but once I click on the playlist the log never gets beyond

Code: Select all

[5824] 1628 DB open SQL:  SELECT Playlists.* from Playlists WHERE IDPlaylist=201
I've even left it running for an hour, but it seems to be stuck in a loop. I have made sure that it isn't a circular reference (i.e. one autoplaylist references itself) and I have also cleared the database and started over to make sure it wasn't due to corruption.

I hope I've explained the problem clearly enough. Any thoughts?

Posts: 3088
Joined: Fri Mar 09, 2007 9:00 am

Post by Ludek » Fri Nov 16, 2007 11:44 am

Unfortunatelly I cannot reproduce.

My 'A1' auto-playlist is:
Title, starts with, 'a'

and 'A2' auto-playlist is:
Playlist, is, A1
Track length (seconds), >=, '240'

and A2 shows all the tracks in a second.
Is your configuration the same?
i.e. The same sequence of Property, Condition, Value ?

There is a known regression in RC2, but only for 'Any text field' property, see

Posts: 55
Joined: Sat Jul 09, 2005 7:29 am
Location: Marietta, GA

Post by nduke » Fri Nov 16, 2007 12:21 pm

The Starts With A playlist was just my attempt to try an isolate the problem. I wanted to make an easier example to see if there was something specific to my existing autoplaylists.

Since I posted this I've realized the problem isn't necessarily specific to just my nested autoplaylists. From my experience with RC2 (and from other posts that have been posted to the forum in the last day) it looks like there are a number of situations that can cause the CPU to go and stay at 100%. I'm seeing many posts describing similar results. Most seem to revolve around actions that lead to large numbers of songs in a list.

In the meantime I reinstalled RC1 and everything is back to normal.

Posts: 146
Joined: Tue Sep 11, 2007 10:47 am

Post by TwiztidSinz » Fri Nov 16, 2007 3:22 pm

I had a similar problem (an 'extra' Mediamonkey.exe using 50% CPU, which was actually the previous instance of MM still running) that has gone away.
I kind of narrowed it down to "frequent" opening and closing of MM3 and other media players, sometimes having two open at a time. e.g. pausing MM3 then playing a video with Media Player Classic and closing MM3 while the vid was playing and song still paused, or sometimes (though much less rarely) from opening and closing MM a few times over an hour or so.
This was under Vista, so that plus the paused song plus the playing video while closing MM3 might have been the cause, though I haven't had this issue at all since before RC1.

Maybe this is completely unrelated to your issue, or maybe you're doing something similar to what I was doing.
Not sure if you're on XP or Vista or if the OS has/had anything to do with my problem or not, but it could be related to the OS so providing that info might help in narrowing down the problem.
Motherboard: Intel D915PBL
Processor: Intel Pentium 4 550 Prescott 3.4GHz LGA 775 (w/ Hyper-Threading)
Memory: Corsair 2048MB (512x4) DDR2 533 (PC2 4200) Dual Channel
Hard Drive: Western Digital WD800JD 80 GB / WD2500JS 250 GB / WD2500KS 250 GB
Video Card: Sapphire RADEON X1600 XT 256MB 128-bit GDDR3 PCI Express x16

Post Reply