RC2/3 - Freeze with large autoplaylist [F4041 RC4]

Beta Testing for Windows Products and plugins

Moderator: Gurus

nduke
Posts: 55
Joined: Sat Jul 09, 2005 7:29 am
Location: Marietta, GA

RC2/3 - Freeze with large autoplaylist [F4041 RC4]

Post by nduke » Tue Nov 27, 2007 1:53 pm

I previously posted about this issue when RC2 first came out. I'm having the same problem with RC3. Reinstalling RC1 eliminates the issue.

I have an autoplaylist that essentially consolidates other playlists (both static and auto playlists) into one by using the criteria Playlist is... I also have it set up to order by Random. The total number of tracks is usually around 3000.

In RC1 and before I would click on the autoplaylist in the tree and within 3-5 seconds the list would appear. When I installed RC2 and clicked on the playlist my CPU would jump to 100% and stay there. Debug View would also stop listing any events until I forced MM to quit.

I reinstalled RC1 over RC2 and the problem disappeared.

When I installed RC3 and clicked on the autoplaylist the CPU jumped to around 100% again. With this release I do get messages in Debug View. Mostly thread started/finished messages. This goes on until I force MM to quit. My record so far is 24 minutes before quiting.

To try and rule out corrupt files or database I have uninstalled a few times and even deleted the database to start fresh a couple of times (that's a nightmare!).

I'll email support with my debug log, but any help would be appreciated!

Ludek
Posts: 3074
Joined: Fri Mar 09, 2007 9:00 am

Post by Ludek » Wed Nov 28, 2007 6:21 am

Thanks to your debug log I found the regression, reproduced and have fixed it. It is fixed in RC4. Thank you.

Post Reply